1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

L4D2 doesn't work on my computer

Discussion in 'Sager and Clevo' started by Damonkashu, Feb 11, 2010.

Thread Status:
Not open for further replies.
  1. Damonkashu

    Damonkashu Notebook Consultant

    Reputations:
    0
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    30
    I've got a sager 8662, 4 GB of RAM, running windows 7 64-bit, and every other game I join, it will crash in an audio looping crash once the game starts.

    Anyone else try to play Left 4 Dead 2 and experience this sort of problem? Valve support is not helping me at all
     
  2. Magical_Unicorn

    Magical_Unicorn Notebook Enthusiast

    Reputations:
    31
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Sounds like you should try updating your drivers. What version are you currently running?
     
  3. surfasb

    surfasb Titles Shmm-itles

    Reputations:
    2,637
    Messages:
    6,372
    Likes Received:
    0
    Trophy Points:
    205
    sounds like display drivers.
     
  4. tjp888

    tjp888 Notebook Guru

    Reputations:
    8
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    15
    I am running Win 64 bit also on my D900F. I had that audio looping problem when I first installed L4D. L4D2 has always run well. I'm trying to think how I fixed it...... I want to say it was the newer nVidia drivers, but I'm not sure.

    One trick I learned when trouble shooting games misbehaving is to take the game out of "full screen" mode and tell it to run in a window.
     
  5. Totemobakadesu123

    Totemobakadesu123 Notebook Geek

    Reputations:
    0
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    15
    I also have the same problem. I have the NP8662 with a Q9100, 260M.
    for some reason, It runs fine if I create the game on a local server. For all other games, I freeze at the beginning with a looping sound
     
  6. roymathieu

    roymathieu Notebook Consultant

    Reputations:
    153
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    30
    no problem with L4D2 here
     
  7. ccarollo

    ccarollo Notebook Consultant

    Reputations:
    42
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    30
    Might want to try right clicking on L4D2, then Properties, the Local Files tab, and Verify integrity of game cache. Or delete the local game content and download it fresh.
     
  8. Purlpo

    Purlpo Notebook Evangelist

    Reputations:
    8
    Messages:
    620
    Likes Received:
    0
    Trophy Points:
    30
    Try disabling multicore rendering in the options menu. Might work.
     
  9. Totemobakadesu123

    Totemobakadesu123 Notebook Geek

    Reputations:
    0
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    15
    I tried all those (disabling multicore, deleting the cache in the game, verifying integrity, etc) and I even did a clean install. There must be something else that is crashing it.
     
Thread Status:
Not open for further replies.

Share This Page