Killer Wireless-AC 1550 Review

Discussion in 'Networking and Wireless' started by Ultra Male, Mar 3, 2018.

  1. Lightning_-

    Lightning_- Notebook Guru

    Reputations:
    0
    Messages:
    59
    Likes Received:
    10
    Trophy Points:
    16
    Fixed it by updating to da latest drivers
     
    WhatsThePoint, Vasudev and jaybee83 like this.
  2. Falkentyne

    Falkentyne Notebook Prophet

    Reputations:
    5,929
    Messages:
    4,857
    Likes Received:
    6,555
    Trophy Points:
    581
    That's because it *IS* a Bios issue. If it happens without the killer drivers installed (basic windows drivers with the 1535 without Killer drivers)
    I don't have this issue on my GT73VR because MSI fixed it.
     
    Vasudev likes this.
  3. macmyc

    macmyc Notebook Consultant

    Reputations:
    92
    Messages:
    290
    Likes Received:
    219
    Trophy Points:
    56
    Yeah it happened also with windows drivers if i recall correctly.

    What should i do to get MSI to update the bios then?
     
    Vasudev likes this.
  4. Falkentyne

    Falkentyne Notebook Prophet

    Reputations:
    5,929
    Messages:
    4,857
    Likes Received:
    6,555
    Trophy Points:
    581
    What laptop is this?
    All you can do is call them on the phone and pray :(

    MSI even had a bug in the GT73VR where the PEG port would not be reactivated if you switched from dgpu to igpu and back to dgpu.
     
    Vasudev likes this.
  5. macmyc

    macmyc Notebook Consultant

    Reputations:
    92
    Messages:
    290
    Likes Received:
    219
    Trophy Points:
    56
    GT62VR 6RD, afaik even people with GS63 and GT72VR had this issue...
     
    Vasudev likes this.
  6. Falkentyne

    Falkentyne Notebook Prophet

    Reputations:
    5,929
    Messages:
    4,857
    Likes Received:
    6,555
    Trophy Points:
    581
    They probably stopped Bios updates for their older models. You need to ask them if they can fix the problem.
    The GT73VR originally had the same issue but one of the last few bios updates addressed this was written in the update notes).
     
    Vasudev likes this.
  7. macmyc

    macmyc Notebook Consultant

    Reputations:
    92
    Messages:
    290
    Likes Received:
    219
    Trophy Points:
    56
    Yeah i checked the bios changelogs for the GT73VR and they fixed it. I sent them a support request, hopefully they will do something about it.

    EDIT:

    This is their answer:

    This is disgusting. I'm gonna link them all the topics on their forum of people having this issue.
     
    Last edited: Oct 29, 2018
    Falkentyne and Vasudev like this.
  8. Ultra Male

    Ultra Male Super Tweaker

    Reputations:
    16,000
    Messages:
    18,206
    Likes Received:
    25,590
    Trophy Points:
    931
Loading...

Share This Page