Killer Wireless 1535 terrible signal range?

Discussion in 'Networking and Wireless' started by Terreos, Dec 28, 2017.

  1. Killer_Networking

    Killer_Networking Company Representative

    Reputations:
    205
    Messages:
    108
    Likes Received:
    217
    Trophy Points:
    56
    I will have to give these troubleshooting methods a shot, though only as a last ditch effort, as they may not be ideal.

    Changing the roaming aggressiveness will prevent the adapter from switching to a better network when one is present, which could be problematic for some users, especially those that use public Wi-Fi. Prefer 5 GHz could also be problematic for some, since 2.4 GHz can still often provide superior range, and "No Preference" should allow the adapter to choose the best available. It's strange that either would improve Wi-Fi signal.

    The disconnects from the Killer Control Center running at startup may be referring to older versions of the Killer Control Center? We had some similar issues in the past, but nothing reported like that recently.
     
    hmscott and Vasudev like this.
  2. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    2,344
    Messages:
    5,591
    Likes Received:
    3,423
    Trophy Points:
    431
    I never connect to Public Wifi, I carry a dongle always.
    Well I felt 5GHz band gave me superior speed and range when I'm away from the router, say 20-30 feet and I sit in a corner of a room.
    Only Killer was able to connect to 5GHz when iphone 7,s7, Intel cards suffered with stability issues and huge battery drain.
    If I'm in LoS and very far away from the router I manually connect to 2.4GHz.
    You can actually choose No preference for Band setting(like you suggested) since I only told OP who has dual band router and 5GHz will have very less traffic and interference from nearby routers in the vicinity.
    Only option that needs changing is Roaming Aggressiveness to Medium Low or lowest for better stability if you run into issues. Otherwise no need to fiddle Killer WIFI card settings.
    I noticed that KCC app on startup causes connection instability briefly upon starting W10. I didn't have the issue in 1.0.14xxx versions, the problem started in 1..0.15xx and above. Can you look into this?
    Thanks for your input.
     
  3. Killer_Networking

    Killer_Networking Company Representative

    Reputations:
    205
    Messages:
    108
    Likes Received:
    217
    Trophy Points:
    56
    Definitely! So as not to hijack this thread, though, can you try doing a completely uninstall and reinstall (which would be my first suggestion) with this guide - http://killernetworking.com/driver-downloads/kb/faq/58-clean-install-any-driver - and then contact me at killersupport@rivetnetworks.com so that we can look into instability, if you're still seeing it after the uninstall/reinstall?

    -- Anthony with Killer Networking
     
    Papusan, Vasudev and hmscott like this.
  4. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    2,344
    Messages:
    5,591
    Likes Received:
    3,423
    Trophy Points:
    431
    Thanks.
    I always do a complete uninstall using Revo followed by a reboot. Afterwards I use CCleaner to delete obsolete reg keys and install the new driver package from Killer which is MD5 hash verified.
    Maybe I'll try adding KCC to startup & see if there's any issue. I removed the startup delay of Win10 using regkeys from Winaero. If the issue persists I'll drop a email to your official email.
     
  5. tps3443

    tps3443 Notebook Consultant

    Reputations:
    37
    Messages:
    287
    Likes Received:
    108
    Trophy Points:
    56

    This has fixed my issue! Thank you!

    I’ve got Killer 1535, and during a amazing BF1 game online, it would randomly drop the connection to the server. I’d probably be a level 30 by now if it wasn’t for being kicked out of servers, or dropped connection.

    My latency is less than 20ms, and my internet a lot faster than the average joe.

    I’ve been dealing with Killer issues, and dropped connection for to long now.

    And it’s finally gone!
     
  6. Vasudev

    Vasudev Notebook Prophet

    Reputations:
    2,344
    Messages:
    5,591
    Likes Received:
    3,423
    Trophy Points:
    431
    Its good to hear that. @judal57 suggested me this.
    Newest drivers needs minimal tweaking at all. Usually setting Roaming aggressiveness to Lowest fixes most issues.
     
    Papusan likes this.
Loading...

Share This Page