killer wifi problems

Discussion in 'Networking and Wireless' started by mtness, Dec 30, 2017.

  1. mtness

    mtness loitering

    Reputations:
    367
    Messages:
    1,841
    Likes Received:
    111
    Trophy Points:
    81
    over the past month or so i have been experiencing increasingly frustrating issues with my network adaptor, (killer wireless-n/a/ac 1535 wireless network adaptor) when ever i game it doesn't matter if its a demanding game or not the network card disables itself, simply turns itself off completely, it does not restart i have to manually open network and sharing centre and reactivate the device.

    i have done the only obvious thing i can think of, going into device manager and unchecking "allow the computer to turn off this device to save power" but this has had no effect on the problem.

    the temps of the notebook are all great, its had a recent re-thermal pasting, and gpu sits in the 80s while heavy gaming and cpu hits mid 70's.
    I'm not sure why it is happening and really hoping you all can help in some way
     
  2. Jdpurvis

    Jdpurvis Notebook Evangelist

    Reputations:
    58
    Messages:
    314
    Likes Received:
    57
    Trophy Points:
    41
    You might check under power settings, Advanced options, to be sure that the option to use power saving for the Wifi is not enabled. Changing the setting in Device Manager, as you have done, should be enough, but sometimes there are little inconsistencies in Win10. You might also see about updating the Wifi drivers from Killer. Also, they noted that allowing the Killer Control Center to start at bootup has been known to cause issues with the Win driver, so it might be better to start it manually after boot - or not at all - some feel it is best to just use the driver and not the control center.
    Hope this helps,

    Joe
     
    Vasudev likes this.
  3. mtness

    mtness loitering

    Reputations:
    367
    Messages:
    1,841
    Likes Received:
    111
    Trophy Points:
    81
    thanks Joe

    under power settings/advanced options my network settings are set to "high performance" i cant see an option at all to power save, so i guess thats ok, i have tried various drivers from the latest to rolling back to much earlier ones to try and fix the issue, i don't have killer control centre on my laptop so i will download and install that now and see if it makes any difference.
     
  4. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    3,920
    Messages:
    7,033
    Likes Received:
    4,687
    Trophy Points:
    431
    Papusan likes this.
  5. mtness

    mtness loitering

    Reputations:
    367
    Messages:
    1,841
    Likes Received:
    111
    Trophy Points:
    81
    ok ill test with the killer control centre tomorrow and see if that effects anything if not i will change those settings you recommended, thanks for the reply.
     
    Vasudev likes this.
  6. mtness

    mtness loitering

    Reputations:
    367
    Messages:
    1,841
    Likes Received:
    111
    Trophy Points:
    81
    i have been testing the suggestions you all made, namely the killer control centre and setting changes Vasudev recommended and using both it seems to be better, played through some multiplayer games and didn't have one disconnect....ill keep testing over coming days as time permits.

    cheers guys
     
    hmscott, Vasudev and Papusan like this.
  7. mtness

    mtness loitering

    Reputations:
    367
    Messages:
    1,841
    Likes Received:
    111
    Trophy Points:
    81
    unfortunately on playing for a longer period today, just over one hour the network adaptor has once again turned itself off, requiring me to "trouble shoot" to turn it back on again, currently i have both killer control centre and the settings recommended by Vasudev in use, not sure where to go from here tbh. :(

    please note that i was trying GTA V in single player story, when i quit the game and the game tried to cloud-sync it failed as at some point during the game session the adaptor turned off, cant specify exactly when it happened though.
     
    Vasudev likes this.
  8. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    3,920
    Messages:
    7,033
    Likes Received:
    4,687
    Trophy Points:
    431
    Do you have a picture of WLAN card and SSD's location. I think your card disabled itself because of overheating.
     
    hmscott likes this.
  9. mtness

    mtness loitering

    Reputations:
    367
    Messages:
    1,841
    Likes Received:
    111
    Trophy Points:
    81
    as far as a can remember the ssd drives are under the palm rests and the WLAN card is under the keyboard around about the up/down/left/right location, the cpu and the gpu are at the very back of the laptop under where the screen area.
    https://imgur.com/a/aoJAD thats a image of the temps of the cpu/gpu under heavy load over 1hr+ gaming, also with tv turned, and that's the hottest ive seen the cpus get we are in summer here and it has been in the high 30's Celsius today, around 97F

    please also note that this time playing both GTA V and the division for well over an hour the network card didn't turn it self off, it seems to be very erratic now rather than every time.
     
    Last edited: Jan 4, 2018
    Vasudev likes this.
  10. Killer_Networking

    Killer_Networking Company Representative

    Reputations:
    206
    Messages:
    115
    Likes Received:
    224
    Trophy Points:
    56
    Hello mtness,

    There are a few things that can cause your Wi-Fi adapter to disable itself, but unfortunately they don't really make themselves known up front. Here is what I would try to correct the issue.

    • Update your machine's BIOS, if an update is available, from your machine or mainboard manufacturer.
    • Update your machine's chipset driver from your machine or mainboard manufacturer.
    • Update your Wireless Access Point's firmware. If the access point is a Wi-Fi modem that is owned by your ISP, you'll have to contact them and have them update the firmware for you. Old firmware can cause this issue as the adapter will disable itself if it receives a large number of bad frames from the access point.
    • Update to the latest Killer Control Center available from our website - http://killernetworking.com/driver-downloads/item/killer-control-center-x64 - though it sounds like you may have done that already.
    • Completely uninstall and reinstall your suite and drivers, using this guide - http://killernetworking.com/driver-downloads/kb/faq/58-clean-install-any-driver - which will ensure that Windows is using only the latest driver files for the Wi-Fi adapter.
    • Change your Wi-Fi power settings using this guide - http://killernetworking.com/driver-downloads/kb/faq/59-wi-fi-power-settings. I know some power settings were mentioned above, but some may have been missed.
    • Use the built-in Network Reset. You can do this by clicking Start and typing Network Reset. You may have to reinstall any VPN adapters, and re-input any Wi-Fi or VPN passwords after using the Network Reset. You may also need to reinstall the network adapter drivers.
    If none of the above solves the issue, please contact me directly at killersupport@rivetnetworks.com so I can get a diagnostic from you using the Killer Control Center. That will allow me to see a bit more about your system, and make sure everything is as it should be, and maybe see if there is anything anomalous.

    -- Anthony with Killer Networking
     
    hmscott, Papusan and Vasudev like this.
Loading...

Share This Page