1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Keyboard Beep Playing Games

Discussion in 'Asus' started by BeefyBeefo, Aug 13, 2009.

Thread Status:
Not open for further replies.
  1. BeefyBeefo

    BeefyBeefo Notebook Consultant

    Messages:
    169
    Likes Received:
    0
    Trophy Points:
    30
    So, this will continue to happen even though I have disabled hot keys?
     
  2. mk1freak

    mk1freak Notebook Evangelist

    Messages:
    346
    Likes Received:
    0
    Trophy Points:
    30
    YES I remember now u need to disable the second language, it basically changes your keyboard layout making it essentially useless during gaming, hence the beeps
    I was thinking it had to do with txt input, which was the case once the hotkeys changed the
    language for your keyboard.
    I'll confirm for you exactly once I get home from grocery shopping.
    In the meantime go into the languages section of control panel and try disabling any extra languages you have installed, or disabling the default hotkey to switch language
     
  3. BeefyBeefo

    BeefyBeefo Notebook Consultant

    Messages:
    169
    Likes Received:
    0
    Trophy Points:
    30
    Excellent, thanks!

    I was trying to figure out where these settings could have been. I disabled the other languages as well as all key sequences in the control panel. The icons no longer come up on the taskbar when I press Control + Space together. I will probably be playing a little more tonight and I will let you know if the beeping has stopped. Thanks again for all your input. :D
     
  4. Chronus

    Chronus Notebook Geek

    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    15
    yeah i thought it may have been that lol -.-; i remember times when doing cs source and the buy menu wouldnt work, was due to foreign language being inputted
     
  5. BeefyBeefo

    BeefyBeefo Notebook Consultant

    Messages:
    169
    Likes Received:
    0
    Trophy Points:
    30
    I'm played twice since disabling the languages and it hasn't happened since. I'm guessing that was it. :D

    If if starts happening again, I will update this thread.

    Otherwise, thanks a lot for the input! :D
     
  6. mk1freak

    mk1freak Notebook Evangelist

    Messages:
    346
    Likes Received:
    0
    Trophy Points:
    30
    im glad you got the problem fixed! dam this forum is great!
     
  7. pet0sh

    pet0sh Notebook Enthusiast

    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    15
    Wish i had seen this thread earlier. It's a somewhat common problem on asus laptops. glad you figured it out yourself.
     
  8. fud

    fud Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Had the same problem with my new Asus computer.

    When I play any FPS game, my laptop would beep every time I pressed a button and it would lag the whole computer to sh!t. Holding the any button down would make it beep consistently. Disabling the second language hotkeys also fixed this problem for me.

    Thanks for the thread.
     
  9. user736176

    user736176 Notebook Enthusiast

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    15
    awesome. i have been trying to google this issue as well. when i play left 4 dead 2, sometimes i crouch and jump with ctrl+space and itll beep or change my language. i can usually fix it by pressing ctrl+space again but its still annoying none the less. thank you for the fix. ill have to try it when i get home later!
     
  10. bigsippycup@gmail.co

    bigsippycup@gmail.co Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    THIS was what my problem was with running Wolf:ET & other FPSs that use shift+alt on my new ASUS G73... I disabled stickykeys and togglekeys, but there's a default language-changer hotkey on my copy of Windows 7. NOT ANYMORE! No more beeps! Nice catch guys!
     
Thread Status:
Not open for further replies.

Share This Page