keyboard backlight control on clevo P775DM3(-G)

Discussion in 'Linux Compatibility and Software' started by giostark, Jan 22, 2018.

  1. giostark

    giostark Notebook Enthusiast

    Reputations:
    5
    Messages:
    22
    Likes Received:
    20
    Trophy Points:
    6
    Hi there ,
    Im trying to figure out how to make it work under my Arch linux (last build).
    https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi
    The Arch proper modules didnt work . Also the last provided by tuxedo seems not work. Any of you , maybe , succeeded to make it work?
    Unfortunately when i type "dmesg | grep clevo" no model is displayed.
    As reported my model should be compatible :
    P775DM3(-G) Clevo P775DM3(-G) TUXEDO XUX707
    But my brand is Santech so i didnt know if some small customization can make the difference for the final building.
    I reported the request for add my model but unfortunately still nothing happens.
    https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi/issues/33/p7xxdm3-g-clevo-p775dm3-model-support
    Tnx anyway.
     
  2. giostark

    giostark Notebook Enthusiast

    Reputations:
    5
    Messages:
    22
    Likes Received:
    20
    Trophy Points:
    6
    Hi there,
    I finally figured out how to make this work:
    Finally... thanks to the community. Im using arch so having problems compiling from the source here provided https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi/overview I managed doing so:
    Installing the module and the utility provided on Aur.
    https://aur.archlinux.org/packages/clevo-xsm-wmi-dkms/
    https://aur.archlinux.org/packages/clevo-xsm-wmi-util/
    Then I downloaded the source from here and uncompressed the tuxedoxxx.zip and modified as follow. I found that the description of my model in dmidecode have a "dash - " before the "parenthesis ( " and not after as stated in the clevo-xsm-wmi.c file.
    So as suggested by devstructor devstructor here : https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi/issues/41/pa71hp6-not-working I added the following lines between the model listed near the end of the file.
    Code:
    {
           .ident = "Clevo P7xxDM3-(G)",
            .matches = {
                DMI_MATCH(DMI_PRODUCT_NAME, "P7xxDM3-(G)"),
            },
            .callback = clevo_xsm_dmi_matched,
            .driver_data = &kb_full_color_ops,
        },
    
    After this i changed always in the same file clevo-xsm-wmi.c this as suggested by bolog here https://bitbucket.org/tuxedocomputers/clevo-xsm-wmi/issues/20/sager-np8174-not-working :
    Code:
    CLEVO_XSM_DEBUG("%0#4x  IN : %0#6x\n", method_id, arg);
    
    status = wmi_evaluate_method(CLEVO_GET_GUID, 0x01,
       method_id, &in, &out);
    
    changed to:
    Code:
    CLEVO_XSM_DEBUG("%0#4x  IN : %0#6x\n", method_id, arg);
    
    status = wmi_evaluate_method(CLEVO_GET_GUID, 0x00,
       method_id, &in, &out);
    
    After those small modifications I copied the modified module substituting the module provided in Aur: sudo cp clevo-xsm-wmi.ko /lib/modules/$(uname -r)/kernel/drivers/input/keyboard/clevo-xsm-wmi.ko

    Now the back light work.
     
Loading...

Share This Page