I've bought another 'broken' Alienware - M17x R4

Discussion in 'Alienware 17 and M17x' started by Maxware79, Nov 24, 2019.

  1. Maxware79

    Maxware79 Notebook Evangelist

    Reputations:
    60
    Messages:
    392
    Likes Received:
    279
    Trophy Points:
    76
    So I have another 'broken' Alienware on its way. This time it's an M17x R4.
    It was listed as only posting to an external monitor and the pic of the BIOS says Internal Graphics Not Detected. I'm assuming two are linked.
    There wasn't a lot of extra info but the BIOS pic shows it has a 3630QM, ATI GPU (7970M probably..), no HDD, 1gb RAM.
    It doesn't look like they looked after it very well but a new paint job and lid is on the cards if I can get it running properly.
     
  2. kingofswag187

    kingofswag187 Notebook Deity

    Reputations:
    323
    Messages:
    1,939
    Likes Received:
    769
    Trophy Points:
    131
    Card is likely dead, all of them die pretty fast, the ones that do last are few and far apart. I'd just take out the card and see if that fixes the internal screen, and if not, maybe look into a replacement.
     
  3. Maxware79

    Maxware79 Notebook Evangelist

    Reputations:
    60
    Messages:
    392
    Likes Received:
    279
    Trophy Points:
    76
    I have 0 experience with AMD cards. Do they use switchable graphics? I have an M290X from the 17 that blew up so I can slip that one in and see how it goes.
    I've also read that it could be an issue with the CPU's onboard graphics. Since the BIOS is showing the ATI card but no IG, I was leaning towards the CPU but if it doesn't have switchable graphics then the GPU is probably the cause.
    I should have it by Thursday
     
  4. kingofswag187

    kingofswag187 Notebook Deity

    Reputations:
    323
    Messages:
    1,939
    Likes Received:
    769
    Trophy Points:
    131
    AMD cards can use switchable graphics (Enduro) or PEG.
     
  5. Maxware79

    Maxware79 Notebook Evangelist

    Reputations:
    60
    Messages:
    392
    Likes Received:
    279
    Trophy Points:
    76
    I just hope the mother board doesn't catch fire like my last project. Fingers crossed it comes today instead of tomorrow. The eBay seller seemed a little sketchy so hopefully it's not an empty box.
     
  6. Maxware79

    Maxware79 Notebook Evangelist

    Reputations:
    60
    Messages:
    392
    Likes Received:
    279
    Trophy Points:
    76
    Got the R4 today. Man someone has butchered this poor thing. Random screws in all the wrong places and a lot missing.
    I pulled the 7970M (which was roaring hot) but still no display. I put an old SSD in with Win10 and it booted fine to an external monitor. Couldn’t get it to go to BIOS though.
    Pulled the keyboard off and found someone has been messing with the display connector. Looks like they tried stripping the cable skin off an inch or so.
    [​IMG]
    My Ranger main connector fits but not the secondary mobo connector so I didn’t try it.
    Still haven’t pinpointed the issue.


    Sent from my iPhone using Tapatalk
     
  7. Maxware79

    Maxware79 Notebook Evangelist

    Reputations:
    60
    Messages:
    392
    Likes Received:
    279
    Trophy Points:
    76
    Also, on shutdown the LCD shows some sign of life but it isn’t pretty.
    [​IMG]


    Sent from my iPhone using Tapatalk
     
  8. Maxware79

    Maxware79 Notebook Evangelist

    Reputations:
    60
    Messages:
    392
    Likes Received:
    279
    Trophy Points:
    76
    Just a standard Thursday night with laptop parts sprawled everywhere.
    [​IMG]


    Sent from my iPhone using Tapatalk
     
    ssj92 and MagicMike like this.
  9. Maxware79

    Maxware79 Notebook Evangelist

    Reputations:
    60
    Messages:
    392
    Likes Received:
    279
    Trophy Points:
    76
    So I’m leaning to a motherboard fault. I pulled the 7970M and swapped the CPU out for a 3920XM. Still no display on the LCD. I guess it could still be the LCD or LCD cable but I’m guessing it’s the board.
    If the R3 and R4 displays are compatible then I just have to wait for the wife to go out for a little while so I can test her display without her finding out that I’m still buying broken machines.



    Sent from my iPhone using Tapatalk
     
  10. Maxware79

    Maxware79 Notebook Evangelist

    Reputations:
    60
    Messages:
    392
    Likes Received:
    279
    Trophy Points:
    76
    Update. I tried the display from my M17x R3 but still no good. I reset the BIOS and the intel graphics are now detected along with the 7970M.
    I’ve just done a pre-boot diagnostic and the CPU fan failed the test but I can’t see how that would affect the display

    Edit: the fan failed the test because I forgot to plug the stupid thing back in after swapping CPU’s.

    Sent from my iPhone using Tapatalk
     
Loading...

Share This Page