Issue with Intel i7-7700HQ: Turbo Boost causes reboots or freezes

Discussion in '2015+ Alienware 13 / 15 / 17' started by krillin, May 23, 2019.

  1. krillin

    krillin Notebook Guru

    Reputations:
    0
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    15
    Hello All,
    I've been experiencing this issue with my 13 R3 for the past month or so with little success in figuring out how to resolve it. At this point I'm leaning towards faulty hardware; either motherboard or CPU, but I wanted to get a second opinion or see if anyone else has seen anything similar.

    I'll try to keep this as short and simple as possible. So here it is...

    My PC reboots or freezes (black screen) when I adjust my Max Processor State to anything above 98%.

    The clock speed of the CPU currently maxes out at 2695MHz at this percentage.
    If I attempt to increase to 99% or 100%, it will either reboot or freeze. This can happen immediately or shortly after.

    These are the things that I have tried:

    - Switched BIOS to several older versions, and back to the latest (also shorting the CLR pins under the RAM slot to clear CMOS settings).

    - Tested with and without Max CPU/Fan Performance

    - Turning off Intel Speedstep in the BIOS, but just caps the CPU speed at 800Mhz no matter what, which in turn will run without issues but just noticeably slower.

    - I repasted with MX-4 first, and then with Thermal Grizzly Kryonaut. Both with same results. I confirmed this is not happening due to overheating, as my idle temps were/are 44-46C seconds before switching processor state above 98%

    - Reinstalled Windows 10 just for the heck of it.

    - Swapped out with new RAM testing each slot individually and paired.

    - Undervolted -0.100v using XTU in an attempt to lower temps, when I thought it could have been temp related.

    - Tested 3 different AC adapters (x2 180W and 240W). Thought it could have been battery related so I unplugged the battery from the laptop and ran with AC power only.

    One thing I also wanted to mention is that I do not believe this is software/driver related. When I reinstalled Windows 10, it kept freezing at the beginning of the setup. I had to turn off Intel Speedstep to force it to run at 800MHz so I could complete the installation.
    Also, switching from 96% to 98% in Windows doesn't affect the clock speed.

    I am not sure what else I could test past this.
    This just happened out of the blue and my laptop doesn't really leave my desk.

    Any comments are welcomed. Thanks All!
     
  2. propeldragon

    propeldragon Notebook Evangelist

    Reputations:
    122
    Messages:
    536
    Likes Received:
    365
    Trophy Points:
    76
    What's event viewer and reliability monitor giving you?
     
  3. krillin

    krillin Notebook Guru

    Reputations:
    0
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    15
    Hi propeldragon,

    The only thing I am really seeing in the Event Viewer in relation to the CPU is an Event 37 (ex. The speed of processor 3 in group 0 is being limited by system firmware. The processor has been in this reduced performance state for 86400 seconds since the last report.) I read somewhere that this message is related to Intel Speedstep and is considered a normal in Windows 10.

    In Reliability Monitor I am only really seeing errors that "Windows was not properly shut down". I am assuming because of the forced shutdown.

    I'm about to head to bed since I have an early morning so I might not respond for the rest of the evening. Thanks for the response though!
     
  4. redsfan7035

    redsfan7035 Notebook Geek

    Reputations:
    12
    Messages:
    95
    Likes Received:
    21
    Trophy Points:
    16
    Curious if you tried using JUST the battery and putting max cpu to 100 for battery?

    Most definitely a cpu/motherboard defect. You went through quite exhaustive troubleshooting, definitely applaud your effort and persistence.
     
    propeldragon likes this.
  5. propeldragon

    propeldragon Notebook Evangelist

    Reputations:
    122
    Messages:
    536
    Likes Received:
    365
    Trophy Points:
    76
    Yeah sounds faulty to me unless some how the undervolt is sticking, xtu can get goofy.

    If you're running stock volts. 7700hq should be hitting 1.1v.
     
  6. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,148
    Messages:
    10,315
    Likes Received:
    7,583
    Trophy Points:
    931
    Is the BIOS updated to latest version that fixes Meltdown and Spectre? If so, there is some known issues when the CPU is under max load so I recommend using Inspectre to disable Spectre protection as a test measure and see if it fixes the issue. Do note that disabling the protection increases the risk but I have been running it on for the past 6 months w/o any issues.
    If you're on W10 v1809 then I think Retpo patch is partially applied to mitigate that issue.
     
    c69k likes this.
  7. krillin

    krillin Notebook Guru

    Reputations:
    0
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    15
    Hey redsfan7035,

    Yeah, I tried running with battery only (sorry I forgot to include this) and I also get the same results.
    Thanks for the kinds words. It's definitely been an exhausting experience so far. I'm pretty much at the point where I want to put this to rest and just accept running at ~2.7GHz...

    Hey propeldragon,

    Whether it is running on stock voltage or not, the outcome doesn't change. I don't recall off the top of my head what it is hitting but I'll check when I get back home from work. Thanks!

    Hi Vasudev,

    I believe I am currently running the latest BIOS version, 1.7. However I also tested with 1.2.3 (oldest I was able to go) and versions in between and still get the same results. Inspectre wouldn't apply to me in this particular case, would it? Thanks!
     
    Last edited by a moderator: May 23, 2019
  8. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    7,148
    Messages:
    10,315
    Likes Received:
    7,583
    Trophy Points:
    931
    You can certainly try it. You can enable/disable spectre protection using inspectre with just a click. Make sure you open it as admin.
     
    c69k likes this.
  9. krillin

    krillin Notebook Guru

    Reputations:
    0
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    15
    I'll give it a go when I get home later this evening. Thanks!
     
  10. propeldragon

    propeldragon Notebook Evangelist

    Reputations:
    122
    Messages:
    536
    Likes Received:
    365
    Trophy Points:
    76
    Also try to up the voltage and see if that fixes it.
     
    Vasudev and c69k like this.
Loading...

Share This Page