Interesting observation regarding keyboard issues - Aero 15x

Discussion in 'Gigabyte and Aorus' started by rooney111, Feb 10, 2019.

  1. rooney111

    rooney111 Notebook Enthusiast

    Reputations:
    0
    Messages:
    39
    Likes Received:
    2
    Trophy Points:
    16
    So I have a near perfect problem free Aero 15x.
    Only issue is there are two keys with double entry/double keystroke issue.
    Most threads say that 3.0.8 firmware update fixed it and if it didn't fix, then it is a hardware issue. So I was just about to RMA it. I'm on latest FW and reinstalled fw twice, but no luck.

    Today while at work, I had the laptop connected to a bluetooth Logitech keyboard. I STILL have the same double keystroke issue with the same keys! On a whole different keyboard.

    Doesn't this mean the issue is software related and not hardware related!?
     
  2. rooney111

    rooney111 Notebook Enthusiast

    Reputations:
    0
    Messages:
    39
    Likes Received:
    2
    Trophy Points:
    16
    Thoughts anyone? Just really looking for a reason not to send the laptop in as the ETA I was provided was over 4 weeks in my country. If the issue is software and not hardware related, am I right in assuming a fix *might* come in the future? My previous Aero 15 v7 had similar issue but was corrected by fw update but my new v8 15x didn't get fixed by the fw update.
     
  3. Ollie222

    Ollie222 Notebook Consultant

    Reputations:
    3
    Messages:
    176
    Likes Received:
    5
    Trophy Points:
    31
    If a separate bluetooth keyboard has the same issue then it's not going to be an actual keyboard hardware issue and suggests it's a software or firmware problem however it could still be a hardware issue with something other than the keyboard in the machine.

    Why not make a Windows usb recovery drive and boot to the command prompt from it or use a linux boot usb and then see if the keyboard still has the same problems.

    Do you have the same issue with a usb plug in keyboard?
     
  4. rooney111

    rooney111 Notebook Enthusiast

    Reputations:
    0
    Messages:
    39
    Likes Received:
    2
    Trophy Points:
    16
    So I confirmed it was not hardware related when I booted from Linux the issue wasn't there.
    This prompted me to do a clean W10 install and the issue has gone! Should have done windows reinstall a lot earlier!
     
  5. Ollie222

    Ollie222 Notebook Consultant

    Reputations:
    3
    Messages:
    176
    Likes Received:
    5
    Trophy Points:
    31
    What an odd problem but I'm glad you've got it sorted.
     

Share This Page