Intel WiFi Link 1000 B/G/N fix for being REALLY SLOW

Discussion in 'Dell XPS and Studio XPS' started by Kallzeh, Nov 16, 2011.

Thread Status:
Not open for further replies.
  1. Kallzeh

    Kallzeh Notebook Enthusiast

    Reputations:
    0
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    15
    Hey guys, a lot of people have been having issues with the XPS's standard Wifi card, the Intel WiFi Link 1000/ Intel Centrino 1000.

    I believe I have found a fix for it being extremely slow at times, I applied the fix a few hours back and have not had any problems since - I know a few hours isn't that long so I will update later with further results.

    Basically, some of you won't like this, but for those with broadband speeds of 50Mbps or less it shouldn't affect you so much.

    DISABLE WIRELESS N.

    To do this, go to 'Control Panel', 'Device Manager', Expand 'Network Adapters' then double click on 'Intel(R) WiFi Link 1000 BGN'.
    From here, select the 'Advanced' Tab and under 'Properties' click '802.11n Mode'.

    Change the value to 'Disabled', then click OK and close everything else.

    As I said this has worked for me and saved me from buying a new WiFi card and a lot of trouble, I apologize if it doesn't work for you.
     
  2. Jon vMagic

    Jon vMagic Notebook Consultant

    Reputations:
    101
    Messages:
    258
    Likes Received:
    0
    Trophy Points:
    30
    aye, did this a while back and does work - using an intel 1030 and also found that disabling bluetooth in device manager fixes slow speeds on wireless n while keeping my 50mb download

    now I just generally use an ethernet though
     
  3. Kallzeh

    Kallzeh Notebook Enthusiast

    Reputations:
    0
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    15
    That's good that it works for you too, After over 24 hours I have had no problems so am pretty pleased :)
     
  4. tonyr6

    tonyr6 Notebook Consultant

    Reputations:
    20
    Messages:
    148
    Likes Received:
    16
    Trophy Points:
    31
    Ethernet beats wifi any day. If I have a choice I always choose Ethernet. I only use wifi when I have no chose like the iPod touch.

    2.4 ghz should have never been the standard for wifi.
     
  5. Kallzeh

    Kallzeh Notebook Enthusiast

    Reputations:
    0
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    15
    Yes Ethernet is better, but that isn't possible for some people.
     
  6. conscriptvirus

    conscriptvirus Notebook Evangelist

    Reputations:
    89
    Messages:
    336
    Likes Received:
    9
    Trophy Points:
    31
    unfortunately some of us don't have access to ethernet (in a college dorm) and they expect us to use wireless :(

    i'll try this even though i don't see the logic behind it. i've been getting high ping spikes and just random slowness, which can be really annoying during gaming. i hope there will be an alternative fix later..
     
  7. Falco152

    Falco152 Notebook Demon

    Reputations:
    442
    Messages:
    1,882
    Likes Received:
    75
    Trophy Points:
    66
    For your case, any fixes posted, it's going to be highly unlikely will work for you.

    Quite possible that your campus wireless is configured to allow roaming ie as in you can pretty much constantly move around campus while retaining your connection. Their hardware have special scheduler on how data get passed in such a way that you always be connected to the best least used access point at any time at a cost of very little delay and continuously repeats at random intervals.

    However, this delay can screw with games that are asynchronous but require data to be in order like most FPS games.

    You could try significantly reducing the strength of your wireless in order to fall in smaller set of access points, to reduce the frequency of switching with a smaller set. But if you managed to connect to a congested access point, don't be surprised if you get simply dropped.
     
  8. Vipervlv

    Vipervlv Notebook Enthusiast

    Reputations:
    18
    Messages:
    39
    Likes Received:
    2
    Trophy Points:
    16
    Yesterday i had a strugle with the router and the centrino 1030 and found that if the router security is set to WPA2 -AES and the bluetooth disable the speeds is great, as it connects at N ( the router is Edimax 6424 v2). The centrino connected at 150MBps.
     
  9. Tusin

    Tusin Notebook Evangelist

    Reputations:
    72
    Messages:
    696
    Likes Received:
    0
    Trophy Points:
    30
    I know this is OT. But why not spend a few dollars and get a 5300/6300 or similar?
     
  10. Tsunade_Hime

    Tsunade_Hime such bacon. wow

    Reputations:
    5,413
    Messages:
    10,722
    Likes Received:
    1,203
    Trophy Points:
    581
    Because Intel WiFi Link 1000 is the base WLAN on alot of laptops now. Also for the price of the upgrade through Dell, (~40 for 6300) you can get an OEM one on Ebay for less. 5300/5100 are even less.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page