Intel Turbo Memory Controller: This Device Cannot Start (Code 10)

Discussion in 'Lenovo' started by thietlong, Oct 23, 2007.

Thread Status:
Not open for further replies.
  1. thietlong

    thietlong Notebook Consultant

    Reputations:
    3
    Joined:
    Sep 1, 2004
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    30
    Well, luck would have it that I check up on my device manager and to my dismay, the good old, yellow exclaimation pop up afront off Intel Turbo Memory Controller and double clicking on it get me:

    This device cannot start. (Code 10)

    Click 'Check for solutions' to send data about this device to Microsoft and to see if there is a solution available.

    I remember there was a thread on the board regarding this issues, but it didn't get much attention. Anyone know any solution to this issue. I upgrade to the latest driver from Microsoft (instead of the Lenovo one), reboot and the problem still persisted. Would greatly appreciate any input.
     
  2. MarkoD

    MarkoD Notebook Guru

    Reputations:
    6
    Joined:
    Aug 18, 2007
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    15
    Try the Intel drivers, here. Be sure to download the ones for your OS.
     
  3. bananaman

    bananaman Notebook Consultant

    Reputations:
    99
    Joined:
    Jul 16, 2007
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    30
    I think you meant to link to the Intel Turbo Memory drivers here :).
     
  4. MarkoD

    MarkoD Notebook Guru

    Reputations:
    6
    Joined:
    Aug 18, 2007
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    15
    Whoops, you're right...sorry :).
     
  5. michelkenny

    michelkenny Notebook Geek

    Reputations:
    0
    Joined:
    Aug 23, 2007
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    15
    In the BIOS, your SATA mode needs to be set to AHCI or else you get the error you're getting. What OS are you using? Did you do a clean install with the SATA mode as compatibility? If so, you'll probably have to reinstall when you switch to SATA since windows won't boot.
     
  6. bananaman

    bananaman Notebook Consultant

    Reputations:
    99
    Joined:
    Jul 16, 2007
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    30
    If by chance you are using Windows XP, you can get rid of the yellow exclamation pop-up by installing the Lenovo Intel Turbo Memory Windows XP Yellow Exclamation (!) Eliminator.

    Intel Turbo Memory only works with Vista, but if you have done an XP downgrade, or just configured your system with Turbo Memory for future use, this gets rid of that annoying little yellow triangle :rolleyes:.
     
  7. thietlong

    thietlong Notebook Consultant

    Reputations:
    3
    Joined:
    Sep 1, 2004
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    30
    I didn't check the bios when I did the clean install but I upgrade from Premium to Ultimate 64 so I didn't think the XP issue should be a problem here. If the system come with Premium, what usually is the pre-config mode, AHCI or Compatibility? I already downloaded and installed the latest driver from Intel but problem still persisted. Any additional inputs would greatly be appreciated. Thanks guys.
     
  8. thietlong

    thietlong Notebook Consultant

    Reputations:
    3
    Joined:
    Sep 1, 2004
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    30
    Ok, I just check my BIOS and it's already preset to AHCI mode. Now I am really puzzle as to what the problem would be since I already try to update the driver and there's also no XP involved; it's preset to AHCI mode. Really weird indeed.
     
  9. capt'nrob

    capt'nrob Newbie

    Reputations:
    0
    Joined:
    Oct 25, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    After having the same problem, I added one step and upgraded the bios to the most recent release version 1.26 for the Vista 32bit T61 Lenovo. Then reset the SATA controller mode option to AHCI. After rebooting, the Intel Turbo Mode Console was now activate (previously not); and both Windows Ready Boost and Windows Ready/Drive were enabled (previously disabled). Total associated cache is 1 GB. On the same page, the Intel Flash Cache Logic Chip shows as a subset (subdirectory) of the Turbo Memory Controller. In Device Manager, the yellow exclamation disappeared as did the Code 10 warning. All is well.
     
  10. thietlong

    thietlong Notebook Consultant

    Reputations:
    3
    Joined:
    Sep 1, 2004
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    30
    So did you have to change your BIOS to Compatibility first before you reset it to AHCI or can you just leave the BIOS as is then update the BIOS.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page