Intel Turbo Boost not showing?

Discussion in 'Windows OS and Software' started by Trance003, Jan 6, 2012.

Thread Status:
Not open for further replies.
  1. Trance003

    Trance003 Notebook Enthusiast

    Reputations:
    68
    Messages:
    44
    Likes Received:
    13
    Trophy Points:
    16
    Hello there everyone. Firstly, thanks for checking out my thread.

    Okay, down to the problem. As far as i'm concerned, every system that has intel turbo boost technology will have that gadget running on the desktop. In my case, i'm not sure whether it is enabled or not. I did check the BIOS on the boot menu and it showed that it is enabled but there is no sign of the gadget running on the desktop. I'm not even sure whether it is operating when i'm using my laptop. Any suggestions and/or thoughts?

    For reference, my specs are:
    Processor: i7 2860QM 3.6GHz
    GPU: NVIDIA 580M SLI
    RAM: 16GB 1866MHz
    Hard Drive: 1TB Hybrid RAID0 Bluray
     
  2. miner

    miner Notebook Nobel Laureate

    Reputations:
    1,326
    Messages:
    7,143
    Likes Received:
    0
    Trophy Points:
    205
  3. JKleiss

    JKleiss Notebook Evangelist

    Reputations:
    261
    Messages:
    674
    Likes Received:
    0
    Trophy Points:
    30
    You don't need the gadget running or even installed in order for the turbo boost to work, on that CPU in that system you have, trust me it will be running, unless you have disabled it in the BIOS yourself.
     
  4. Trance003

    Trance003 Notebook Enthusiast

    Reputations:
    68
    Messages:
    44
    Likes Received:
    13
    Trophy Points:
    16
    Thanks guys! That really gave me a relieve. Cheers!
     
Loading...
Thread Status:
Not open for further replies.

Share This Page