Intel-TongFang QC7 (Element/Fusion 15/MAG-15/Vapor 15 Pro)

Discussion in 'Other Manufacturers' started by B0B, Sep 2, 2019.

  1. tinytop69

    tinytop69 Notebook Consultant

    Reputations:
    105
    Messages:
    297
    Likes Received:
    5
    Trophy Points:
    31
    Thanks for the response. I tried to hook up an external monitor to the laptop to see if there was anything popping up there. Still nothing. Guess this is a return for me...
     
  2. eddi3x3x3

    eddi3x3x3 Notebook Evangelist

    Reputations:
    24
    Messages:
    416
    Likes Received:
    110
    Trophy Points:
    56
    Yea the mag 15 is way louder than the m15 on Max fans lol. In order for the mag 15 to match the fan sound of the m15, you have to put the fans to standard and even then the fan noise sounds a little more annoying than the m15

    Sent from my Moto Z (2) using Tapatalk

    To me it also seems like electroboost doesn't do much vs balanced mode unless you use the max fan option which is a little disappointing.

    Sent from my Moto Z (2) using Tapatalk

    Anyone here familiar with return policy of Amazon for this laptop? Like how many days I have to return it or if there is a fee for the return?

    Sent from my Moto Z (2) using Tapatalk
     
    Last edited by a moderator: Nov 10, 2019 at 11:00 AM
  3. tinytop69

    tinytop69 Notebook Consultant

    Reputations:
    105
    Messages:
    297
    Likes Received:
    5
    Trophy Points:
    31
    I should have an answer for you on tue/wed as I sent an email to eluktronics On how they would handle an amazon return

    amazon site says this however:
    Amazon.com Return Policy: You may return any new computer purchased from Amazon.com that is "dead on arrival," arrives in damaged condition, or is still in unopened boxes, for a full refund within 30 days of purchase. Amazon.com reserves the right to test "dead on arrival" returns and impose a customer fee equal to 15 percent of the product sales price if the customer misrepresents the condition of the product. Any returned computer that is damaged through customer misuse, is missing parts, or is in unsellable condition due to customer tampering will result in the customer being charged a higher restocking fee based on the condition of the product. Amazon.com will not accept returns of any desktop or notebook computer more than 30 days after you receive the shipment. New, used, and refurbished products purchased from Marketplace vendors are subject to the returns policy of the individual vendor
     
  4. eddi3x3x3

    eddi3x3x3 Notebook Evangelist

    Reputations:
    24
    Messages:
    416
    Likes Received:
    110
    Trophy Points:
    56
    Let me know because I don't want to get hit with a restock fee just for opening the box, I rather then just sell it to someone else possibly.... I'm still very much in the fence on whether I want to return it or not because it does FEEL really nice and light vs the m15 but the performance that I thought I was getting with electroboost just doesn't seem to be there.

    Even with Asus tweak to increase thermal limit, all that does is essentially enable the fans to ramp past standard and performance Max because according to Intel spec: "if gpu temps are past 75C, fans will ramp to Max" which defeats the purpose of setting the fan profile to standard in the control center.

    Really hoping community makes fan control app soon cause this feels like a good programmer laptop.

    Sent from my Moto Z (2) using Tapatalk

    @XMG @Eluktronics houston we have a problem, When I connect my Moto z2 force phone to the thunderbolt 3 connection in the back it claims the device is charging but my phone actually loses charge while connected... Something is not right with the thunderbolt software as it doesn't seem to be supplying enough power to fast charge my phone. Alienware m15 successfully charges phone quickly using the same usb type C to usb type C cable.

    Using latest version 58 bios from eluktronics (Public Release 11/6/2019)
    Using latest thunderbolt drivers from eluktronics 1.41.648.5

    Edit: I thought it was a nice touch to have the feature in control center for "Pulsate light bar when computer is asleep and plugged in" but could it be possible to have the light bar change color (from red to yellow to green) to show how much charge the battery has? Just something cool that would differentiate it.
     
    Last edited by a moderator: Nov 10, 2019 at 11:01 AM
  5. Randomisity

    Randomisity Notebook Enthusiast

    Reputations:
    0
    Messages:
    19
    Likes Received:
    1
    Trophy Points:
    6
    sorry was no help; yes there's usually no way to tell from looking what HDMI revision a cable is, which was why I thought it could possibly be the problem in the first place (cable looks ok and physically fits but doesn't support spec). I'm at a loss for this and I think unless XMG/Eluktronics/etc. actually respond, this forum might not be the right place (not *that* many people reading this). Have you tried other places (err, Reddit?). I myself have found that the machine doesn't even support ACPI power management events for opening the lid so was surprised that it has an effect on the display! (I wanted the machine to wake from sleep just by opening the lid, but that's apparently not possible because a "lid open event" isn't generated, only a "lid close").

    good luck man, reading what you posted, I can understand the frustration

    EDIT: wait, come to think about it, maybe there's something about the "lid close" event that can be modified/tweaked to solve your problem?

    further edit:

    what I mean is - I was complaining in an earlier post, about the machine not automatically waking from sleep when I open the lid, when the system was smart enough to go to sleep when I close the lid: apparently the reason for this disparity is that the hardware is set up to allow an ACPI "power event" for closing the lid (which you can configure in the power settings what behaviour you want, whether to sleep, hibernate, ignore etc.), BUT apparently there's NO corresponding "lid open" event. It's not clear to me at this point whether the hardware functionality to allow this is NOT available, or if it's just not implemented in software/drivers (I don't know enough about this to say). Your problem is that the behaviour of your machine when your lid is open/closed is not what you want. So I'm wondering it it's possible to, I dunno, disable things in the device manager such that the lid close/open is not detected at all (if the OS doesn't see it it can't react to it?), as a kind of quick-and-dirty workaround... though as I type this it seems to me something that needs to be implemented in the BIOS, in which case it's out of the end-user hands?
     
    Last edited: Nov 10, 2019 at 5:17 AM
  6. eddi3x3x3

    eddi3x3x3 Notebook Evangelist

    Reputations:
    24
    Messages:
    416
    Likes Received:
    110
    Trophy Points:
    56
    Anyone know how easy or hard it would be to replace the fans with another set of quieter fans on this unit?

    Sent from my Moto Z (2) using Tapatalk
     
  7. mkoev

    mkoev Notebook Enthusiast

    Reputations:
    0
    Messages:
    21
    Likes Received:
    4
    Trophy Points:
    6
    I've been thinking about the same, because I already saw a 1660ti unit in Europe.It looks and feels great...buuuut It's obnoxiously loud. I am one of those guys who's not the most... gentle when I speak so I'll just say it outright. No way I am paying a minumum of 1600 EURO for this unit only because it looks and feels really sleek. I had the chance to actually compare it head to head with my old DELL 7577 (i7 7700hq, GTX 1060 max-q) and for me there's very little difference other than the form factor. I am a casual gamer and I don't do any design so running Windows 10 feels the same. I HAVE to play games with headphones on because of the fans and that's something I don't want to do. OK, the display looks much better, but that's it. I don't play at ultra details so in this case the 1060 max-q and the 1660 TI don't differ too much. It don't care about keyboard leds, I am fine with just one color. The huge adapter actually "kills" the mobility of this unit and that was the final flaw which made me not to purchase it. A mobile laptop (although powerful) must be easy to carry around. Idle temperatures are definitely not much lower than those of my Dell (granted, I've followed B0Bs videos regarding that exact Dell model and my CPU never goes over 89 degrees C even after 2-3 hours of gaming at high details). Please don't understand me in a wrong manner, I am not trying to say "this laptop is not worth it, it's bad, lower it to 1000 euro and I'll buy it". Not at all, it's a great little machine, but it does not fit with my personnal preferences. I know we are at the beginning of its life cycle and it's too early to speak about a 2nd generation, but improving fan accoustings (temps are fine, I no longer care about the 75C cap, seems to be very well engineered) and lowering the size of the adapter will make this laptop a killer machine and dare I say.. a Razer killer :D Ah... and I see ppl really want per key programming for the leds so I guess that one too :D
     
    Last edited: Nov 11, 2019 at 2:03 AM
  8. garzillo

    garzillo Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    2
    Trophy Points:
    6
    Hi all! I've spent the past 48 hours of struggling with my Mag 15 and am hoping someone around these parts might know what's wrong.

    Problem:
    The 2070MQ is not working properly. As far as I can tell the drivers on the Eluktronics site are installed correctly, but the NVIDIA control panel refuses to open. I can definitely see the 2070MQ in things like the Device Manager and hwinfo, and once upon a time (before a clean windows install) it WAS working so I'm pretty sure it's not a hardware issue. I can kill the process and try to run it again, but then I get a "You are not currently using a display attached to an NVIDIA GPU" message.

    Stuff I've Tried
    1. Clean Windows install
    2. Installed all Eluktronics drivers in the order they're on the site (same as what XMG recommends), including the latest BIOS update (357.0056).
    3. Uninstall/reinstall of drivers using DDU with slight variations ad nauseum (436.30 provided by Eluktronics and XMG) and the latest 441.XX directly from NVIDIA.

    At this point I don't even know what to try. I originally tried a fresh Windows install because I was getting poor battery life (3-4 hours on battery saver just doing some web browsing), so it seems I traded one problem for another.
     
    Last edited: Nov 10, 2019 at 2:55 PM
  9. dmolnar123

    dmolnar123 Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    5
    Back to square one. I noticed that the battery after a few days started to drain quicker. I remembered that GeForce Experience was not installed, so I installed it, and it updated the graphics driver to the newest version. And the lag started again. Same as before, HWiNFO doesn't want to launch, Control Center freezes, can't switch between performance profiles etc..
    I'm desperately trying to install older versions of GPU driver to see if it fixes the problem, no luck so far. I am so disappointed. It looks like I will have to send back the laptop, hopefully for replacement.
     
  10. hrez2kx

    hrez2kx Notebook Enthusiast

    Reputations:
    0
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    5
    Adding in my experience hoping Eluktronics/XMG will respond. Having the same experiences as dmolnar123 and garzillo.

    My new 2070mq model is unusable from new, with Nvidia Control Panel, HWinfo, and the Eluktronics control panel constantly crashing. After resetting windows and installing all of the driver's from Eluktronics website in the order that they were listed, everything was fine for about a day, then back to being unusable. I can't even change the power stare of the laptop without massive lag. This is very disappointing that a $2k purchase doesn't work correctly out of the box and I am out of ideas in terms of how to fix it. Will call for tech support during a weekday, but I wish all of this could have just been avoided by shipping a WORKING and TESTED product.
     
Loading...

Share This Page