Intel HD 5500 causing problems

Discussion in 'Gaming (Software and Graphics Cards)' started by Handyann, Mar 9, 2018.

  1. Handyann

    Handyann Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hi all,
    Hope I've got this in the right place, as this isn't about a game, but Photoshop - apologies if not.

    I have an HP Envy notebook with Intel HD 5500 and Nvidia Geforce 940M graphics. I'm getting problems with Photoshop CC 18 crashing whenever I try to bring in an image from outside the program.

    I found a You Tube video which suggested that the Intel HD could be the problem and to disable it to test. I did this, and PS worked perfectly, but the screen resolution and some of the text in Outlook, for example, wasn't nice!

    Can anyone please advise me on how to achieve a proper-looking display and have PS working? I've been onto Adobe and they were very nice, but useless - just kept installing and uninstalling PS with no changes.

    Many thanks
     
  2. don_svetlio

    don_svetlio In the Pipe, Five by Five.

    Reputations:
    338
    Messages:
    3,616
    Likes Received:
    1,822
    Trophy Points:
    231
    Try messing with the Nvidia control panel and see if you can brute-force PS to use the 940MX constantly.
     
  3. Handyann

    Handyann Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    Thanks for that suggestion. I've set PS to only use the Nvidia graphics, but the problem persists. Interestingly, I've discovered that it's only JPEGs that PS crashes with - every other graphics format is fine. I've also just forced Windows to update the Intel HD driver, but no change with that either.

    I've hunted on other forums and it seems that a lot of people are having the JPEG issue, but the only suggestions are to update the graphics drivers. I've updated both now with no success.
     
  4. JRE84

    JRE84 Notebook Evangelist

    Reputations:
    62
    Messages:
    362
    Likes Received:
    142
    Trophy Points:
    56
    could be the same problem i had.....try settting advanced power settings to run at 90 under highperformance plan select additional options then advanced then goto processor states and set max to 90 and min to 5
     
Loading...

Share This Page