Intel AX200 wireless adapter and Dell xps 15 (9570)

Discussion in 'Networking and Wireless' started by Stollen123, Jun 17, 2019.

  1. Stollen123

    Stollen123 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    6
    I use Dell xps 15 (9570) and i did upgrade the Wi-Fi Card to Intel AX200 Wi-Fi 6 Card with the AX Standard.
    I have a Fiber internet connection FTTH) 500Mbit/s Download and 200Mbit/s upload.
    Calling Dell support before installing the card they assured that I could use the Card but Dell does not support it officially at least until now..

    I am using a Router with the ac standard or Wi-Fi 5...

    The card is slow and the connection to the internet is breaking from time to time. And the range of Signal is not that Great.
    And the Speedtest is showing Download at Maximum about 300 MBit/s
    When I use my IPad Pro 11 I am getting download at about 500Mbit/s

    When I right click on the WiFi connection and then go to property I could see the card speed is about 390 MBit/s in the 5 GHz canal..rarely it would show 430 MBit/s .. and twice it showed for few seconds the speed of 866 MBit/s
    I use the latest WiFi drive..did reset the WiFi connection in Windows 10 ..the router has the latest drive..

    What can I do to resolve the problem?
     
  2. xLima

    xLima Notebook Evangelist

    Reputations:
    115
    Messages:
    446
    Likes Received:
    235
    Trophy Points:
    56
    https://r.tapatalk.com/shareLink?ur...share_tid=828621&share_fid=33462&share_type=t

    Try here, it should be same card, just rebrand.

    Sent from my BLA-L09 using Tapatalk
     
  3. Starlight5

    Starlight5 W I N T E R B O R N

    Reputations:
    516
    Messages:
    2,897
    Likes Received:
    1,350
    Trophy Points:
    181
    @Stollen123 I'm having the same problem. So far I disabled Packet Coalescing and it seem to have improved the situation, though more tests are required to say for sure. I suggest you give it a try.
     
    Last edited: Jun 22, 2019
  4. Stollen123

    Stollen123 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    6
    thank you for your suggestion..i just disabled the Packet Coalescing and will monitor the situation..
     
  5. Starlight5

    Starlight5 W I N T E R B O R N

    Reputations:
    516
    Messages:
    2,897
    Likes Received:
    1,350
    Trophy Points:
    181
    @Stollen123 so how's it been for you without Packet Coalescing?
     
Loading...

Share This Page