iGPU causing glitches in audio stream

Discussion in 'Lenovo' started by annabel_shanderin, Aug 8, 2019.

  1. annabel_shanderin

    annabel_shanderin Notebook Geek

    Reputations:
    14
    Messages:
    82
    Likes Received:
    43
    Trophy Points:
    26
    I could use some help in order to narrow down an issue with audio glitches that I am almost certain is related to the iGPU (UHD 620) in my t480s.

    First, my setup is this:

    Lenovo T480s, 8250u, no discrete graphics, 16gb dual channel ram (2400mhz) and an RME Babyface. I'm running Ableton Live 10.1 on Windows 10 pro (1903). Beyond that, I'm running throttlestop in order to undervolt and disable turbo power limit. Everything is stable.

    Here is the conundrum:

    I found out that disabling the iGPU in device manager gives me much better performance. Take this example: I have a session in Live where I have 7 quite complex wavetable synths running different patterns with arpegiators, and each of them are send out to reverb and delay sends. Now, I can run this at 256 sample buffer size (44.100hz, btw) without any issues. Moving below that, though, introduces cracks and pops into the audio stream. HOWEVER, if I disable the iGPU in the device manager, I am able to run the same session at 64 sample buffer size and, get this, Live's cpu usage meter is even slighty lower, averaging 47% compared to average 50% at 256 buffer with iGPU enabled – meanwhile, the CPU usage in task manager is the other way around: 93% when running at 64 buffer with iGPU disable, and 46% at 256 buffer with iGPU enabled. This is pushing it, I know.

    I've tried with different intel GPU drivers: The newest from Lenovo, the newest from Intel, as well as older ones. As far as I can tell, the driver version has nothing to do with this behaviour. I also played around with different power settings in the intel graphics app, and no effect here either.

    Now, and this puzzles me, I also have a t460s (with a UHD 520, though), and this shows the opposite behaviour as to what I have explained above: More glitches when the device is DISABLED(!); less glitches with the device enabled.

    I would love to hear about your experiences, if someone would care to test it out. For now, I have made a script to disable and enable the driver with a shortcut on the desktop as a workaround, but I would love to be able to work in Live with an external monitor, which I can't if the driver is disabled.

    Is this a Lenovo specific issue? a t480s specific issue? UHD 620 specific? Ableton Live specific? What are your thoughts?

    If you are interested in testing it for yourself, I'll upload the test session that I'm using here: https://drive.google.com/open?id=1nr..._AR-Dy2hpSXGju
     
  2. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,720
    Messages:
    5,619
    Likes Received:
    4,339
    Trophy Points:
    431
    Can you post some pictures of how you have ThrottleStop setup? Make sure you are using the FIVR - Disable and Lock Turbo Power Limits option. Many Lenovo laptops thrive when this option is checked.

    Turn on the Log File option in ThrottleStop so you have a record of your CPU performance. In the Options window, check the Add Limit Reasons to Log File option. Go do some testing and once you are finished, exit ThrottleStop and go into the ThrottleStop / Logs folder and upload the log so I can have a look or copy and paste the data to www.pastebin.com

    Maybe there is a little more performance left in your CPU that you are not yet taking advantage of. What C0% is being reported when your laptop is idle and you are sitting at the desktop with only ThrottleStop open? Getting the background tasks down to a bare minimum is the best way to avoid glitches when the CPU is loaded.

    [​IMG]

    Set Speed Shift EPP on the main screen to 0 for maximum and consistent performance.
     
  3. annabel_shanderin

    annabel_shanderin Notebook Geek

    Reputations:
    14
    Messages:
    82
    Likes Received:
    43
    Trophy Points:
    26
    Hi UncleWebb, thanks for stopping by :)

    I appreciate your thoughts, and your ThrottleStop application very much! It really opens up the potential of laptops!

    However, I would be surprised if I can squeeze any morejuice out of my cpu than I already have. I have already disabled and locked turbo limits and undervolted via FIVR. CPU core: -92,8, cache: -92,8, system agent -70,3 and iGPU: -59,6. And EPP is set to 0. See screenshot below. Also, I see that you have both speedstep and speedshift enabled. Any reason for that? Isn't speedshift essentially doing what speedstep is just more efficiently?

    As I mentioned, I'm farely sure that the culprit is the iGPU. My testing shows clearly to me that having it enabled severly criples the audio performance under low buffers. The reason I need to work at low audio buffers (64 sample buffer would be nice) is that I do music, and therefore need fast response time from when I push a key on my MIDI keyboard and to the sound is triggered. With the iGPU disabled in device manager, I can work glitch free under much lower audio buffer sizes than with it enabled. Any ideas as to why that is?
     

    Attached Files:

  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,720
    Messages:
    5,619
    Likes Received:
    4,339
    Trophy Points:
    431
    You are welcome! I noticed one minor problem in your FIVR screenshot. When under volting the Intel GPU, you usually have to under volt the iGPU Unslice equally. If you do not do this, the Intel GPU under volt is probably being ignored.

    Have you tried running a ThrottleStop log file while using your computer? I am just curious if you are able to maintain a steady 34.00 multiplier or if there is any throttling going on. Intel's U CPUs are low power CPUs. The power budget is shared between the CPU cores and the iGPU. When you disable the iGPU, perhaps this frees up a few watts which the CPU cores can then use. If you run a log file with and without the iGPU enabled, maybe that will provide a clue or it might kill my theory. What are your turbo power limits set to?

    Just a wild guess but with the iGPU disabled, perhaps there is less latency within the CPU package.

    Have you done any testing with C1E disabled or with any of the other C states (C3, C6, C7) disabled? I will show you the registry trick if you want to play with this.

    When Speed Shift is enabled, having SpeedStep enabled or disabled does not seem to matter. I usually leave it enabled. Mostly force of habit. Not for any scientific reason.
     
    Vasudev likes this.
  5. annabel_shanderin

    annabel_shanderin Notebook Geek

    Reputations:
    14
    Messages:
    82
    Likes Received:
    43
    Trophy Points:
    26
    I am able to maintain a steady 34.00 multiplier (33.92 to be precise – 34.00 x 99.767 MHz) under load. At least that's what the upper right square of TS's main window tells me. Also the log seems to agree: https://pastebin.com/Y9sH28fT (the two sequences of 99.9-100% load are when running cinebench r15 with the GPU enabled and with the GPU disabled. In that order of appearance).

    And it is not throttling under sustained load either, though it gets quite hot, so I am considering looking into repasting.

    I don't think the C-states are an issue as I don't see the CPU clocking down at all when SpeedShift EPP is set to 0.

    Thanks for the heads up on the GPU unslice undervolt. I have decided to undo the undervolt of the iGPU as well as the System agent, though, as I read somewhere that the benefits were nothing substantial. Do you have a comment on that? Should I undervolt iGPU, Unslice and system agent after all?

    I don't think it's a question of the GPU freeing up watts for the CPU when disabled because the CPU reaches and holds its max boost clock either way. But I think you are right about the latency being less within the CPU package with the iGPU disabled. The question is, then, why does it work the other way around with my t460s?

    Thanks again!
     
  6. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    6,720
    Messages:
    5,619
    Likes Received:
    4,339
    Trophy Points:
    431
    Some computer things are a mystery. When your CPU cores are 100% loaded, any random background task can interfere with its smooth operation. Slight differences in Windows from one computer to the other might cause this.

    I just reread your original post. You said that you are disabling the iGPU in the Device Manager but you do not have any discrete graphics. After doing this, the iGPU must still be active or else you would not be seeing anything on screen. When disabled, I do not think the iGPU has any driver installed beyond just a very basic one. With reduced functionality, less latency makes sense. You would probably need to talk to one of the iGPU engineers at Intel to find out what is really going on in this state. All of the above is my best wild guess.

    I do not think disabling the C states will make any difference in your case. Here is a good post explaining how to do this if you are interested in doing any testing.

    http://forum.notebookreview.com/threads/the-throttlestop-guide.531329/page-206#post-9631401

    You need to do a quick and safe registry edit and then reboot. It is easy to undo this mod and go back to your original configuration when you are finished testing.

    I do not bother under volting any of these. They do not seem to make a significant difference.
     
    Papusan likes this.
  7. annabel_shanderin

    annabel_shanderin Notebook Geek

    Reputations:
    14
    Messages:
    82
    Likes Received:
    43
    Trophy Points:
    26
    Once again, thank you for your tips and your speculations. I'll leave it for now as I managed to tame Ableton to behave quite decent with a developer line (_ForceGdiBackend) that I found in another forum, and it cuts the cpu usage in half somehow.

    So things are running very well now with low buffers and low latency even with the igpu enabled. So I'm happy. Thanks for all your help!
     
    Papusan likes this.
Loading...

Share This Page