1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

If you own the L305D-S5895 laptop PLEASE read, urgent "to me" help.

Discussion in 'Toshiba' started by Suspense_Lover, Nov 20, 2008.

Thread Status:
Not open for further replies.
  1. Suspense_Lover

    Suspense_Lover Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    I recently bought a factory sealed non refurb Toshiba Satellite L305D-S5895 Laptop off of eBay for $550 shipped and on top of that I even used the MS Live search Cashback thing so all in all I paid about $420 for it. That aside, I despise Vista with a passion so what I would like to do is format the HDD and install my copy of XP Home. Now while thats not a problem because I've done it before with other computers the problem is with the drivers. Now I've already wiped out Vista and installed XP Home and everything seems to be running fine I just need to find drivers for everything so I can use the Wi-FI / LAN etc. Now Toshiba's website has a few drivers listed as XP compatible for this laptop but not everything, seems the ones that they have listed are just for minor stuff no one cares about. It seems that the drivers that are missing for a successful XP instal are ALL the important ones like the ethernet controller, video, Wi-Fi etc etc etc.

    Anyway, if you have this laptop successfully running XP in all it's glory please reply as I need help getting all the drivers... Ty. Even if you dont have this laptop but can provide me with all or even some of the XP drivers for it that I would be eternally grateful.

    The one driver I do have that I know for a fact works is the Realtek HD Audio Codecs.
     
  2. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
    HI, don't worry, it's not a big deal just put attention
    you must download this software first
    EVEREST, the free edition is enough
    www.lavalys.com
    then select in the right list hardware devices and windows devices in the right window, so you will be able to know what's the hardware name wich has no drivers, this will let you google it and find the drivers, or you can also use the drivertoolkit software, also very helpful
     
  3. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
    haha, forgive me, i'm sleeping, you must choose from the left list the hardware devices option and then windows devices on the right side, keep in touch to know how is it going
     
  4. Suspense_Lover

    Suspense_Lover Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    While I do or atleast think I understand what you said that wont work for me if I cannot atleast get the Wi-Fi or LAN working.
     
  5. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
    you can use the pc wich your working with right now, download the software and save it in a usb memory, then use the software in the notebook where we want to know what devices your notebook has, and then google for it in the pc where you have internet acces
     
  6. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
    if you want, just let me know what the ethernet device name is or the wireless and i'll help you to find it, so you can do the rest of the work in the notebook
     
  7. Suspense_Lover

    Suspense_Lover Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    I actually do have a spare USB 256mb flash drive I can use so ya that will work. I'll see what I can maybe dig up on my own which as of now hasnt been very much and then ask for help if I need it which I probably will / kinda do now hence the post heh. I guess the main good news as of now is that XP Home installs fine. I read another post here where one guy couldnt get even half way with the install / format.

    Since I cant post URL's / Pic's til 15 posts I gotta do it like this... anyway heres a snap I took before I wiped out Vista. I expanded what I felt were the more relevant items to worry about first. Anyway, I'll try to find em on my own but figured I'd post this now since I will probably end up needing help. I'm good with computers but as sad as it sounds I suck when it comes to downoading / finding drivers for a system with a "not intended" OS installed.

    eojmarket.com/NonForumStuff/images/ToshibaDevices.jpg
     
  8. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
    looks like piece of cake, give a second
     
  9. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
    it's the video driver
     
  10. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
  11. Suspense_Lover

    Suspense_Lover Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    I did just find what I think is the Video stuff, wont know til I try it out so to speak heh and thx. BTW seconds up LOL

    Edit: LOL you snuck your reply in before me.
     
  12. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
  13. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
  14. Suspense_Lover

    Suspense_Lover Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    Both links give me this...


    Sorry, you have insufficient access.

    403 Access Denied.

    If you typed the URL yourself, please make sure that the spelling is correct.
    If you clicked on a link to get here, there may be a problem with the link or the page may no longer exist

    Edit: **** you quick on replies lol, that link "above this reply" works.
     
  15. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
  16. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
    well, i have to sleep, keep going mate, i'll be back tomorrow, by now, i'm done
     
  17. Suspense_Lover

    Suspense_Lover Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    Well to you and everyone else who may decide to help I owe ya one if this works out not that it shouldnt ;-)

    Thx and night, I got 5am so I'll be callin it a night myself here in a few mins.
     
  18. sdragonshin

    sdragonshin Notebook Geek

    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    15
    well, i have 4:00 am, i'm from mexico
     
  19. Suspense_Lover

    Suspense_Lover Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    Ok, I'm getting ready to crash for real this time lol but I wanted to ask something. Given the laptop in question would I be better off installing my 64bit copy of XP Pro since the system has 3GB of memory installed which is expandable to 4GB ?

    Also, are those two links your provided for the Video & Ethernet x64 compatable ?
     
  20. Suspense_Lover

    Suspense_Lover Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    I think I have everything working right, but theres a few small things.

    1. The MIC doesnt seem to work, theres not even an option to mute, enable it anywhere on the sound stuff.

    2. The following two things are showing up in the device manager with the yellow !

    Modem Device on High Definition Audio Bus & SM Bus Controller

    I cant use Skype or Vent til I figure out the MIC thing... normally when you click the volume control its there or if not its under properties and just needs to be "checked" to be activated but it's no where to be found ;-(
     
Thread Status:
Not open for further replies.

Share This Page