i7-3630qm throttles to 1200 Mhz at less then 70°C if Turbo Boost is enabled

Discussion in 'Asus' started by Chriz74, Oct 20, 2016.

  1. BestJinjo

    BestJinjo Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hi Chriz74,

    I actually suffered the exact same problem with Samsung Chronos 7 Series NP780-Z5E with i7-3635QM 2.4Ghz with 3.4Ghz max single core boost; and Radeon HD8770M 1GB videocard after installing Windows 10 and running various updates over the last month.

    I reset the BIOS to standard defaults (Press F2 right before boot), disabled the Radeon GPU (as I thought it may have been working and sharing PSU/battery power with the CPU), took apart the laptop and cleaned the dust (while at it, I replaced the horribly slow 1TB Samsung SpinPoint M8 5400rpm mechanical drive with a 500GB Samsung 850 EVO -- this made a world of a difference for me in terms of overall system snapiness -- BTW Samsung incorrectly lists Series 7 as SATAII but it supports the full SATAIII and the EVO gets 544MB/s reads and 512MB/sec reads/writes in CrystalDiskMark). I also reset all the Power Option profiles and played with Processor Power Management but nothing worked.

    The answer lied in pressing Fn+F11 to manually boost/wake up the CPU Fans. I had to press it 5-10 times for it to finally work and now the CPU boosts to 3.2-3.3Ghz. After that I set the Battery Life Extender to 80%, set Samsung Power Optimized profile, and the CPU works properly. I was literally ready to go out and buy a new laptop as 1.2Ghz wasn't sufficient for my needs. It must have been a software glitch.

    Hope this helps.
     

Share This Page