HP Spectre x360 Owner's Thread (2017)

Discussion in 'HP' started by muzicman82, Mar 8, 2017.

  1. IceDragon7

    IceDragon7 Notebook Evangelist

    Reputations:
    303
    Messages:
    633
    Likes Received:
    2
    Trophy Points:
    31
    Any chance this might be related to the issue where my bluetooth mouse is really laggy on initial login to Windows?
     
  2. ha1o2surfer

    ha1o2surfer Notebook Evangelist

    Reputations:
    57
    Messages:
    460
    Likes Received:
    42
    Trophy Points:
    41
    It could be, the power options can be different for each user and the default Intel power saving scheme is "maximum battery" when on battery so change that to maximum performance (it doesn't hurt battery life at all...) and the lag goes away even sitting at the log in screen.
     
  3. aemaethx

    aemaethx Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    I recently picked up a HP x360 Spectre (13 late 2017) as well and found the cooling to be quite... alarming. I knew that the thermals on this weren't that great but I didn't expect it to be shooting straight to 90c+ sometimes when it would be using turbo boost.

    I also repasted the thermal paste in my device (which was not fun, so many little screws!) - twice actually; but still felt it didn't bring down my temps? I've double checked that I cleaned and applied it correctly, even tried taking down the core voltage offset to -0.105v but am still hitting the high 90c+ mark. Any other advice or things you think I could try out? I've disabled Turbo Boost on battery mode which does help a lot, but when I plug in my egpu and need to have TB on then this is where it struggles. I suppose I'll have to chalk it down the bad cooling and can't really expect that an ultrabook this thin would be able to push out that sort of performance.
     
  4. ha1o2surfer

    ha1o2surfer Notebook Evangelist

    Reputations:
    57
    Messages:
    460
    Likes Received:
    42
    Trophy Points:
    41
    To be honest, lowering the temps really doesn't help that much. Let it turbo as high as it's wants because the BIOS will actually power limit throttle before thermal throttling occurs. I tried keeping the laptop cold by placing it in front of my AC vent. I kept the temps at 60c even at full turbo and after 10 seconds it drops down to 15watts and the temps go way down. Even shooting up at 90c it still turbos to 3.3ghz since that's still a safe temp. My opinion, ignore it.

    I tried doing the same thing, thought my repaste job was awful but I do hit 80c+ all the time even with a perfect paste job and anything above 70c the fans are at full anyways and then after a short it drops to 15watts anyways were my temps never go above 65. It's becoming too much work to fix what HP should have done from the factory. I know this isn't much help but yeah..

    Another thing you can try.. use Throttle Stop and set the 4 core turbo limit to 30x. At 3ghz the CPU only uses 20 watts and every 100mhz increase from there uses like 3-4 watts. It's very inefficient. So you end up at 3.3ghz using 30 watts. Which is a lot for such a wimpy heatsink.

    What's the problem with your eGPU? I have the turbo set like I stated above and play overwatch at 1080p @144hz all day long on ultra and it doesn't skip a beat. The only game I have an issue with it Tom Clancy's, the Division. It's very pcie bandwidth dependent.
     
  5. aemaethx

    aemaethx Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Oh I see, thanks for clearing that up for me. I totally thought I was doing something wrong but like I thought, it's just how it is by design. I'll take a look into using Throttlestop though at this point I think I'll just have to let it be - I managed to undervolt mine to -0.100V and I'm getting satisfying results (39c idle right now w/ TB turned off on battery).

    Actually there is no issue with my eGPU, I'm using a Gigabyte Aorus 1080 gaming box and it runs perfect with this machine. I've mainly noticed on CPU bound games that having TB on or off is where it hurts the performance of the eGPU (sorry I should've made that clear), games like CS:GO, and GTAV which love core speed as opposed to actual thread counts - you can test this by turning off/on TB and try playing the game.

    Anyhow thanks for the advice!
     
Loading...

Share This Page