HP Omen 15 (5XXX series) Gaming Notebook

Discussion in 'HP' started by DrClone, Oct 8, 2014.

  1. who is AEK

    who is AEK Notebook Enthusiast

    Reputations:
    0
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    15
    Keep watching the drivers page for the HP Omen if you're on Windows 10. They've been updating the page with new drivers recently. So far there's seven of them. Nothing for HP Omen Control, though.
     
  2. GadgetBoi

    GadgetBoi Notebook Evangelist

    Reputations:
    441
    Messages:
    515
    Likes Received:
    6
    Trophy Points:
    31
    Looks like they're testing and updating with old(8.1) drivers. When you look at the details all the drivers versions are dated and the release dates are the same as the 8.1 drivers.

    Since updating I have had a few Intel graphic's driver crashes. I found updated 4600 drivers for Win10 on the Intel site. Since updating those no crashes.

    Link is to the driver landing page only.
    https://downloadcenter.intel.com/do...phics-Production-Driver-for-Windows-10-64-bit
     
    Last edited: Jul 31, 2015
  3. programmerTim

    programmerTim Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Hi. Has anyone had any luck with having "Fans Always On" disabled in the BIOS using anything more recent than F.09A? I updated when I got the laptop in May, but downgraded again soon after discovering that the fans were stuck on regardless of the BIOS setting.
     
  4. who is AEK

    who is AEK Notebook Enthusiast

    Reputations:
    0
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    15
    I haven't had any problems with my machine besides the already-known Omen Control not working issue. I did upgrade the Intel Rapid Storage Technology driver since it wouldn't work on W8.1 and it now works in 10. I think those Nvidia drivers are either 353.30 or 353.62, but I recommend sticking with the ones Nvidia gives you when you install W10. No issues with those, either.

    I upgraded to F.24 after installing Windows 10 and haven't had any issues regarding that.
     
  5. D303

    D303 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    5
    I have a problem after upgrading to windows 10.
    My computer becomes sluggish after plugging it in - anybody else?
     
  6. who is AEK

    who is AEK Notebook Enthusiast

    Reputations:
    0
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    15
    Have you looked at your power settings? I haven't had that problem. If that's not it then have you updated your BIOS?

    I must be lucky. I haven't had a single issue with Windows 10.
     
  7. Satego.x200

    Satego.x200 Notebook Guru

    Reputations:
    0
    Messages:
    67
    Likes Received:
    4
    Trophy Points:
    16
    Hey Folks - I just received my Omen 15 all great so far , especially Overall Speed and buld Quality - I am really impressed how solid ist build....

    One Thing... the temperatures..... I am mostly playing World of Tanks with it - I have set the graphic Settings so that it just holds the 60 FPS.... after 15-20 minutes gaming HWINFO Shows me that it had reached up to 91C CPU temp.....
    Normal ? meaning are yours getting such hot as well ?

    Thx
     
  8. Th4tRedhe4d

    Th4tRedhe4d Notebook Evangelist

    Reputations:
    12
    Messages:
    450
    Likes Received:
    62
    Trophy Points:
    41
    Prop the back of the machine up and disable turbo boost. You'll get much lower temperatures.
     
  9. Satego.x200

    Satego.x200 Notebook Guru

    Reputations:
    0
    Messages:
    67
    Likes Received:
    4
    Trophy Points:
    16
    Prop the back of the machine up and disable turbo boost. You'll get much lower temperatures

    OK I had propped up the back already massively....
    Where / how can I dissable Turbo Boost ? Only In the BIOS ?
     
  10. Th4tRedhe4d

    Th4tRedhe4d Notebook Evangelist

    Reputations:
    12
    Messages:
    450
    Likes Received:
    62
    Trophy Points:
    41
    No, in Windows go to:

    Control Panel -> Hardware and Sound -> Power Options -> Change plan settings -> Change advanced power settings -> Processor power management -> Maximum processor state -> Set to 99%

    (Note: You need to set it to 99% for both battery and plugged in depending on when you want to have it disabled. Also make sure you set it for each individual power plan you want it disabled on.)
     
Loading...

Share This Page