HP DV7 Sound fix for ubuntu.

Discussion in 'HP' started by ericmc783, Dec 14, 2008.

Thread Status:
Not open for further replies.
  1. ericmc783

    ericmc783 Notebook Enthusiast

    Reputations:
    0
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    15
    In case any of you were wondering, a fix was found for the sound problems with DV7 notebooks when running ubuntu.


    1) Open the Terminal.
    2) In the terminal: type sudo gedit /etc/modprobe.d/alsa-base
    3) This will open that file In gedit:
    Scroll to the bottom of the file and add the new line:
    options snd-hda-intel enable_msi=1
    4) Save the file and close gedit (you can now also stop the terminal).
    5) Reboot the computer.

    After rebooting, the sound should work properly.

    Also, I thought it may help if I shared the settings I'm using for the audio on my HP. (The settings mentioned below shouldn't be modified before trying the fix above).

    In System | Preferences | Sound:

    Sound Events - Sound Playback: Autodetect

    Music and Movies - Sound Playback: Autodetect

    Audio Conferencing - Sound Playback: Autodetect

    Sound Capture: HDA Intel STAC92xx Analog (ALSA)

    Default Mixer Tracks - Device: HDA Intel (Alsa Mixer).
    (Select "Front" as the track to control with the keyboard).

    After setting this, right-click on the speaker icon (usually at the top-left of the screen), and select "Open Volume Control". Click the Preferences button and Check ALL of the choices given to you. Click CLOSE, and now in the volume control, you should see a new tab that says switches. Go to that tab. Check "IEC958 Default PCM", and leave the other 3 options UNCHECKED. Using the Default PCM switch instad of the regular ICH958 seems to be the trick to getting audio working correctly.

    After doing this, go back to the playback tab. Set the PCM volume to at least 50% (you may want to go higher). Set the master volume to 100&, and the Front to 50%. You should now be able to hear sound properly. you can test this with the sound effects in system | preferences | sound. The volume buttons on your keyboard will adjust the audio for the front speakers, which seems to work better than using the Master, at least in my case. You can try using Master or PCM instead if you want.
     
  2. gioris

    gioris Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    i am using kubuntu and i have the same problem, how do i fix it in kubuntu?
     
  3. the12plus

    the12plus Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hello there,

    I was really glad a workaround got found when I read your post since I get absolutely no sound out of my Ubuntu 9.04 64bit on a dv7-2140ev model. However, I followed the exact procedure you described and it just won't work :( .

    I initially tried adding the lines in /etc/modprobe.d/alsa-base.conf, thinking you might have misspelled the filename and rebooted (didn't work), then restored /etc/modprobe.d/alsa-base.conf to the previous version, added the line in /etc/modprobe.d/alsa-base and rebooted (didn't work). Then, with the updated version of /etc/modprobe.d/alsa-base, set up all the sound settings you proposed, the very same way (didn't work).

    Is there something I am doing wrong? Could it be that you have tested this workaround on another Ubuntu version, eg 8.10?

    Thanks a lot in advance
     
  4. Th3_uN1Qu3

    Th3_uN1Qu3 Notebook Deity

    Reputations:
    214
    Messages:
    1,192
    Likes Received:
    0
    Trophy Points:
    55
    You can find that info on google... Oh well.

    A little birdie told me that snd_hda_intel isn't gonna magically work with everything. Try putting options=hp_dv7 or options=hp_dv5 instead. One of them will work. Also there's that stupid bug in the waveout level that nobody bothers to fix.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page