1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

How to turn off Intels Turbo Boost (to reduce heat in system)?

Discussion in 'HP Business Class Notebooks' started by wallace2010, Oct 20, 2010.

  1. wallace2010

    wallace2010 Notebook Enthusiast

    Reputations:
    0
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5
    Does anyone know a way to turn off turbo boost?

    Haven't found a topic about it in google apart of a bios option, however my Notebook (Elitebook 8540w) has no bios option for this or at least I didn't find it.
    Disabling the Intel Turbo Boost Technology driver seems no help as well.
    (The Intel sidebar tool to visualize turbo boost in action still shows a blue bar)


    my problem in detail:

    I run a 8540w with I7-620m and my fans are increasing/decreasing speed a lot (temps between 55C and 70C) when using some of my daily programs which is quite annoying.
    I feel that as soon as turbo boost is activated automatically, the fan cries for speed and slows down a few seconds later.

    Hence my fan noise issue most likely comes from programs that unnecessarily requests additional performance and thus make the system turn on turbo boost regularly. This fact most likely brings a lot more heat to the system and fan noise to my ears.
    I'd like to turn off Turbo Boost and rather do without some additional system speed than bearing the fan noise all the time.
     
  2. Mumak

    Mumak Notebook Evangelist

    Reputations:
    818
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    0
    There are more ways how to disable Turbo Boost, but they need to be executed in Kernel so require a driver. I don't know if there's a tool able to do this, ThrottleStop maybe? Since I don't want to implement active hardware control in HWiNFO32, you might want to ask Unclewebb if he's willing to implement Turbo Boost disable in ThrottleStop (if it's not already there). In case he doesn't know how to do that, he can drop me a PM ;)
     
  3. wallace2010

    wallace2010 Notebook Enthusiast

    Reputations:
    0
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5
    Thank you Mumak. I'm wondering why there is no easy way to turn off this feature like a BIOS option or something though.
     
  4. AlbuquerqueFX

    AlbuquerqueFX Notebook Consultant

    Reputations:
    68
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    30
    If you're using Windows Vista or later, go to your power options, change your current plan settings, click the advanced section, expand the Processor Power Management section, click the Maximum Processor State, and change it to something other than 100%.

    Intel Turbo mode is not directly controllable from the OS, as it's a 'superset' of the C0 activity and P0 performance states. However, the processor can ONLY go into turbo mode if it's requested to run at full performance (P0) and it's activity is 100% (C0), and of course so long as it fits under the standard thermal and power consumption targets.

    By changing the maximum CPU state via the Windows NT6 power applet, it will be forced to throttle below C0, which means it will enter a turbo state.
     
  5. jdbfdhsvbhdvhs

    jdbfdhsvbhdvhs Notebook Consultant

    Reputations:
    8
    Messages:
    178
    Likes Received:
    0
    Trophy Points:
    30
    According to UncleWebb disabling turbo won't help your temps much because the processor will spend less time in the C6 sleep state (0v). You should ask something like that in the "undervolting guide" thread.
     
  6. wallace2010

    wallace2010 Notebook Enthusiast

    Reputations:
    0
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5
    AWESOME, it works!
    No more turbo boosting and my laptop fan is supersilent now!

    Didn't expect that much difference in noise level but indeed it was the turbo boost switching on and off frequently which made enormous heat and fan noise!
     
  7. onkyo1

    onkyo1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    5
    Are you using a FX880 or M5800 graphics card, I am curious to hear if you were having the heating problem with the FX880 card.
     
  8. wallace2010

    wallace2010 Notebook Enthusiast

    Reputations:
    0
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5

    hmmm, I have a nvidea 1800M, but I don't think it the gpu was responsible for the heating problem.
     
  9. lukalukaluka

    lukalukaluka Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    5
    To how much perecent did you put it?
     
  10. gull_s_777

    gull_s_777 Notebook Consultant

    Reputations:
    34
    Messages:
    294
    Likes Received:
    1
    Trophy Points:
    31
    yup its nice simple way to turn trubo off...
    it keeps always kicking in and with the processing power of i7 , we usually don't need it anyway.....
    So turning it off can easily make a noisy laptop silent, and silent laptop supersilent :)
     
  11. ktx49

    ktx49 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    what percentage did you guys use in the settings....the post above does not specify just says change from default of 100, which i did, with no success....i still hear my fans or something engaging in frequent intervals for no apparent reason.....not very loud or anything but it does seem strange and unneccesary
     
  12. nrasandun

    nrasandun Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Thank you man. you saved me. My CPU (core i7 950) was overheating while playing Battlefield 3. temps go around 70-80 centigrade. I changed the Maximum Processor State. Now temps are fine. below 65 centigrade. Thanks again. I really owe you!
     
  13. Prometheus5061

    Prometheus5061 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Thanks guys!!! I now have a relatively quite Alienware laptop!! :thumbsup: Thanks heaps
     
  14. JLL_Alien17

    JLL_Alien17 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    2
    Trophy Points:
    6
    I use the TMonitor from CPUID to turn off my turbo boost. When the program is open I just right click anywhere on the graphs select "Turbo" and you then have the option to disable or enable the turbo.
     

Share This Page