1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

How to turn off intel video card?

Discussion in 'Dell XPS and Studio XPS' started by xpsbrenden, Jun 24, 2011.

  1. xpsbrenden

    xpsbrenden Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    6
    So I have a new XPS 15z with the 2gig Nvidia graphics card. Is there anyway to turn off the Intel graphics card so the system just utilizes the Nvidia card? I've done a search and some posts say on certain systems you and achieve this in BIOS but that's not the case on the 15z.

    any suggestions would help! :D
     
  2. zjacobss

    zjacobss Notebook Evangelist

    Reputations:
    26
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    30
    Sorry, you can't.
     
  3. seeker_moc

    seeker_moc Spes mea in Deo est

    Reputations:
    354
    Messages:
    2,098
    Likes Received:
    5
    Trophy Points:
    56
    This is one of the reasons I don't understand why people like Optimus so much. At least with the AMD switchable graphics there's a physical switch, so you can control which GPU is used when. Granted, with Optimus the switching is automatic, but I'd rather spend the extra .5 second flipping a switch then not having control of the hardware in my own machine. Nvidia really needs to come up with a simple app that allows you to manually select which GPU to use if you so desire.
     
  4. madmattd

    madmattd Notebook Deity

    Reputations:
    368
    Messages:
    1,348
    Likes Received:
    0
    Trophy Points:
    55
    You can.....

    Right-click on Desktop, go to "Nvidia Control Panel" or something like that. Click the "Manage 3D settings" option on the left. You can then select which GPU to use as a default (it is usually set to auto-select). The other tab lets you override for individual programs, you can add ones not in the list by clicking "add" and navigating to said program's .exe.

    Personally I leave mine on auto-select. I have no need to be using extra power and generating more heat if I am just sitting on the desktop or web browsing/typing. For games and my CAD work the good GPU switches on. And I manually set the NVidia GPU for the odd game that doesn't auto-select properly. It's not that hard honestly.

    You could just set the default to use the Nvidia, but then your fan will run non-stop and your battery life will go down the toilet.
     
  5. zjacobss

    zjacobss Notebook Evangelist

    Reputations:
    26
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    30
    Yes you can choose to run a program with the gpu but the intel graphics will always be active managing your screen or display, I don't know how to say this.
     
  6. madmattd

    madmattd Notebook Deity

    Reputations:
    368
    Messages:
    1,348
    Likes Received:
    0
    Trophy Points:
    55
    Well how the Optimus works is that all graphics are rendered by the Intel chip. When the NVidia card is asked for, the NVidia does all the processing and just sends the results to the Intel chipset to display it. There is no software OR BIOS way of circumventing this, it is how it is wired. The 3D systems are different in that the Intel graphics are permanently bypassed.

    I don't see what the problem with the Intel managing the display is? I know some people don't like it but honestly I have had no problems with it. I suppose there is a .000000001s delay between the NVidia rendering and the the Intel displaying, but that is not noticeable by the human eye.
     
  7. BobTheSniper

    BobTheSniper Notebook Consultant

    Reputations:
    23
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    30
    I have my NVidia chip turned off globally, and set to only run on games. Intel HD 3000 is fully capable of doing anything except gaming.
     
  8. Falco152

    Falco152 Notebook Demon

    Reputations:
    433
    Messages:
    1,748
    Likes Received:
    13
    Trophy Points:
    56
    Well, AMD is starting to go the same direction as Nvidia Optimus for their switchable technology.
    A couple of preview models are available for purchase now.
     
  9. madmattd

    madmattd Notebook Deity

    Reputations:
    368
    Messages:
    1,348
    Likes Received:
    0
    Trophy Points:
    55
    Very true, and I've been considering doing this except I have too many games, lol.
     
  10. floofy

    floofy Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    5
    There might be a way, but there's no reason to. Your graphics card kicks in whenever you need it for something, whether it's running a game, video, etc. Using integrated or not in Windows won't affect it all, the Intel HD is enough plus it saves power.

    I have the 15z too and I had a problem with the GPU automtically kicking in so some of my games would just lag. I just dled the latest software from NVIDIA and it works perfect now. This was after I installed a fresh x64 Professional so I didn't have any of the Dell presets installed.
     
  11. lupoli

    lupoli Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    you guy's do not understand, sometimes we need to turn off this automatic switching because of some things.

    For example, my dxdiag would not let me get results from the nvidia GPU and i cannot start nhancer because it does not recognise the nvidia chip.


    Any help on shutting it down temporarily?
     
  12. zjacobss

    zjacobss Notebook Evangelist

    Reputations:
    26
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    30
    You just can't shut it down completely...
     
  13. madmattd

    madmattd Notebook Deity

    Reputations:
    368
    Messages:
    1,348
    Likes Received:
    0
    Trophy Points:
    55
    As was said in this thread already, in the NVidia control panel->3D settings, just set the system default to one card or the other. Or change it on a program-by-program basis. Real simple, works great, fixes any detection issues you may have.

    And all output to the display is still done through the Intel buffer, nothing you can do about that. But Windows doesn't really know that, it just sees one card or the other depending on your settings in the NVidia Control Panel.
     
  14. otacon

    otacon Notebook Evangelist

    Reputations:
    3
    Messages:
    499
    Likes Received:
    6
    Trophy Points:
    31
    It cannot be done, sorry. The only way to get dxdiag to run on the Nvidia GPU is to run an external monitor.
     
  15. savagess2546

    savagess2546 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Well the reason I would like to do so is just so that games that detect hardware settings recognize it. I love Optimus but it doesn't kick in until the game is a few seconds running. Games like Halo 2 perform a hardware scan before even starting the game and it only sees the Intel card and spits out an error window claiming insufficient resources.
    But I'm curious if running it on an external display with the nVidia card would fix this? I have a new monitor coming in and I'm going to try that. Just for kicks.
     
  16. Jon vMagic

    Jon vMagic Notebook Consultant

    Reputations:
    101
    Messages:
    298
    Likes Received:
    0
    Trophy Points:
    30
    right click on an application shortcut or the "exe" that you want to run...

    click "run with high performance nvidia GPU" or whatever the option is (something to that effect anyway) - this works with pretty much any game or application and DOES bypass the "auto-switching" feature... Alternatively go into the nvidia control pannel, go to program options and you can manually add/select games or applications to automatically use the nvidia GPU.

    however... some people here don't seem to grasp the concept of Optimus technology... your laptop monitor is PLUGGED IN to the Intel graphics, if you turned it off then you'd get no picture at all. When running games or applications which switch between the 2 GPU's what's basically happening is the Intel card recognises it needs more power and the nvidia GPU kicks in... sending the output to the Intel card and then to the monitor
     
  17. Merranza

    Merranza Notebook Consultant

    Reputations:
    1
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    30
    Never mind this message, fixed my problem. Matt you are 100% right :)
     
  18. xm709

    xm709 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Hi!
    I experience some troubles with Nvidia Optimus and ENB mod for Skyrim. The problem is that ENB just don't run the game on nvidia GPU, but on intel. It is written in the documetation that to fix that I must turn of intel gpu in bios. I tried it but there is no way to do that. Any suggestions? Maybe someone else faced this problem and successfully solved it?
     
  19. robcope

    robcope Notebook Evangelist

    Reputations:
    16
    Messages:
    329
    Likes Received:
    0
    Trophy Points:
    30
    Skyrim plays great on my L702X. Seems wierd you would be having trouble with this.
     
  20. xm709

    xm709 Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Actually the game runs smoothly without any graphics mods on my GT 540M (22-27 FPS; AA 8x; AF 16x; all on high/ultra, only shadows on medium), but with ENB I have 12 FPS due to Nvidia GPU doesn't engage. I marked this in GPU-Z.
    Do you run ENB? If you do, this is really weird...
     

Share This Page