How to lock CPU speed

Discussion in 'Samsung' started by Forssberg, Jan 30, 2016.

Thread Status:
Not open for further replies.
  1. Forssberg

    Forssberg Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    5
    Hello,

    I have NP-300V5A model:
    - i5 2410m
    - 8 GB RAM
    - GT 520MX

    I have problem with CPU speed. It is not being fully used in the game. When I play it the CPU speed is quite low, 800 Mhz to 1800 Mhz commonly.
    Default CPU speed is 2.3 Ghz, with turbo 2.9 Ghz.

    You may think that perhaps CPU is not needed by the game.... The answer is no.
    Because of this weird speed of processor I get 10-30 FPS, instead of 50-60 which I can reach but only for about 10 seconds - then CPU underclocks to lower speeds.

    CPU is not an issue, I get steady 2.3 Ghz at 85*C (CPU testers), in game it is about 75*C.
    GPU temp is 85*C (GPU tests) at 100% use so no problem.

    I do not know why CPU sets itself lower than it is required by the game Thus I want to know if there is some kind of tool which could lock my CPU at desired level of speed?
    10 years ago I had one tool to lock CPU speed as one game was not able to trigger CPU to "higher speed". This tool switched CPU speed "on live". I do not remember its name though.
     
  2. Plur

    Plur Notebook Consultant

    Reputations:
    117
    Messages:
    202
    Likes Received:
    111
    Trophy Points:
    56
  3. Forssberg

    Forssberg Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    5
    Unfortunately this app does nothing for my CPU, tried 6.0 and newest beta.

    I do not know why CPU thinks there is nothing to work for, while I do play a game and get 10 FPS.
     
  4. Dannemand

    Dannemand Decidedly Moderate Super Moderator

    Reputations:
    11,279
    Messages:
    4,383
    Likes Received:
    2,030
    Trophy Points:
    231
    This sounds a lot like Samsung Silent Mode was accidentally enabled. In Settings (Fn-F1) make sure Silent Mode is set OFF (not AUTO).
     
    ALLurGroceries likes this.
  5. Forssberg

    Forssberg Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    5
    It is disabled.
    It seems somehow it is not possible to keep CPU working while needed :O
     
  6. John Ratsey

    John Ratsey Moderately inquisitive Super Moderator

    Reputations:
    7,167
    Messages:
    28,880
    Likes Received:
    1,971
    Trophy Points:
    581
    I wonder if the game is not activating the Nvidia GPU. If the game is using the Intel GPU then the CPU speed will be reduced in order to keep within the power ceiling of the CPU package.

    Do you have the Nvidia control panel or similar? Make sure that it is set to use the Nvidia GPU when you run the game. It may also display an icon to show that the dGPU is active. HWiNFO > Sensors should also display information about the dGPU if it is active.

    John
     
  7. Forssberg

    Forssberg Notebook Enthusiast

    Reputations:
    0
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    5
    Yup, dedicated nVidia GPU is activated in the game's profile. It works.
    I do not know why CPU speed is not consistent during playing. Temperature is stable 85-90 max and within this I have frequency drops.
    In the stress tests I achieve 95*C and CPU is still solid 2.3 Ghz.

    The important thing I noticed is using dedicated card which should be in theory few times better than integrated I have similar FPS but much more FPS drops than using integrated.
    Is it possible then I use 2 cards and as you say CPU must divide its resources for CPU and integrated GPU even if it is not being used at the time? I mean perhaps I use two cards somehow even if integrated is not being utilized?

    I know I say a lot of things but honestly don't know what string to catch, I only observed that temperature should have no impact on throttling as it can sustain solid 2.3 Ghz during ~95*C while in game it is max ~85*C.
    My energy profile is set to max, I use Process Lasso and its management (Core Parker example) and still nothing.
    I disabled energy saving in BIOS, but have no access to SpeedStep though.

    I don't get it how some game cannot trigger CPU to push more power instead of 0,8Ghz or jumps around 1.2 Ghz.

    EDIT:

    After playing while my CPU is stuck at 800 Mhz. Changing power plan won't do anything, setting minimum processor state in power plan also nothing.
    It seems to be deeper issue :O
     
    Last edited: Jan 31, 2016
  8. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    7,093
    Messages:
    5,851
    Likes Received:
    4,989
    Trophy Points:
    431
    If a program does not work for you, post a screenshot of how you have ThrottleStop setup. Make sure in the Windows Power Options that you are using the High Performance profile with the Minimum processor state set to 100%. Also make sure that BD PROCHOT is not checked.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page