[How To] Eurocom Scorpius 3D / Clevo P370EM(3) UEFI Windows 8.1 / 10 Install

Discussion in 'Sager and Clevo' started by Windza, Dec 10, 2020.

  1. Windza

    Windza Notebook Enthusiast

    Reputations:
    5
    Messages:
    11
    Likes Received:
    1
    Trophy Points:
    6
    Folks,

    Decided it was time to give my Eurocom/Sager/Clevo P370EM3 (3D display variant) a hardware and software refresh after a couple bad boots on current Windows install and decided I wanted to move to a clean UEFI install thinking it was going to be a straightforward process (I was wrong).
    Followed all the advice I found in various threads I found here and elsewhere but every time I came up against some variation (options in BIOS) or the Windows installers just refused to install to a GPT partition.

    I considered just giving up and just going with a Legacy/MBR install but that would've bugged me to no end so I just committed to it and after spending the better part of 3hrs I wanted to pass on what ended up being the magic combination in case it can help someone else wanting to make this work.

    **First things first, I'm still running the original BIOS that was loaded by Eurocom from new (it's a late 2012 series).
    upload_2020-12-10_12-39-16.png
    This BIOS does NOT have any options to enable/disable Legacy/MBR or UEFI/GPT like I was seeing others suggesting but under the boot tab, it did have the "Launch EFI Shell from filesystem device" option" with a context message indicating that would require a shellx64.efi file.
    upload_2020-12-10_12-39-33.png
    For a relative newcomer to UEFI, there is nothing intuitive here to the purpose of that option and the information out there about where and how that shellx64.efi file gets used is vastly different at best BUT I did end up locking onto that as the likely route for the Windows installer to recognise/allow a UEFI install.**

    I did consider doing a BIOS upgrade (even Eurocom suggested I needed a later BIOS) but it was still unclear whether this would result in anything different so I put BIOS upgrade into the unwarranted risk category and left it as a backup plan that I didn’t end up needing.

    TLDR: If your BIOS has the "Launch EFI Shell from filesystem device" listed under boot and you're avoiding a BIOS upgrade, the following steps should work to get you a UEFI/GPT partition install on Windows 8.1 or 10 x64. It may work for other OS's but I have not verified this.

    1. Create a UEFI capable Windows boot disk using your tool of choice and well documented methods (not covering that topic here – please search accordingly).
      FWIW, I used Rufus with Win 10 x64 on 8GB USB drive.

    2. Create an EFI Shell boot disk using the following steps;
      • Format a USB drive as FAT32 using your tool of choice and place the shellx64.efi from the attached shellx64.zip file into the root directory.
        It may also work to put this in a /efi/boot/ directory but I didn’t find this necessary.
        I used a 4GB USB drive.
      • For those with trust issues like I do, the shellx64.efi file is the shell from TianoCore EDK2 and sourced from GitHub - if you wish to download directly here’s the link;
        https://github.com/tianocore/edk2/blob/UDK2018/ShellBinPkg/UefiShell/X64/Shell.efi
        Rename the file you download as shellx64.efi and follow the step above.
    3. Plug both USB drives into the P370EM and boot into BIOS using the F2 key.

    4. Navigate to the Boot tab and use the “Launch EFI shell from filesystem device” and you should end up in the EFI shell with a screen as follows;
      upload_2020-12-10_12-48-42.png
      If you end up with the “Not Found” error back in BIOS, please retrace your steps and try a different directory as mentioned in step 2a. Alternatively, you might also want to try a different USB port as I’ve seen suggested in some places (this didn’t seem to matter for my install).

    5. Now that you’re in the EFI shell, the real magic can start to happen and you now get to launch the Windows installer that will now finally recognise UEFI capability;
      • You should end up with a list of filesystem options, two of which should be your USB drives and a command line ready for you to do something!
        upload_2020-12-10_12-51-3.png

      • Navigate to your Windows boot drive and execute the commands as laid out below.
        Code:
        Shell> FsX:
        FsX:> \EFI\BOOT\BOOTX64.EFI
        
        In my example below my Windows installer was Fs2 (and I went the long route to the directory because I needed to verify I had the right drive).
        upload_2020-12-10_12-52-26.png
    6. At this point, my screen went dark for what seemed like a couple mins while I assume installer files were cached somewhere.
      The screen flickered a couple times and I found myself at the standard Windows installer where, as I stepped through, I was ecstatic to see it finally mandated that my partitions be formatted as GPT and not MBR.
      Success!

    7. From this point forward, it was all standard Windows install process and no further special steps were required.
      I was a little uncertain if I’d need some form of boot script to ensure it booted correctly but there is no concern there – PC behaves normally and the boot time is marginally faster than Legacy/MBR without the Windows boot screen shown at all.

    I realise there may be better ways to do this (not sure if shellx64.efi can be added directly to the Windows installer USB?) but this is what worked for me so figured I’d capture it exactly as it worked.
    There might also be similar write-ups out there that cover what I’ve done here but I certainly didn’t locate them so am throwing this out there anyway in the hopes that someone else can benefit.

    I’m open to folks providing constructive comments if I should update these steps to ensure a better process.

    Also, in case it's beneficial; here is a list of handy references I found along the way;
    https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface#bcfg
    https://systemscenter.ru/waik.en/html/8b7d58e5-8264-479c-9ea2-872a9932155e.htm
    https://ohlia.github.io/Wiki-site/wiki/EFI/Creating-a-Bootable-USB-drive-with-UEFI-Shell/
     
    Last edited: Dec 10, 2020
    Meaker@Sager likes this.
Loading...

Share This Page