How to Enable Intel Dynamic Acceleration (IDA) on Both Cores of a Core 2 Duo

Discussion in 'Windows OS and Software' started by unclewebb, Apr 21, 2010.

  1. ionutmaruta

    ionutmaruta Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I don't understand :( After restart CPU-Z it show 2925 MHz :(

    [​IMG]

    If I run ThrottleStop 6.00 it show like this:

    [​IMG]

    So why my CPU not remain overclocked ? :(
     
  2. Dufus

    Dufus .

    Reputations:
    1,172
    Messages:
    1,336
    Likes Received:
    534
    Trophy Points:
    131
    When you reboot BIOS resets settings. IIRC TS has the option to save settings but needs to be run each startup to apply them so once you are happy with your settings have task scheduler automatically start TS after reboot..
     
  3. ionutmaruta

    ionutmaruta Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Now I have another problem. From the below screenshot i modify the following:

    [​IMG]

    Intel Virtualization Technology = ENABLED
    Intel SpeedStep = ENABLED
    CX States = ENABLED
    T States = ENABLED

    The rest of settings from the above screenshot are DISABLED.

    So the notebook is starting, I run CPU-Z in some second without ThrottleStop 6.00 and it show me for 1 minute 3191.95 MHz ... 3056.95 MHz... again 3191.95 MHz .... then 3056.80 MHz...

    After 1 minute it show 3.0 X 789.90 then 3056.95 and remain at this frequency for a while then 789.90 :(
    I'm waiting another minutes to see 3191.95 or something like that... and no chance :(

    I don't want to start ThrottleStop 6.00 after every startup of my operating system.
    This must be done from the BIOS or other way...

    I have another old computer with Athlon AMD64 4000+ (real 2.6 GHz) and I can overclock from BIOS using settings till 2.8 GHz or 3.0 GHz and Windows show me 2.8 or 3.0 .

    Last night I restart my notebook from 30-40 times to get the correct setting but no chance :(

    LATER EDIT:

    On a search on Google I found the left screenshot.
    In comparation with the right screenshot of mine the multiplier from the left screenshot show 12x instead of (6-11.5) .

    Why not my processor not remain at 12x :(

    [​IMG]

    After 30 minutes I run CPU-Z again and Go ORTHOS to stress the CPU and it show me:

    [​IMG]


    This is a bug ? Now I see the Multiplier ... 11.5x and (6-12).
    CPU is stressed with GO ORTHOS but no chance to get 3.2 GHz :(

    After 1 hour I moved on Windows 7 Ultimate and I load two different versions of CPU-Z :))

    Now it show like this:

    [​IMG]

    I think this frequency 3.2 GHz is a FAKE because if I stress my CPU using GO ORTHIS it show maximum 3.06 GHz :(
     
  4. animeking

    animeking Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Got this to work on my Studio XPS 1640 Core 2 Duo 2.4 GHz P8600.

    Stock 2 Core multiplier 9.

    Tricked it to 9.5, new frequency is 2.527 GHz, 5.3% improvement.
     
  5. tjwasiak

    tjwasiak Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    That way you will not get Dual-IDA!! You have to leave SpeedStep disabled!

    This is normal SpeedStep behaviour - CPU is clocked according to load, you can get extra half multiplier only for one core (it will be enabled only when one core is under some, but not full load).

    You can use other software, but you have to run something at every startup and have SpeedStep disabled in BIOS.

    Is it notebook? Desktop Athlon64 4000+ is not 2.6 GHz - it is 2.0 or 2.1 (depends on stepping) GHz and could be overclocked quite easily but not that far...

    Set BIOS properly, then set ThrottleStop (or other software) and you will get it from the 1 start :)

    When you disable SpeedStep and set ThrottleStop properly you will get 3.2GHz...
     
  6. xiphmont

    xiphmont Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hello all, and a question to others (have you seen this, and do you have any theories/improvements to offer?)

    My x61t is loathe to go into dual-IDA mode but it will do it if I'm persistent. This is on a regular Midleton BIOS and an L7700, so my max non-IDA FID/VID is 0x919 and my IDA FID/VID is 0xa24. FTR, I'm using Linux and just reading/setting MSR registers directly.

    What I see here is:

    1) The IA32_PERF_STATUS registers only occasionally advertise the 0xa24 IDA FID/VID pair as the 'current maximum' on one core or the other (never both that I've seen). The rest of the time they show 0x919.

    2) IA32_PERF_STATUS will only list the 0xa24 FID/VID when IDA is already enabled but not being used

    3) The machine apparently will only enter dual-IDA when you happen to toggle the IDA bit when the desired 0xa24 FID/VID is advertised on one of the cores.

    I don't know if this is due to to the behavior of the C2D or the BIOS interfering somehow. SpeedStep is off in the BIOS. Thermal management BIOS settings don't seem to affect the behavior.

    For now, I set up a little script here that requests 0xa24 then just toggles IDA off then on via 0x1A0 once a second until the request sticks; it can take anywhere from 2 to 20+ tries. Once dual IDA is set, the processor stays at the top IDA multiplier on both cores until you explicitly turn IDA off, at least according to IA32_PERF_STATUS.

    Is the 'setting dual IDA' process so hit-or-miss on other machines?

    Oh Ho!

    I just noticed I can temporarily offline one of the cores, which ~immediately causes the other core to offer IDA (FID/VID 0xa24). At that point, the IDA request always sticks, and upon onlining the other core, both are in IDA.

    Perhaps there's a simpler way yet, but it's nice to know this seems to always work (though there is probably a very short delay between offlining the second core and IDA actually being available).

    Code:
    # wrmsr 0x1a0 0x1364862489
    # echo 0 > /sys/devices/system/cpu/cpu1/online
    # rdmsr -p0 0x198
    6150a2406000615
    # wrmsr 0x199 0xa24
    # wrmsr 0x1a0 0x5364872489; wrmsr 0x1a0 0x1364862489
    # rdmsr -p0 0x198
    6150a2406000a24
    # echo 1 > /sys/devices/system/cpu/cpu1/online
    # rdmsr -p0 0x198; rdmsr -p1 0x198
    615091906000a24
    615091906000a24
    
    edit after much playing: It's pretty clear now the x61t has little thermal headroom to work with. Stock behavior of the 'balanced' thermal strategy BIOS setting appears to be to throttle ruthlessly to keep on-die temp averaging no higher than 70C. Disabling SpeedStep and forcing 0x915 brings me to bumping up against 83C. Anything beyond that (even the 'stock' 0x919) and thermal throttling kicks in. I can run linpack for about 5 minutes at 0xa18 before throttling starts (machine locks up at 0xa17), and at the full 0xa24, the CPU overheats so fast it just powers off.

    So... the x61t can do dual-IDA, but it's not clear that you'd want to. The undervolting potential of the stock clocks looks much more interesting.

    Edit edit: Yeah, selecting the BIOS's 'Maximum Performance' thermal strategy stops the BIOS throttling at 70C when SpeedStep is enabled.
     
  7. thgergo

    thgergo Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Yes, I have seen this behavior here already, just in the previous page.

    I suspect, my ubuntu linux kernel always run something on both cores, the threads are switching between the cores all the time. Thus it almost never have the opportunity to enter the IDA speeds. I have a t9500 with 800mhz fsb in a Dell D630.

    In the other hand SLFM, might allow us further overclock. Since SLFM=halved FSB(front side bus) speeds does not seem locked same way as the ones with full FBS speed.

    For example, I can set 2500Mhz with 25x multipler with 100mhz FSB, in spite of my T9500's max multipler is 13x. Also it can enter into IDA modes, I can set 2700Mhz with 27x multipler with the IDA trick. 2600 with 26x without IDA trick, and 2800 28x even with IDA however is failing, it just does nothing.

    Thus my theory was:
    #1 Enter into an abnormal multipler with SLFM. For example 16x. Thats only 1600mhz with 100mhz Fsb.
    #2 disable speedstep
    #3 disable SLFM
    #4 This was the stage when I did not know what to do, since without speedstep, it even wont revert the 200mhz fsb. (For 3200Mhz with 16x multipler)

    Any idea what should I try?
     
  8. ionutmaruta

    ionutmaruta Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    @tjwasiakf thanks for the reply, but there is no other chance to see my T9900 processor at 3.2 Ghz permanently ?

    My Windows 7 properties show me:

    Processor: Intel(R) Core(TM)2 Duo CPU T9900 @ 3.06 GHz 3.07 GHz

    instead of

    Processor: Intel(R) Core(TM)2 Duo CPU T9900 @ 3.06 GHz 3.20 GHz (or something like that)
     
  9. Starlight5

    Starlight5 I'm a cat. What else is there to say, really?

    Reputations:
    215
    Messages:
    2,195
    Likes Received:
    764
    Trophy Points:
    131
    Will CPU ever drop frequencies to some slower state if Dual-IDA is enabled? I would like to have both Dual-IDA and some other state, depending on load. And is it possible to choose undervolting settings for each separately?
     
  10. xiphmont

    xiphmont Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    On thinkpads at least, it will only happen if required for thermal throttling, when the BIOS will drop the processor to minimum mulitplier (not SLFM). Otherwise, the processor will stay locked at full dual-IDA. You'll still have power saving C-states though-- it's not running flat out the whole time.

    FID/VID transiitons are managed by the OS; undervolting can be as flexible as the OS allows. The processor will only impose minimum and maximum VID. Otherwise, the OS has complete flexibility.
     
Loading...

Share This Page