How to disable Turbo Boost.

Discussion in 'Dell XPS and Studio XPS' started by MaskedCarrot, Aug 8, 2017.

  1. MaskedCarrot

    MaskedCarrot Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    I saw stuff like this listed in various threads under various ways, but this method worked for me.

    To prevent a Laptop from going into Turbo mode, check out this site and follow the directions.

    http://www.geeks3d.com/20170213/how-to-disable-intel-turbo-boost-technology-on-a-notebook/

    I did that on my XPS 15 and it works great. They list a few different ways to do it, but I used the option under bullet point 2.4 there whereas you download a REG file which makes a registry entry for you that brings the option back under power management.
     
  2. John Ratsey

    John Ratsey Moderately inquisitive Super Moderator

    Reputations:
    6,807
    Messages:
    28,578
    Likes Received:
    1,563
    Trophy Points:
    581
    I just set the maximum processor state to 99% in the advanced power settings. It's my standard setting for battery operation as Turbo uses disproportionately more power than the increase in speed. I made this graph when I got my Precision 5510:
    Precision 5510 speed power.jpg

    John
     
    GoNz0 and pressing like this.
  3. bennyg

    bennyg Notebook Deity

    Reputations:
    250
    Messages:
    1,003
    Likes Received:
    307
    Trophy Points:
    101
    Throttlestop.

    Use the profiles. You can do it a few different ways, one might work better depending on your goal (what youre trying to fix)

    1. (best)
    Reduce maximum turbo multipliers (FIVR tab for SL/KL) as desired for each core use config (1 to 4 cores active). This is the way I've set it up on multiple lappys from locked core 2's through partially unlocked ivy bridges and a fully unlocked 6700K. You can set up 4 profiles for anywhere from maximum to minimum performance and the hotkeys work to trigger them from inside any program too without needing alt-tab, too easy.

    2.
    The Disable Turbo check box does exactly that. Your cpu will not go above base clock.

    3.
    The other way you could do it is by lowering the Turboboost power limits on the 2nd tab, I don't think these are fitted to profiles though. These limits are set higher than the 45W tdp of the cpu along with a timer and depending on how the EC is programmed to decide on can speed, the momentarily high tdp might cause a short fan speed spike (annoying). These can be a way to overclock locked CPUs, by setting this limit higher and the duration longer if available, it's how I get my ivy bridges to run at permanent 3.8-4.0 and 3.9-4.1ghz). By reducing the power limit it can still turbo to higher multi as needed to maintain the minor benefit to system responsiveness - but won't trigger the fan spike.

    Set the profile hotkeys as you wish (I use shift+ctrl+alt+1,2,3,4) and you can also set it to load your desired profile on boot. Getting TS to autostart is a hassle (needs to be done through Task Scheduler) but it can do exactly as you wish, very powerful useful tool.
     
    Last edited: Aug 11, 2017
  4. unclewebb

    unclewebb ThrottleStop Author

    Reputations:
    5,614
    Messages:
    4,794
    Likes Received:
    1,640
    Trophy Points:
    231
    The ThrottleStop Disable Turbo option works OK on every processor from Core 2 Duo to Kaby Lake and anything in between. The advantage of ThrottleStop over using Windows Power Option to disable Turbo Boost is that if you use ThrottleStop, you can create two keyboard short cuts so you can easily toggle Turbo Boost on and off. This allows a person to switch Turbo Boost on and off, even while you are in the middle of a game without having to exit back out to the desktop. Windows Power Options does not give you that kind of control over Turbo Boost.
     
    hmscott, pressing and Papusan like this.
  5. MaskedCarrot

    MaskedCarrot Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    Well I can confirm that using the REG file to get the Processor performance boost mode back and setting it to Disabled does indeed disable Turbo Boost.

    For a test I reset my power settings to default, set the Maximum Power State to 99% and then checked HWMonitor. It still showed the maximum freq including Turbo Boost.

    I then restored defaults again and Disabled the boost mode again and after rechecking HWmonitor it shows the Maximum freq correctly without Turbo Boost.

    So it may be an old function as someone said in this thread, although they deleted the post, but it still works fine.

    Also one thing I noticed in HWmonitor is that my battery has a MAX of 87 mWh out of the 97 it should be. The laptop is only a little over a month old and not used much yet, and I only charged the battery maybe 4 times or so. I am surprised it is already at 87.
     
    Last edited: Aug 14, 2017 at 9:53 PM
  6. namaiki

    namaiki Sydney, Australia Super Moderator

    Reputations:
    3,889
    Messages:
    6,107
    Likes Received:
    76
    Trophy Points:
    216
    On my laptop with a i7-3615QM setting the Max frequency to 99% disables Turbo Boost. If the reg file works for you then I think it should be fine.
    The battery wear seems a bit excessive. It can be worsened by benchmarking or gaming while on battery. If you are unhappy with the reported battery wear you should contact Dell support.
     
  7. GoNz0

    GoNz0 Laptop Engineer & Online games hosting.

    Reputations:
    169
    Messages:
    3,409
    Likes Received:
    1,060
    Trophy Points:
    231
    I have a reg entry for the max processor speed so I just set that to 2.8ghz and job done :D
     
Loading...

Share This Page