How can I find out what's preventing display and sleep timeouts?

Discussion in 'Windows OS and Software' started by CitizenInsomniac, Jul 8, 2020.

  1. CitizenInsomniac

    CitizenInsomniac Notebook Enthusiast

    Reputations:
    5
    Messages:
    25
    Likes Received:
    10
    Trophy Points:
    6
    My laptop, running Windows 10 version 2004 (10.0.19041.329), is no longer able to automatically turn off its display or go to sleep. My display timeout (while on AC power) is set to 30 mins, and sleep timeout is set to 60 mins.

    After 30 mins of idle time, it turns off the display - and then turns it back on a minute or two later. This pattern then continues indefinitely, with the screen constantly turning off and then back on every few minutes. It's incredibly frustrating.

    If I manually send the computer to sleep, then it stays asleep, so apparently sleep mode itself is not a problem.

    Running powercfg -requests lists NONE in every category.
    Running powercfg -waketimers shows a few scheduled tasks, but all of them scheduled to run many hours or days in the future.
    Running powercfg -lastwake shows either that the computer never went to sleep, or the last time I woke it from a manually induced sleep.

    I've checked Event Viewer for power management events and couldn't find any indication that the computer even attempted to go to sleep, let alone woke up from it.

    It seems pretty clear that something is preventing the system from continuing to stay idle after it reaches the initial display timeout, but I can't figure out what it is.

    Any ideas? Any tools I could use to figure which apps or drivers may be interrupting the idle timer or interfering with the display/sleep timeouts?
     
  2. Spartan@HIDevolution

    Spartan@HIDevolution Company Representative

    Reputations:
    30,125
    Messages:
    22,806
    Likes Received:
    35,132
    Trophy Points:
    931
    Take an image of all installed apps from the Control Panel / Programs & Features
     
  3. CitizenInsomniac

    CitizenInsomniac Notebook Enthusiast

    Reputations:
    5
    Messages:
    25
    Likes Received:
    10
    Trophy Points:
    6
    Could you elaborate? Are there specific apps that are known to interfere with idle timers?
     
  4. Spartan@HIDevolution

    Spartan@HIDevolution Company Representative

    Reputations:
    30,125
    Messages:
    22,806
    Likes Received:
    35,132
    Trophy Points:
    931
    There could be, I wanna see what apps you have installed. for example you can take a screenshot like this:

    1.png 2.png 3.png 4.png
     
  5. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    553
    Messages:
    3,387
    Likes Received:
    438
    Trophy Points:
    151
    Run the Computer in Safe Mode to verify the issue that will tell if that is a O/S or software install problem.
     
  6. CitizenInsomniac

    CitizenInsomniac Notebook Enthusiast

    Reputations:
    5
    Messages:
    25
    Likes Received:
    10
    Trophy Points:
    6
    Quick update, in case anyone else is running into the issue of Windows 10 (2004) not turning off the display or going to sleep as expected:

    This appears to be an issue with how idle time is measured by Windows. I don't have a full explanation yet, but I have managed to find a workaround for the problem. Running an app such as IdleClock which measures idle time seems to fix the problem for some reason. When the app is running and there is no user interaction, Windows correctly honors the display & system sleep timers set in the power management policies. When the app isn't running, Windows seems to have trouble recognizing that the system is idle and consequently prevents the display and system from entering sleep mode.

    One solution is to always run IdleClock in the background, though since the app doesn't minimize to the system tray that can be annoying. Another is to automatically launch and terminate IdleClock with Task Scheduler. Create a new task, set the app to launch at user logon and repeat starting every hour, and in the Conditions tab enable "Start the task only if the system is idle for 30 mins", enable "Wait for idle for 1 hr", and enable "Stop if the computer ceases to be idle". If your sleep timers are shorter than 30 mins, you may want to choose shorter values. This will cause IdleClock to start whenever you're not using the computer for >30 mins, and terminate as soon as you start using it again. While IdleClock is running Windows will correctly detect idle time and respect system sleep policies.
     
    Vasudev likes this.
  7. Mr. Fox

    Mr. Fox BGA Filth-Hating Elitist

    Reputations:
    34,369
    Messages:
    37,013
    Likes Received:
    61,827
    Trophy Points:
    931
    Chances are good that a 3D process is running that is causing it. Download GPU Shark and run it. It will show you any 3D processes running at idle.

    You can use Autoruns to keep those things in check.
     
    Papusan and Vasudev like this.
Loading...

Share This Page