High CPU Temperature when using Comfort Mode GT75VR 7RE

Discussion in 'MSI' started by nihil6686, Oct 25, 2019.

  1. nihil6686

    nihil6686 Notebook Enthusiast

    Reputations:
    5
    Messages:
    25
    Likes Received:
    14
    Trophy Points:
    6
    For some reason, whenever I put my laptop in Comfort mode (Idle) the CPU temperature will shoot up to 67 C and stay there but if I switch to Sport or Eco mode then the temperature will go down to 47 C. Is there a reason for this?
     

    Attached Files:

  2. Arrrrbol

    Arrrrbol Notebook Deity

    Reputations:
    3,129
    Messages:
    713
    Likes Received:
    1,053
    Trophy Points:
    156
    Its just the way the fan curve is set up.
     
  3. nihil6686

    nihil6686 Notebook Enthusiast

    Reputations:
    5
    Messages:
    25
    Likes Received:
    14
    Trophy Points:
    6
    So, it's not a problem/going to damage anything for my CPU temperature to sit around that temperature on idle?
     
  4. zipperi

    zipperi Notebook Evangelist

    Reputations:
    53
    Messages:
    672
    Likes Received:
    178
    Trophy Points:
    56
    My GT70 CPU has been floating round 65 C for 6 years - no hard feelings. If it were 80+ I'd be worried.
     
    Kevin@GenTechPC likes this.
  5. nihil6686

    nihil6686 Notebook Enthusiast

    Reputations:
    5
    Messages:
    25
    Likes Received:
    14
    Trophy Points:
    6
    Fixed it. It has to do with VR ready disabling processor idle state
    https://forum-en.msi.com/index.php?topic=295133.0

    The symptom: the processor doesn't slow down (does not decrease its clock frequency when there's no need to work so fast, no workload).

    The cause: the processor does not enter the idle state.

    The solution: change the registry setting that make processor idle state setting visible then enable Processor Idle state.

    Steps to follow:
    1) open up the system registry: Windows Key + R, type regedit, press enter;
    2) go to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\5d76a2ca-e8c0-402f-a133-2158492d58ad];
    3) right click Attributes in the right pane, select Modify, then change the value to zero;
    4) now go to Power options: right click the battery icon at the lower right corner of your screen, choose Power Options;
    5) press Change plan settings of your active power plan;
    6) press Change advanced power settings;
    7) go to Processor power management;
    8) open up the Processor idle disable;
    9) enable idle both for On battery and Plugged in modes.

    DONE!!!

    Note: the setting is only active for the current power plan. For other power plans you'll have to repeat steps 5-9.
     
    Kevin@GenTechPC likes this.
Loading...

Share This Page