[HELP] V15 Nitro Black Edition won't turn on after installing SSD

Discussion in 'Acer' started by paullagreca, Jul 7, 2016.

Thread Status:
Not open for further replies.
  1. paullagreca

    paullagreca Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    So I was upgrading my V15 nitro black edition right. I opened it up no roblem and firs tinstalled an M.2 SSD and the computer still turn on and stuff after I installed that so I was able to clone my OS onto it. So then I turned off the PC so I could install a 2.5 SSD instead of the stock HDD that is already in the laptop. I didn't do anything differently from the first time, didn't touch any other cables or anything on the motherboard, but the laptop simply wont charge or turn on!



    I did some digging and found this post which is similar to my problem.

    http://forum.notebookreview.com/threads/help-acer-asipre-v15-nitro-wont-power-up-on-battery.785204/



    They talked about some microswitch, but I made sure everything was tight and in place and still nothing won't turn on. I even tried manually pressing what I assume is that microswitch, above the HDD bay, and still no results. I also tried pushing the button to reset your battery on the back of the laptop with a needle and that did nothing. Does anyone have any solutions????
     
  2. Starlight5

    Starlight5 W I N T E R B O R N

    Reputations:
    516
    Messages:
    2,897
    Likes Received:
    1,350
    Trophy Points:
    181
    @paullagreca did you try booting with HDD? New SSD may be incompatible with BIOS, it happens very rare but still possible. Is it a Crucial/Micron drive?
     
  3. paullagreca

    paullagreca Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Yes, unfortunately it still would not turn on. I also tested the charger with a volt-meter, and the charger is working just fine.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page