Help needed: 8740w + GTX 1070

Discussion in 'HP' started by triturbo, Apr 3, 2018.

  1. triturbo

    triturbo Long live 16:10 and MXM-B

    Reputations:
    1,565
    Messages:
    3,742
    Likes Received:
    1,186
    Trophy Points:
    231
    I've got recently a Zotac 1070. I've used an external display (DP) to install it, but the internal screen (eDP) is not recognized at all. Any input would be appreciated. Thanks.

    [​IMG]

    @ChanceJackson @Prema
     
  2. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    556
    Likes Received:
    228
    Trophy Points:
    56
    did you flash it to the MSI bios yet? I believe your laptop mobo id is 1520 correct? were there any lines in the unmodified nvbli.inf regarding the 1520?
     
  3. triturbo

    triturbo Long live 16:10 and MXM-B

    Reputations:
    1,565
    Messages:
    3,742
    Likes Received:
    1,186
    Trophy Points:
    231
    Not yet, stock Zotac. Should I?

    Nope, none at all. Should I download the latest driver that was intended for my machine? If yes, the 1070 wasn't available back then.
     
  4. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    556
    Likes Received:
    228
    Trophy Points:
    56
    I suggest flashing to the msi 1070 mxm vbios and seeing if that will recognize the internal screen after reboot, the zotac vBios was never intended for use with eDP and likely lacks that info

    if that doesn't work download the latest nvidia driver HP has for your machine and explore the nvbli.inf for all references to your machine 1520 chances are all official video card configuration use the same Section ID # investigate that section ID and make sure the same installer options in the Section ID you use in your modified INF mirrors what was in the official inf.


    I have some vBioses in http://forum.notebookreview.com/thr...a-g1-zbook-15-but-its-not-perfect-yet.803964/


    *Fair warning my laptop is Optimus capable and that is how i use my 1070n i wasn't able to get it to display to my internal screen with Hybrid Graphics off
     
    Last edited: Apr 3, 2018
  5. triturbo

    triturbo Long live 16:10 and MXM-B

    Reputations:
    1,565
    Messages:
    3,742
    Likes Received:
    1,186
    Trophy Points:
    231
    How was the msi vBIOS working for you?
     
  6. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    556
    Likes Received:
    228
    Trophy Points:
    56
    It was fine except it drew more power @Striker1234 was able to to get his zotac card to display on the internal screen of his eDP dell using the msi vbios
     
    Last edited: Apr 4, 2018
    triturbo likes this.
  7. triturbo

    triturbo Long live 16:10 and MXM-B

    Reputations:
    1,565
    Messages:
    3,742
    Likes Received:
    1,186
    Trophy Points:
    231
    What version of NVFlash you've used? I've tried to no avail both Windows and DOS versions. The DOS ones say that they can't recognize the GPU. The Windows versions all list the Read Me file no matter which key I press, only Q works, but that's to quit.
     
  8. ChanceJackson

    ChanceJackson Notebook Evangelist

    Reputations:
    39
    Messages:
    556
    Likes Received:
    228
    Trophy Points:
    56
    hmm I t was a while ago but I used the windows version of nvflash from an elevated(Admin) command prompt
     
  9. triturbo

    triturbo Long live 16:10 and MXM-B

    Reputations:
    1,565
    Messages:
    3,742
    Likes Received:
    1,186
    Trophy Points:
    231
    Elevated CMD is what I'm using as well. Can you check, or send me the version that you have used? Thanks!
     
  10. aaronne

    aaronne Notebook Evangelist

    Reputations:
    287
    Messages:
    426
    Likes Received:
    447
    Trophy Points:
    76
    triturbo and ChanceJackson like this.
Loading...

Share This Page