Help me get proper wifi speed

Discussion in 'Networking and Wireless' started by Raidriar, Dec 13, 2015.

Thread Status:
Not open for further replies.
  1. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,580
    Messages:
    5,621
    Likes Received:
    4,060
    Trophy Points:
    431
    I need help ladies and gents. I have two FIOS routers: One is a quantum gateway, the other is the actiontec rev I. I want to use both. The primary is the quantum gateway hooked to coax with DHCP enabled on channel 11, and the speed is great, max, full, no problems. I have the revision I set up as slave on 192.168.1.2 on channel 6, and I see that it is working fine, but when I run a speed test, it ramps up to a fast speed sometimes, then quickly drops off to a snail speed, but it usually stays snail speed on wifi, even though ethernet is full speed. WHY? Both routers are only being used in the rooms they are in, I don't need the signal to run any further than that.
     
  2. downloads

    downloads Super Moderator Super Moderator

    Reputations:
    7,680
    Messages:
    8,678
    Likes Received:
    2,114
    Trophy Points:
    331
    What do you mean exactly by "as a slave" - is it set up properly as an access point?
     
  3. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,580
    Messages:
    5,621
    Likes Received:
    4,060
    Trophy Points:
    431
    Yes, I have reserved 192.168.1.1-192.168.1.10 on the primary router, and assigned 192.168.1.2 as the slave IP on the secondary router with DHCP disabled on the second router. For example last night, I get 30/30Mbps no problem, but the connection is rated at 75/75Mbps. The primary router reaches this fine over wifi and ethernet, but the secondary router can't do this unless I connect my computer with ethernet to it.
     
  4. downloads

    downloads Super Moderator Super Moderator

    Reputations:
    7,680
    Messages:
    8,678
    Likes Received:
    2,114
    Trophy Points:
    331
    This sort of sounds like you might be connected at 150mbps instead of 300mbps - the speed seems to indicate that.
    802.11n compliant routers should only use 20MHz channel width when there are neighboring networks that are overlapping the channel you are on, so it's possible that your router revers from 40MHz channel width to 20MHz because of that.

    Use software like inSSIDer (earlier versions were free, up to v3 i think) to check which channels are occupied and change the channel Actiontec is using if necessary. Also make sure that it's set to Auto or 40MHz channel width, not 20MHz.
     
  5. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,580
    Messages:
    5,621
    Likes Received:
    4,060
    Trophy Points:
    431
    I do
    There is no overlap in the channels of the two. Primary is on 11, secondary is on 6, inssider confirms this. I don't see any options to change the frequency though. The link scores is fine and stable flat line of -35dB on the second router. Changing the broadcast signal from b/g/n to n only has no impact.
     
  6. downloads

    downloads Super Moderator Super Moderator

    Reputations:
    7,680
    Messages:
    8,678
    Likes Received:
    2,114
    Trophy Points:
    331
    I don't mean overlap between your two routers but between yours and neighbors'.
    You won't be able to see all of the 2.4GHz devices anyway since it's an open band but Wi-Fi is by far the most popular thing using it so it's the most likely culprit.
     
  7. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,580
    Messages:
    5,621
    Likes Received:
    4,060
    Trophy Points:
    431
    I'm not understanding, the router is in my room and I can't get full speed 10 feet away from it over wifi in my bed. That is really stumping me. There doesn't seem to be much interference from the neighbors.
     
  8. ajkula66

    ajkula66 Courage and Consequence

    Reputations:
    3,018
    Messages:
    3,199
    Likes Received:
    2,318
    Trophy Points:
    231
    What happens if you set the primary (Quantum) router in the bridge mode and disable its wireless capability entirely? Any change in the behaviour of the second router?
     
  9. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,580
    Messages:
    5,621
    Likes Received:
    4,060
    Trophy Points:
    431
    No, but oddly enough...I tried different wifi channels today and found best performance on channels 3,4,7,8 and 10...which absolutely makes no sense to me considering most everybody in the neighborhood is on channel 1 or 11. I'm currently on channel 7 on the secondary and 11 on primary. The secondary router now reaches 63/65 reliably over wifi.
     
  10. downloads

    downloads Super Moderator Super Moderator

    Reputations:
    7,680
    Messages:
    8,678
    Likes Received:
    2,114
    Trophy Points:
    331
    So it was interference, just not from Wi-Fi - a lot of devices use 2.4GHz band from child monitors through Bluetooth to all those proprietary wireless mice and keyboards - none of which would show on inSSIDer graph because none is Wi-Fi.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page