[HELP] Laptop screen suddenly going 60Hz

Discussion in 'Gaming (Software and Graphics Cards)' started by vIkInG_w0w, Oct 23, 2019.

  1. vIkInG_w0w

    vIkInG_w0w Notebook Consultant

    Reputations:
    18
    Messages:
    128
    Likes Received:
    29
    Trophy Points:
    41
    [So I don't know under which thread to post this but since this started happening after I uninstalled "legacy" graphics drivers and switched to Intel and NVIDIA DCH, I figured I should post here]

    So like I said, I used DDU to clean the GPU drivers so that I can switch to DCH and installed everything successfully. Everything is running fine like normal except after a certain amount of time (>20min) of mostly idle (browsing the web, watching a movie) my 144Hz screen suddenly "lags" like a 60Hz. It stays that way until I open a game (CSGO) and quit back and it reverts back to 144Hz smoothness. Another temporary solution is going to NVCP and setting refresh rate to 60Hz, hitting apply but cancelling right after.
    I have set everything to Performance mode in Intel Graphics Command Center, NVIDIA Control Panel, GeForce Experience, Windows Battery, etc. This never happened before during the legacy driver days. Any permanent solution is highly appreciated.

    P.S. Proper procedure was followed during DDU (Safe Mode with restarts) and my Performance settings are the exact same as before.
    P.P.S Yes I do use GeForce Experience to record some highlights and stuff and find it useful. I've been using it since I got this laptop last year and have never run into a problem.
     
  2. joluke

    joluke Notebook Deity

    Reputations:
    698
    Messages:
    1,386
    Likes Received:
    816
    Trophy Points:
    131
    Set the browser to use the nvidia GPU... most likely its always changing between the integrated gpu and the nvidia..
     
  3. vIkInG_w0w

    vIkInG_w0w Notebook Consultant

    Reputations:
    18
    Messages:
    128
    Likes Received:
    29
    Trophy Points:
    41
    I dunno if that's the case since my screen has G-Sync which requires a dedicated GPU. I am also not running in MSHybrid mode.
     
Loading...

Share This Page