1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

HELP - G72GX Double keystroke keyboard problem

Discussion in 'Asus' started by xstahsie, Mar 17, 2010.

Thread Status:
Not open for further replies.
  1. xstahsie

    xstahsie Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    I hope someone has a solution to this double keystroke keyboard problem that I am having with mmy (<-- see ) G72GX laptop.

    Here is what I have attempted but all FAILED.

    1. Updated to the latest BIOS.
    2. Restored Win 7 OS to factory using Recovery Disc supplied by ASUS.
    3. Updated the ATK software available on ASUS website.
    4. EXCHANGED the laptop at Best Buy for a new G72GX, But new G72GX has the SAME problem.
    5. Updated all available Windows Update.
    6. Did a clean installed of the retail copy of Win 7 Ultimate on a nnew (<-- see ) hard drive, withouut (<-- see ) any drivers or updates.

    So, as you can see, I have tried many methods of fixing this double keystroke keyboard issue.

    The problem is thaat (<-- see ) it randomly double type keys every few seconds to every 2-3 minutes. VERY ANNOYING.

    Any help from this community would be appreciated. Thank you.
     
  2. mylowrider

    mylowrider Notebook Consultant

    Reputations:
    17
    Messages:
    197
    Likes Received:
    0
    Trophy Points:
    30
    The problem could be somewhat related to your typing style.

    You can adjust how the keyboard reacts to your input by going to the Control Panel > Ease of Access > Look under Ease of Access Center > Change how keyboard works.

    There you can change different parameters such as "Turn on Filter Keys" to ignore repeated strokes.
     
  3. ren3g7ade

    ren3g7ade Notebook Evangelist

    Reputations:
    138
    Messages:
    456
    Likes Received:
    0
    Trophy Points:
    30
    maybe you are having a latency issue with your acpi. go to device manager and under Batteries (Battery), disable the acpi compliant control battery method. That might help...
     
  4. xstahsie

    xstahsie Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5

    Turning on the filter keys option w/ avoid repeat keystroke didn't help. Thanks anyways.
     
  5. ren3g7ade

    ren3g7ade Notebook Evangelist

    Reputations:
    138
    Messages:
    456
    Likes Received:
    0
    Trophy Points:
    30
    did you try disabling the entry i mentioned above for acpi?
     
  6. xstahsie

    xstahsie Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Thanks for trying to help me out. Yeah, I just tried it out and didn't help either. I disabled it in Device Manager, restart the PC, and launch Wordpad and typed away but i'm still getting double keystroke.

    Any other suggestions? Thanks. :(
     
  7. mylowrider

    mylowrider Notebook Consultant

    Reputations:
    17
    Messages:
    197
    Likes Received:
    0
    Trophy Points:
    30
    You could go to best buy and get another replacement.
     
  8. xstahsie

    xstahsie Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    I have thought about it, but in the meantime... is there a solution to this problem?
     
  9. DCx

    DCx Banned!

    Reputations:
    299
    Messages:
    2,651
    Likes Received:
    0
    Trophy Points:
    55
    Heh, take your keyboard off, use some doublesided carpet tape and make sure the keyboard stays FIRM to the laptop. The same double-tap problem occurred in many 1000h netbooks, and that was the solution (until asus brought out a bios fix).
     
  10. ren3g7ade

    ren3g7ade Notebook Evangelist

    Reputations:
    138
    Messages:
    456
    Likes Received:
    0
    Trophy Points:
    30
    Try disabling the ATKGFNEX Service. It is for the hotkeys. It might be interfering with the keyboard as it is polling. It's worth a shot. I saw someone on another forum mention stuttering as a result of it.
     
  11. xstahsie

    xstahsie Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Well, I want to avoid taking the keyboard off for now but thanks for the suggestions. :)
     
  12. xstahsie

    xstahsie Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Ok, I tried it but it sstill (<-see) the same problem.

    I had a feelinng (<-see) that the ATKGFNEX Service might not help since I did install a retail copy of Win 7 Ultimate without any ASUS sofftware (<-see), drivers, services, etc--just the 30-day Win 7 trial and AS-IS. So, I do not think it is an ASUS application or services that is causing the problem.

    Any more suggestions? Thanks again.
     
  13. ren3g7ade

    ren3g7ade Notebook Evangelist

    Reputations:
    138
    Messages:
    456
    Likes Received:
    0
    Trophy Points:
    30
    looks like it may just be the hardware...i'm out of ideas. you might try calling asus support or emailing them and seeing with they say.
     
  14. xstahsie

    xstahsie Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Alright. Thanks for your help anyways.
     
Thread Status:
Not open for further replies.

Share This Page