HELP!!!!acer 6920g not starting

Discussion in 'Acer' started by switch44, Aug 11, 2009.

Thread Status:
Not open for further replies.
  1. ATG

    ATG 2x4 Super Moderator

    Reputations:
    3,306
    Messages:
    4,461
    Likes Received:
    344
    Trophy Points:
    151
    So it's not the LCD. But those flashes...I don't know what to think...GPU problem maybe? Does your laptop comes with GPU or IGP? I have no idea if this is possible but if you have a GPU - it's in a MXM slot, not soldered. Maybe when the laptop fell the card moved...I repeat, I have no idea if this is at all possible.
     
  2. DarkSilver

    DarkSilver MSI Afterburner

    Reputations:
    378
    Messages:
    2,249
    Likes Received:
    0
    Trophy Points:
    55
    I won't be the GPU failure I guess. Because I have tried to uninstall the GPU. The LCD screen still can function without any VGA or CPU installed.
    However, without intel accelerator or a GPU, even a ancient game warcraft 3 or maplestory can't be started.

    However, I would suggest to check the GPU too even the possibility is low. Check everything is the best and plug-in them nicely.
     
  3. switch44

    switch44 Notebook Enthusiast

    Reputations:
    0
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    15
    well...i checkd all da connections i cud check....
    i even gave it to a service place(cudnt do it thru warranty cuz i dun hv ne itw centres in ma place) and he told me its a motherboard problem because he couldnt find any other fault with it.and now the problem has become even worse.the comp doesnt even start.the light comes on when i put on da comp and goes off as soon as i leave the power button.if i hold it the lights keep flickering.even if i move my finger along the cinedash it starts to flicker.very wierd .im planning on sending it back where i bought it from.any idea why this could happen.i gotta wait for someone to go back to send with them.
     
  4. DarkSilver

    DarkSilver MSI Afterburner

    Reputations:
    378
    Messages:
    2,249
    Likes Received:
    0
    Trophy Points:
    55
    I can tell you really need to send your AS6920G to the Acer factory. Only they know how to fix the bloody motherboard.
    As you tell me before, I know your laptop is kinda strange, even with undervolt, your CPU temperature is just decreased a little. Moreover, the GPU without overclock can hit a max temperature about 77C.
    I myself GPU only hit 73-75C max temp with overclock(595/1370/460).
    I don't know what your motherboard exact problem. But I think it is related to the temperature.
    Another question is, did you remove all the mesh screen(block dust) on the laptop casing which located at the bottom of the laptop?
    I do not suggest to remove it. My area is dusty and dirty(eraser remains, hairs and tiny pieces of papers). I can see the mesh screen trapped with all these stuffs. Imagine if you do not have the mesh screen, these stuffs can get into your laptop inner core. It is not only increasing temperature, it can kill the laptop directly too. My friends laptop got his hairs, dust, eraser remains) entered the Fan and the Fan become malfunction after that.
     
  5. switch44

    switch44 Notebook Enthusiast

    Reputations:
    0
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    15
    nono i dindnt remove the mesh..
     
  6. nawafshrf

    nawafshrf Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I've the similar problem. My Acer 6920G shuts down random in normal mode, but stays normal in safe mode. Somebody,please help me out! I've Windows 7 32bit installed in my system. Did a clean install recently after the problems showed up. After the reinstall ,it still remains the same. It shows the same problem as before. I can only operate in safe mode.
     
  7. DarkSilver

    DarkSilver MSI Afterburner

    Reputations:
    378
    Messages:
    2,249
    Likes Received:
    0
    Trophy Points:
    55
    Why you revive the old topic?

    nawafshrf,
    It seems your problem is more to HARDWARE instead of SOFTWARE.

    Your Windows 7 is ORI or FAKE?
     
Loading...
Thread Status:
Not open for further replies.

Share This Page