Having trouble with low fps in Starcraft 2 on my gtx 485m!

Discussion in 'Sager and Clevo' started by decayedmatter, Sep 30, 2011.

Thread Status:
Not open for further replies.
  1. decayedmatter

    decayedmatter Notebook Evangelist

    Reputations:
    22
    Messages:
    409
    Likes Received:
    0
    Trophy Points:
    30
    My notebook specs are in my sig.

    It's really weird cause on notebook check it says i should be able to run SC2 on ultra at 1080p at 56 fps, yet i'm only getting 15-25 fps no matter what graphical setting i choose at 720p!

    There's gotta be some well known problem i am not aware of. This just doesn't seem normal. My current geforce drivers are 285.38 (the ones released for battlefield 3)

    Do you think i should try reverting back to a non beta video card driver? Starcraft 2 isn't very fun at 15 fps during intense battles.

    Here is a screenshot i took at 1360x768 at all medium settings....vsync off.

    http://img827.imageshack.us/img827/7470/sc22011093023115469.jpg

    Notice the MSI afterburner FPS counter in the top left...15 fps....on medium, at 1360x768? Seriously? And thats not even a big battle thats just blowing up a propaganda sign in the first mission. Something has got to be wrong here.
     
  2. Anthony@MALIBAL

    Anthony@MALIBAL Company Representative

    Reputations:
    616
    Messages:
    2,771
    Likes Received:
    3
    Trophy Points:
    56
    I'd say try rolling back to the older WHQL (non-beta) drivers. Also turn off/down Anti-aliasing and V-sync and see if that helps. I'm sure you've checked this, but also make sure you're running in high performance power mode.
     
  3. decayedmatter

    decayedmatter Notebook Evangelist

    Reputations:
    22
    Messages:
    409
    Likes Received:
    0
    Trophy Points:
    30
    Ahhhhhh crap, i was running in power save mode from the last time i was on the battery. I turned it to high performance and the fps went up to 60 fps solid, thanks!

    Man that means the recent Battlefield 3 beta video i uploaded on my YT channel was also running in powersave mode. I might need to retest that now in high performance. I mustve been cutting my fps in half!
     
  4. Ryan

    Ryan NBR Moderator

    Reputations:
    2,320
    Messages:
    2,512
    Likes Received:
    17
    Trophy Points:
    56
    Another power options problem solved.. :D

    Set high performance to show Aero, and power saver to disable Aero.

    That way, you will know right away if the system is in high performance or in power saver.
     
  5. decayedmatter

    decayedmatter Notebook Evangelist

    Reputations:
    22
    Messages:
    409
    Likes Received:
    0
    Trophy Points:
    30
    Good idea. I didn't know power saver lowered the overall system performance, i thought it just decreased the timwe it takes to go into sleep/dim the monitor and stuff like that.
     
  6. Thisisalamp

    Thisisalamp Notebook Deity

    Reputations:
    256
    Messages:
    758
    Likes Received:
    0
    Trophy Points:
    30
    Power saver actually lowers the clocks/frequencies of the CPU/GPU...so not to strain it and ultimately less battery drainage.
     
  7. decayedmatter

    decayedmatter Notebook Evangelist

    Reputations:
    22
    Messages:
    409
    Likes Received:
    0
    Trophy Points:
    30
    I am learning new things about this laptop every day. Even after owning it since early summer!
     
Loading...
Thread Status:
Not open for further replies.

Share This Page