Hands on Dell Precision 7710

Discussion in 'Dell Latitude, Vostro, and Precision' started by varnum, Dec 9, 2015.

  1. nookformind

    nookformind Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    6
    Hello, i want to replace the LCD Back Cover Lid Assembly of my 7710 (UHD 4K screen) but i can not find new one. But it seems that back cover lid of FHD screen is the same with the one of UHD screen, could anyone can confirm this please?

    Thanks much!
     
  2. ygohome

    ygohome Notebook Deity

    Reputations:
    210
    Messages:
    1,206
    Likes Received:
    146
    Trophy Points:
    81
    @nookformind

    I went to Dell website and entered my service tag and it gave me part#s that make up the display assembly. Dell says the cover for my UHD 7710 is part# 942J9.
    upload_2018-4-10_15-18-41.png

    I can look for that part on Parts People or I can enter my service tag and they show the same part# dell showed plus two other it says are interchangeable.
    upload_2018-4-10_15-16-29.png

    I can't say for certain if it is same the FHD uses but probably is. Also appears to be same cover used on the 7720.
     
    nookformind likes this.
  3. nookformind

    nookformind Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    6
    Thank you, i think they're the same too
     
  4. kengo2r

    kengo2r Notebook Enthusiast

    Reputations:
    0
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    5
    I would like to put a 3rd hard drive in my 7710.

    I currently have the oem M.2 drive and then I added a 2nd 2.5" SSD:
    1. 400-AJBI - 1TB M.2 PCIe Solid State Drive, MPWS,
    2. Samsung SSD 850 EVO 2TB SATA iii 2.5" (P/N MZ7LM2T0, model MZ-75E2T0, S/N S2RLNX0H602801R)

      It sounds like there is room for another M.2 drive. Would the Samsung 860 work? Any issues? Thanks!

    3. Samsung 860 EVO 2TB M.2 SATA Internal SSD (MZ-N6E2T0BW)
      https://www.amazon.com/dp/B07822SVMS/
     
  5. Aaron44126

    Aaron44126 Notebook Virtuoso

    Reputations:
    598
    Messages:
    2,673
    Likes Received:
    504
    Trophy Points:
    131
    The Samsung 860 EVO should work without any hassle.
     
  6. ygohome

    ygohome Notebook Deity

    Reputations:
    210
    Messages:
    1,206
    Likes Received:
    146
    Trophy Points:
    81
    Here is something to consider if you are using an older ePort Dock and not getting signal on your external displays. This drove me nuts for at least an hour.

    older E Port docks (those without blue USB 3.0 ports) do not have DisplayPort 1.2.

    The EPort Docks with USB 3.0 do have Display Port v1.2.

    I have a mix of older and newer E Docks and I've been using the newer. I was rearranging my office and I connected my 7710 to one of the older EPort docks I have here without thinking much about it. My Dell U2715H display was not seeing display port signal. My other displays were working. I was trying everything, bios options, then I remembered I had the U2715H set to DP1.2 incase I wanted to daisy chain but the old Dock only puts out 1.1 signal.

    I've switched back to the newer release of Eport Dock with 1.2. I couldve disabled the daisy chain ability in the monitor though if I wanted to continue using the older dock with DP1.1. To change the monitor settings on the U2715H for DP1.1 <-> DP1.2 it must see an input signal first.

    Have a good day
     
    Last edited: May 18, 2018
    jeremyshaw and alexhawker like this.
  7. ygohome

    ygohome Notebook Deity

    Reputations:
    210
    Messages:
    1,206
    Likes Received:
    146
    Trophy Points:
    81
    Can someone help/enlighten me on if this is windows or my drivers or messed up calibration profile or something else...

    When Win10 shuts off one of my displays after being inactive for set amount of time or when it goes to sleep, when the displays turn back on one of my displays is very over saturated colors. I have three displays:
    laptop UHD[1]; Dell 2560[2]; Asus 2560[3].​

    It's usually display 3 that gets oversaturated, but sometimes it's display 2. When I restart the laptop they are all perfect again. I'm not into video or photography so I've not used any fancy calibration software and I've simply set the individual displays color settings in their own OSD menus to adjust red, green, blue, gama, temp, etc. getting just right across all the displays.

    My "workaround" has been to prevent windows turning them off or going to sleep. At end of my day I shut the system down.

    I need help correcting this behavior. I don't remember this happening before but maybe I was ignorant to the over saturation of colors until now. Maybe one of my external displays is picking up wrong icc profile or maybe picking up the laptops display profile when it wakes from sleep? I don't know.

    Thanks
     
    Last edited: May 24, 2018
  8. rinconmike

    rinconmike Notebook Evangelist

    Reputations:
    38
    Messages:
    313
    Likes Received:
    20
    Trophy Points:
    31
    Will the new Samsung 970 pro work in the 7710? I have issues with the 960 pro where windows explorer is slow when renaming files and some other items. I think it is from the newer firmware that they wound up pulling so i was thinking of trying the 970.

    Sent from my Pixel 2 XL using Tapatalk
     
  9. Aaron44126

    Aaron44126 Notebook Virtuoso

    Reputations:
    598
    Messages:
    2,673
    Likes Received:
    504
    Trophy Points:
    131
    There's no reason to think that the Samsung 970 Pro (or any NVMe drive) would not work fine in the 7710. Samsung drives usually work best if you install the Samsung NVMe driver which you can get from their support site.
     
  10. rinconmike

    rinconmike Notebook Evangelist

    Reputations:
    38
    Messages:
    313
    Likes Received:
    20
    Trophy Points:
    31
    Thanks. I do have the latest 3.0 driver.

    Sent from my Pixel 2 XL using Tapatalk
     
Loading...

Share This Page