[GUIDE] Installing and Overclocking the AMD Mobility 7970 in the M17x R3,an illustrated guide

Discussion in 'Alienware 17 and M17x' started by SlickDude80, Apr 24, 2012.

  1. TostitoBandito

    TostitoBandito Notebook Evangelist

    Reputations:
    109
    Messages:
    439
    Likes Received:
    1
    Trophy Points:
    31
    Question - the plastic stoppers on the 4 screw holes for the GPU heatsink attachment, are they vital? If so, any ideas where to get replacements?
     
  2. speige

    speige Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    retro_wol (or anyone else),

    Can you help me get my 7970M working on my Alienware M17x R3 ?

    I've followed all the instructions, however it's not working.

    Here's what I've done:
    Install modded A08 Bios from OP's link.
    Changed to PEG
    Disabled IGFX
    Installed latest drivers from AMD's site (radeon-crimson-15.12-win10-64bit)

    Windows boots fine. The device manager recognizes the card & shows drivers installed. Intel HD 3000 is gone.

    However, as soon as I open any programs at all, the screen goes grey (back-light on, no pixels/color). I can hear the fans running, but i've verified that windows has actually crashed, it's not just the display.

    Before it crashes, I can click around in windows no problem, only certain programs cause it to crash. It happens *immediately* after launching them. Usually before their GUI shows up. But, it's not just video games, it's things like internet browsers.

    I've run GPU-Z & the temperatures seem fine (~ 55 celcius)

    I wonder if I need to disable Enduro/PowerXpress through a modded driver, but haven't tried that because I haven't found a valid download link yet.

    I upgraded to the 7970M because I was having identical issues with the previous card that came with the laptop (6970M).

    I've wondered if there could be something wrong with the motherboard or the mux. I've debated baking the motherboard in the oven to see if it'll reflow any de-soldering issues.

    I've tried Windows 7 with identical issues except it's a blue screen with vertical lines instead of grey-screen (not the blue screen of death with white writing, a teal-blue with no writing).

    I've tried most of the combinations of muxless/fixed/dynamic/etc in the bios, but may have missed a combination. (had to blind flash a few times due to 8 beeps)
    I've tried the A12 unlocked bios.
    I've tried many different versions of official AMD drivers & Dell/Alienware from the last several years.

    I've tried the disable/enable Ultra-Low-Power-State through the AutoHotKey file (but didn't verify if the registry had actually changed).

    If I disable the device in the device manager (or uninstall the drivers), the machine runs fine (except no video games obviously).

    My gut tells me either there's something faulty in the Motherboard/mux, or I need custom drivers. Maybe I'll research how to get a crash dump & analyze it to see if it has any clues.


    Any suggestions?


    If anyone has this working, maybe they could PM me & we could verify bios settings side-by-side, etc to see if there's something I have different.

    My email is devingarner@gmail.com

    Thanks for your help.
    Devin
     
    Last edited: Feb 5, 2016
  3. spoonjaffa

    spoonjaffa Notebook Consultant

    Reputations:
    65
    Messages:
    132
    Likes Received:
    29
    Trophy Points:
    41
    Do all dell vbios versions work for an m17x r3? how about a 015.022.000.001?
     
  4. arturo74r

    arturo74r Notebook Enthusiast

    Reputations:
    0
    Messages:
    31
    Likes Received:
    3
    Trophy Points:
    16
    I came here for the exact same question. Anyone?

    I have a 7970m with 015.022 vbios and short x-spreader (bracket). I was able to use longer screws to reach this bracket but I am not sure which Dell (alienware) laptop this came out of.

    I tried it on my R3 but all I get is a black screen (no beeps), no windows sound
     
  5. cope123abc

    cope123abc Notebook Consultant

    Reputations:
    5
    Messages:
    141
    Likes Received:
    40
    Trophy Points:
    41
    Guys did anybody get the 7970M in the M17X R3 Fan to work on it's own without the need for HWinfo ? I want the bios to manage the temps not some software :)
     
Loading...

Share This Page