[Guide] Improving Battery Life on Windows [+Enabling Deeper C States]

Discussion in 'Windows OS and Software' started by Che0063, Apr 14, 2018.

?

What was your increase in battery life after following this guide?

  1. None (decreased)

    23.8%
  2. 20%

    19.0%
  3. 40%

    38.1%
  4. 50% +

    19.0%
  1. MacHater

    MacHater Notebook Evangelist

    Reputations:
    146
    Messages:
    364
    Likes Received:
    10
    Trophy Points:
    31
    I tried those, made zero difference. Here's a snapshot of task manager: https://i.imgur.com/91t36xz.jpg (sorted by CPU Usage)
     
  2. Maleko48

    Maleko48 Notebook Evangelist

    Reputations:
    185
    Messages:
    673
    Likes Received:
    503
    Trophy Points:
    106
    Here is my system with Chrome minimized (and 39 tabs open):

    upload_2019-6-22_17-33-56.png

    Are all of your Task Manager entries listed as either Low or Very Low power usage?

    upload_2019-6-22_17-36-1.png

    For a while my Antimalware Windows service would run hard every time I rebooted my machine and cause High or Very High power consumption (although not much actual CPU or Disk load). It would eventually stop itself and finish after an hour or more generally, but the whole process happened every damn time I restarted my laptop. It stopped after I did a deep clean of my services and other junk recently.

    How many total processes do you have running? (again this is mine with Chrome open and 39 tabs)
    upload_2019-6-22_17-38-26.png

    Additionally do you have an OEM power manager? I believe some Dell XPS series laptops had issues getting into deep sleep states with certain performance schemes runnning or something. It's certainly not unheard of for "gaming enhancement" softwares to cause such issues.

    EDIT:

    Also @MacHater did you follow this guide where it counts? I see you are runnign on a 240Hz screen, did you enable the "Power Savings" and "Self Refresh" options for your iGPU?

    upload_2019-6-22_17-53-53.png

    I'm not sure if having 4x the refresh rate has anything to do with it or not, but it seems plausible it could keep your CPU from being able to rest as easily as mine. Also, when is the last time you updated all your drivers and your BIOS?

    And, I know you swapped from Intel RST raid to AHCI boot mode, but have you tried switching the driver to NVMe drivers and completely disabling Intel RST?

    It's beginning to seem that starting with a clean vanilla install would be easiest / best solution all around to rule out certain things, but it sure would suck if it didn't end up solving your issues.
     
    Last edited: Jun 22, 2019
  3. MacHater

    MacHater Notebook Evangelist

    Reputations:
    146
    Messages:
    364
    Likes Received:
    10
    Trophy Points:
    31
    They're all showing as "Very Low". Like I said, I did this test with absolutely nothing running, not even Chrome. And no matter what combination of settings and drivers in AHCI mode, it was consistently performing (power consumption wise) much worse than in the previous mode "RAID On". I switched it back to "RAID On" in the BIOS, and the power consumption went back down to 1.1W from 1.7W.

    I don't see any special power profiles or anything like that. It's just balanced.
     
  4. Maleko48

    Maleko48 Notebook Evangelist

    Reputations:
    185
    Messages:
    673
    Likes Received:
    503
    Trophy Points:
    106
    See my edit on my previous response to you. What is your total process count in Task Manager under the performance tab?

    EDIT:

    Here is my Device Manager:

    upload_2019-6-22_18-8-0.png


    upload_2019-6-22_18-9-8.png


    upload_2019-6-22_18-10-0.png

    SEE HERE:

    https://www.dell.com/community/Lapt...AID-ON-Storage-Drivers-M-2-Lanes/td-p/5072571
     
    Last edited: Jun 22, 2019
  5. MacHater

    MacHater Notebook Evangelist

    Reputations:
    146
    Messages:
    364
    Likes Received:
    10
    Trophy Points:
    31
    72 background processes, most not using any CPU % at all. Most of them are just Windows services. There's about 3-4 DELL/Alienware specific software, again not using any CPU %.
     
  6. Maleko48

    Maleko48 Notebook Evangelist

    Reputations:
    185
    Messages:
    673
    Likes Received:
    503
    Trophy Points:
    106
    They don't necessarily have to be consuming CPU cycles to prevent the deeper sleep states. It's got to be a technical setting or a bad driver somewhere. If your newly installed drive is blank, you could use Partition Wizard Free to clone your primary SSD over to it as a backup then perform a clean Win10 install on your main SSD and see if there is any improvement. Worst case scenario, you just clone your backup back over to your primary SSD and continue troubleshooting.

    I assume you are on a GPT UEFI install correct? Did you try reinstalling the NVMe specific AHCI drivers for your system? Or have you tried using Samsung's NVMe drivers perhaps?

    Also, did you try setting your power settings like this (including the NVMe Idle Timeout since both of your drives are NVMe based)?:
    upload_2019-6-22_18-41-46.png

    In my BIOS I have the following set:
    20190622_181846.jpg 20190622_181921.jpg 20190622_181947.jpg

    EDIT:

    Also, have you tried completely uninstalling the Alienware specific software (I am assuming you have Alienware Command Center)? And have you went to Intel's website and tried doing a manual driver check and update using their utility?

    EDIT EDIT:

    http://forum.notebookreview.com/thr...trol-of-the-i7-8750h-advanced-version.823065/
     

    Attached Files:

    Last edited: Jun 22, 2019
  7. MacHater

    MacHater Notebook Evangelist

    Reputations:
    146
    Messages:
    364
    Likes Received:
    10
    Trophy Points:
    31
    @Maleko48 I have tried every possible combination short of a clean install, which I feel is absolutely overkill. I barely touched this machine as I just got it not too long ago, and it shouldn't need this thorough of adjusting to get it working as intended, correct? All I did was install the latest drivers possible, and Steam, Origin, some games (I don't have any of these running at startup, nor when I'm doing power consumption testing), as well as the Intel NVMe drive. Latest Windows Updates, running on 1903. And of course, the 140.6mV undervolt in ThrottleStop.

    And until someone else with an 8750H shows what idle wattage is like, for all I know this could be working as intended already. After all, it has more cores and threads than both the 7700HQ and 8550U. However, the article mentioned that "H / HQ", 4th gen and higher CPUs should be idling under 1W, otherwise "there could be problems", which is what raised eyebrows for me and hence asking on here.

    The OS is bare bones stock, yes it's UEFI mode with GPT partition, Secure Boot enabled.

    I don't have any Samsung drives in this machine. SK Hynix != Samsung
     
    Last edited: Jun 22, 2019
  8. Maleko48

    Maleko48 Notebook Evangelist

    Reputations:
    185
    Messages:
    673
    Likes Received:
    503
    Trophy Points:
    106
    I wouldn't be as concerned with the actual wattage as I would be with the fact that the C7 package state is not being used. That right there is the primary indicator that your modern system is not operating as efficiently as it could. While it is idling at a decently low level considering it has extra cores and performance per core compared to my CPU while using the same 14nm process technology, I suppose there is not a ton being left on the table, but it would drive me crazy personally. A clean vanilla Windows 10 install is well worth the time and trouble on a newly acquired system imo. Factory installs are garbage.

    In general, NVMe drivers are interchangeable and can be forced with manual driver swaps / installs if you know what you are doing, though I really don't know if that would solve your troubles. You could try asking some people from that MSI thread with the 8750H I put in my edit edit above.
     
  9. Vasudev

    Vasudev Notebook Nobel Laureate

    Reputations:
    6,892
    Messages:
    10,251
    Likes Received:
    7,524
    Trophy Points:
    931
    Please click on Turn ON button to activate TS. Uncheck C1E and Speedstep. Check off Speedshift and apply correct value. 80 means on demand aggressive clock speeds, 0 max performance all the time, 180 and above is battery saver mode which also turns off turbo boost, so if you want turbo use 150 to boost the cpu clocks between 2.8-3.5GHz on all cores which depends on CPU model. I only have 6700HQ, so it boost to 3.1GHz on all cores only.
     
    Maleko48 likes this.
  10. MacHater

    MacHater Notebook Evangelist

    Reputations:
    146
    Messages:
    364
    Likes Received:
    10
    Trophy Points:
    31
    I tried installing a clean install to a separate partition just to see what happens...and it's not looking good:
    [​IMG]

    Still stuck in C3.

    I read somewhere that this could be caused by a bugged BIOS and only a BIOS update can fix it. I did see others with an 8750H report idle wattages in the 0.5W range so mine is definitely a tad high.
     
    Last edited: Jun 24, 2019
    Maleko48 likes this.

Share This Page