[Guide] How to take full control of the i7-8750H (Advanced version)

Discussion in 'MSI' started by hackness, Sep 19, 2018.

  1. bryneb

    bryneb Notebook Consultant

    Reputations:
    9
    Messages:
    247
    Likes Received:
    43
    Trophy Points:
    41
    If you update the bios, do you have to redo the settings?
     
  2. hackness

    hackness Notebook Virtuoso

    Reputations:
    1,227
    Messages:
    2,312
    Likes Received:
    385
    Trophy Points:
    101
    Yes, also it's recommended to revert all settings back to default before updating the BIOS.
     
  3. Divinated

    Divinated Notebook Geek

    Reputations:
    5
    Messages:
    82
    Likes Received:
    26
    Trophy Points:
    26
    You should incorporate Process Lasso into your guide. That program helps A LOT, not just for battery conservation but performance as well.

    Also, the speed shift setting in BIOS uses an absolutely different scheme then the OS/Software speed shift version. The hardware version also needs to be configured in the BIOS under P-Sates. Its just completely different, i would just recommend having the speed shift start up with throttle stop, as setting speed shift enabled in BIOS without configuring P-States kept my laptop at max turbo even on idle.
     
    Last edited: Apr 16, 2019
    Maleko48 and Kevin@GenTechPC like this.
  4. hackness

    hackness Notebook Virtuoso

    Reputations:
    1,227
    Messages:
    2,312
    Likes Received:
    385
    Trophy Points:
    101
    About the Lasso, I use it mainly to set the CPU Affinity and Prioritizing the program, it does provide an easier monitoring view, as I already took care of the Core Parking in Windows, I didn't bother using the Core Parking feature came with Lasso. So, up to now I'm still not sure which part of the Lasso software should I pull into the guide.

    About the speed shift keeping your CPU at max multiplier, which power plan were you on? Balanced plan with slider or High performance plan without the slider?
     
    Maleko48 likes this.
  5. Pepillo

    Pepillo Notebook Guru

    Reputations:
    7
    Messages:
    67
    Likes Received:
    40
    Trophy Points:
    26
    32GB 2400MHz -> 3467MHz @1.30V 20-20-20-49 (OC'd using Stock RAM!!) |

    How is it done to overclock the ram?

    Thanks
     
  6. Divinated

    Divinated Notebook Geek

    Reputations:
    5
    Messages:
    82
    Likes Received:
    26
    Trophy Points:
    26
    It was months ago, i was on balance with the slider. I don't see any point in making a custom power plan since im going to keep the slider on high performance. I've used lasso to limit cpu affinity of every process to cores 2, 4, 6 and their threads. It's a mediocre way to solve my thermal issue for now. The cost to send this for another RMA and replace the heatsink are entirely the same. Not just that, im starting to get slight blacklight bleed on the monitor anyway. Previous RMA was sent in and received back the next week for a full motherboard and memory module replacement. Heck, that's way easier then repasting/replacing the heatsink myself lol.
     
  7. hackness

    hackness Notebook Virtuoso

    Reputations:
    1,227
    Messages:
    2,312
    Likes Received:
    385
    Trophy Points:
    101
    OCing the RAM will raise the temperature of the nearby area for a few degrees.

    /////////////////////////WARNING!!///////////////////////////
    I do not take any responsibility if anything happens.
    You are on your own risk for doing this.

    /////////////////////////WARNING!!///////////////////////////

    ===========Chapter 1:unlocking the Over Clocking menu in the BIOS=============

    Go to Advanced > OverClocking Performance Menu

    Set OverClocking Feature to Enabled.

    ===========End of Chapter 1============

    ===========Chapter 2: Test if CMOS clear resets the RAM timings============

    Go to Advanced > OverClocking Performance Menu > Memory Overclocking Menu

    Set Memory Profile to Custom Profile.
    Increase the number of tREFI by 10.

    Save and reboot to see if the number takes effect.

    Now shutdown and hold the power button for 45 seconds.

    Once released, press again to boot up

    Once boot up go into the BIOS menu, go check if RAM timing has been reverted to default but still on custom profile.

    If it does then it means you can clear the RAM settings using the full CMOS reset technique.

    ============End of Chapter 2===========

    ============Chapter 3: Raising Uncore to +125mV============

    Edit: As of 2019/06/20, +125 worked during my testing and has been stable for more than 3 weeks already.

    Memory controller is one of the areas that the the uncore is managing.

    By raising the uncore voltage, your laptop's memory controller will be more stable when running high frequency RAM.

    Uncore is acknowledged as System Agent in the ThrottleStop.

    So once you raise the uncore voltage in the BIOS, you need to boot into Windows and raise the System Agent's voltage to the same offset value to prevent crashing once ThrottleStop is loaded.

    To raise the uncore voltage go to:
    Advanced > OverClocking Performance Menu > Uncore

    Set Uncore Voltage Offset to 125.
    Make sure Offset Prefix is set to "+".

    Now go into Windows and set the System Agent for all your profiles in ThrottleStop to +125mV.

    ============End of Chapter 3=============

    ============Chapter 4: Raising the Frequency to 3467MHz===========

    Edit: As of 2019/06/20, I have been running @3467MHz stable @1.2V for my Samsung RAM for more than 3 weeks already.

    RAM timing research is long and painful, there are many trial and errors

    Thanks to @Johnksss and @Falkentyne for the help during the research.

    This is my RAM's part number:

    SAMSUNG M471A2K43CB1-CRC.PNG

    Here are the parameters:

    If anything goes wrong, hold power button for 45 seconds to clear the RAM timings.

    Please note that you can push tREFI to 65535 to increase the speed on Read.

    If it doesn't boot, try raising the tRFC by 10~20 and see if it boot. If it doesn't, try raising for more, or you can raise the tCL, tRCD/tRP, tRAS to see if it boots, if the all the timings you have tried are already reaching the max, it means your RAM simply can't run at 3467MHz

    For your own knowledge:

    tRAS = tCL + tRCD/tRP + tRTP

    tCWL:
    Usually =tCL or =tCL-1

    tREFI:
    Larger RAM size will need more frequent recharge, setting this one too high may cause constant freezing.

    tRFC:
    Setting this one too low will cause the laptop not being able to boot.

    tWR:
    Remember that tWR is always twice more than tRTP, if you set it less you will have high chances getting black screen.

    If you see any blue screen or error it means your tRFC timing is too tight.

    If you see any Freezing it means your tREFI is too loose.

    3467-1.3V-20-20-49-20-26-52782-674-9-18 Run Stable.jpg

    Now go get some memory testing tools to test and see if you can pass their tests without any errors.

    =============End of Chapter 4=============

    Good luck fellow members!

    The Balance plan with slider actually break the behavior of the CPU. By setting to High performance on the slider you are forcing your CPU to run at the highest frequency. That slider is called cancer slider by many of our forum members. Using the high performance plan (Not the slider) is to simply avoid the slider from affecting our tweaks.
     
    Last edited: Jun 19, 2019
    thefatapple, Maleko48 and Pepillo like this.
  8. Pepillo

    Pepillo Notebook Guru

    Reputations:
    7
    Messages:
    67
    Likes Received:
    40
    Trophy Points:
    26
    Thank you. I was looking to buy some faster memory modules and you have saved me a lot of money, time, and headaches by disassembling and praying to be compatible.

    The guide is good and is very well explained, it has been easy for me.

    I have searched for the maximum without touching voltages, anyway my modules are Hynix and not Samsung like yours, they tend to climb less.

    From 2,666 Mhz to 3,000 Mhz I was able to climb without problems. Anything greater did not start the bios. The timmings I have been able to keep the same, if I downloaded them I have blue screen on the Ramtest I use to check stability. I was able to put them to 1T instead of 2T and increase the tREFI to 52782. The result is very satisfactory, before:

    [​IMG]

    After:

    [​IMG]

    In addition to the stress tests of Aida and Ramtest, I have been playing several hours with total stability and a remarkable improvement, the increase in the speed of the Ram is noticeable, without a doubt.

    Seriously, thank you very much, I am very happy with the improvement. After having solved the Thermal Throttling of the CPU with Conductonaut and undervolting, and having increased the performance of the 2080 Max-Q with the bios of 90W, the increase in the speed of the RAM was what I needed to round the machine. :)
     
    hackness likes this.
  9. hackness

    hackness Notebook Virtuoso

    Reputations:
    1,227
    Messages:
    2,312
    Likes Received:
    385
    Trophy Points:
    101
    Result is great, glad it worked out!
     
    Pepillo likes this.
  10. Divinated

    Divinated Notebook Geek

    Reputations:
    5
    Messages:
    82
    Likes Received:
    26
    Trophy Points:
    26
    Rather then change the “Processor energy performance preference policy” which changes performance settings when the operating system is in "Autonomous Mode" (AKA Speed shift). Why not turn Autonomous mode off all together?
    power state.png
     
Loading...

Share This Page