[GUIDE] Fix for Jittery display AMD cards!

Discussion in 'Alienware 18 and M18x' started by Sentinel196, Dec 9, 2011.

Thread Status:
Not open for further replies.
  1. Sentinel196

    Sentinel196 Notebook Evangelist

    Reputations:
    245
    Messages:
    309
    Likes Received:
    7
    Trophy Points:
    31
    Hi all,

    I just thought I'd share with you the solution I have found for issues with a jittery screen when looking around the field of view in-game. Tested on an M18x with dual 6990m cards in CrossfireX mode, but should apply to pretty much any PC with current generation AMD cards.

    This method assumes that your PC setup is sufficient to supply a higher frame rate than your monitor's refresh rate. If it doesn't chances are you don't have this issue anyway.

    For an example of what I mean, look here...

    Many people have reported the issue in Battlefield 3. But I was having the same issue in varying degrees in all FPS games including BF3 and MW3. Aafter trying hundreds of conbinations of settings, the following method works best for me.

    1. Download and install 'RadeonPro' and reboot your computer.

    2. Open 'RadeonPro' and in your global profile, under the advanced tab, set 'Flip Queue Size' to '5'.

    3. Under the 'Visual' tab, set V-Sync to 'Off, unless application specifies'.

    4. Click on 'Save Changes'

    5. Go to 'Settings' and set RadeonPro to boot with Windows and Minimised.

    5. In the game video settings, set V-Sync off. [/B](There will be a small amount of screen tearing depending on the refresh rate of your monitor and Frame Rate, but overall gameplay is smoother).

    Enjoy jitter free gaming!

    How does it work? I'm not exactly sure, it almost seems counterintuitive, but I think that by increasing the number of frames rendered ahead of time and disabling V-Sync, the monitor is able to display a video feed as close to realtime as possible without the frame rate matching the refresh rate exactly. This in turn means less frames are skipped by the monitor.

    Think of it as similar to the way a PAL DVD or Blu-ray player repackages a 30FPS NTSC video stream for playback on a PAL monitor.

    Hope this helps and please post your feedback. I'm happy to stand corrected if others don't succeed with this method.
     
  2. Mr. Fox

    Mr. Fox BGA Filth-Hating Elitist

    Reputations:
    30,328
    Messages:
    35,736
    Likes Received:
    57,769
    Trophy Points:
    931
    Nice! Thanks for sharing your tip.
     
  3. katalin_2003

    katalin_2003 NBR Spectre Super Moderator

    Reputations:
    14,953
    Messages:
    5,670
    Likes Received:
    1,503
    Trophy Points:
    331
  4. weinstein888

    weinstein888 Notebook Evangelist

    Reputations:
    73
    Messages:
    308
    Likes Received:
    0
    Trophy Points:
    30
    Finally a solution. +rep
     
  5. Mr. Fox

    Mr. Fox BGA Filth-Hating Elitist

    Reputations:
    30,328
    Messages:
    35,736
    Likes Received:
    57,769
    Trophy Points:
    931
    Bump.... This information might come in handy for 7970M CrossFire owners. I forgot about it and may give it a shot... it helped the 6900M series work better.
     
  6. dr_gin_rain

    dr_gin_rain Notebook Consultant

    Reputations:
    4
    Messages:
    198
    Likes Received:
    18
    Trophy Points:
    31
    it doesn't work for me. I still got screen tearing in BF3. Any ideas?
     
  7. Mr. Fox

    Mr. Fox BGA Filth-Hating Elitist

    Reputations:
    30,328
    Messages:
    35,736
    Likes Received:
    57,769
    Trophy Points:
    931
    The fix that was being demonstrated in this thread was jittery behavior, which is not the same problem as screen tearing.

    Have you installed the latest CAP profile? What driver are you using? I had very bad screen tearing in BF3, Batman Arkham Asylum and Arkham City using 12.5 beta and 12.6 mobilitu. Catalyst 12.7b and CAP2 seems to have helped that quite a bit.
     
  8. dr_gin_rain

    dr_gin_rain Notebook Consultant

    Reputations:
    4
    Messages:
    198
    Likes Received:
    18
    Trophy Points:
    31
    I have catalyst 12.8 and 12.7 CAP 3.

    By the way, is there anyway to fix mouse lag if vsync is on ?
     
  9. Mr. Fox

    Mr. Fox BGA Filth-Hating Elitist

    Reputations:
    30,328
    Messages:
    35,736
    Likes Received:
    57,769
    Trophy Points:
    931
    Well, vsynch being enabled often causes mouse lag. I don't think there is a way to correct this in CCC like there is in the NVIDIA Control Panel. CCC is not very sophisticated or robust with settings like NVCP.

    Did you already try what was suggested in the YouTube video comments for the command to be entered in the BF3 console?

     
  10. dr_gin_rain

    dr_gin_rain Notebook Consultant

    Reputations:
    4
    Messages:
    198
    Likes Received:
    18
    Trophy Points:
    31
    Thanks a lot Fox..This is awesome..it works :D
     
Thread Status:
Not open for further replies.

Share This Page