GT75VR 7RF USB 3.0 Problems

Discussion in 'MSI' started by 82280zx, Oct 6, 2019.

  1. 82280zx

    82280zx Notebook Guru

    Reputations:
    7
    Messages:
    74
    Likes Received:
    18
    Trophy Points:
    16
    I have a Elegato HD60 S I want to use to play / capture my switch on my laptop, I know the Elegato works at home on my desktop machine but when I plug it in on my MSI (Tried all usb ports) it says it requires a USB 3.0 Port... I thought this had 3-5? All the USB jacks are Blue so shouldn't they all be 3.0? I noticed it is using the Microsoft driver for usb 3.0 but I haven't been able to locate any others for it? Anyone run into this?
     
  2. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    964
    Messages:
    8,208
    Likes Received:
    2,004
    Trophy Points:
    331
    You shouldn't need to worry about driver itself with Windows 10 since its driver support is native.
    Have you tried a different port? What about Windows Updates?
     
  3. 82280zx

    82280zx Notebook Guru

    Reputations:
    7
    Messages:
    74
    Likes Received:
    18
    Trophy Points:
    16
    I figured out the problem, I had a usb c cable that wasn't 3.0 capable and it was forcing the capture card into 2.0 and not working, thanks though!
     
    Kevin@GenTechPC likes this.
  4. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    964
    Messages:
    8,208
    Likes Received:
    2,004
    Trophy Points:
    331
    Wow, great. Is that USB C cable certified to run at USB 2.0?
     
Loading...

Share This Page