Gsync and battlefield 4

Discussion in '2015+ Alienware 13 / 15 / 17' started by gschneider, Jul 17, 2017.

  1. gschneider

    gschneider Notebook Evangelist

    Reputations:
    233
    Messages:
    472
    Likes Received:
    121
    Trophy Points:
    56
    Hi guys,

    I am being retarted but how do I get Gsync to work in battlefield 4?

    I don't have V-sync on, I have Gsync on for full screen and windowed mode. All my settings are set by Geforce Experience, (sets resolution scaling to 150%).

    I have no idea why I still get savage tearing?

    Thanks all
     
  2. eadgar

    eadgar Notebook Consultant

    Reputations:
    0
    Messages:
    111
    Likes Received:
    13
    Trophy Points:
    31
    I had a similar thing with Civ 5, it has something to do with more frames being rendered than the screen can display, so G-Sync turns off. The solution was to keep V-Sync off in game settings, but force it on in nVidia Control Panel. Not sure whether it would apply to BF4.
     
  3. Galm

    Galm "Stand By, We're Analyzing The Situation!"

    Reputations:
    990
    Messages:
    5,359
    Likes Received:
    2,618
    Trophy Points:
    331
    GSync can't work if you get more fps than your screens refresh rate.

    So @eadgar this is for you too.

    You need to get a different program to cap your fps just below. So if it's a 60Hz monitor try like 57-58, if it's 144Hz try like 138-140. That forces GSync on.
     
Loading...

Share This Page