GIGABYTE Control Center Smart Utilities Fixed

Discussion in 'Gigabyte and Aorus' started by msing539, Aug 16, 2019.

  1. msing539

    msing539 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I've had an Aero 15-X9 for a few months--shortly after I wiped and installed Windows, Control Center stopped showing me driver updates--meaning it was just blank. Fan control and fusion continued to work, but it was a pain figuring out if I had the latest drivers. I tried uninstalling and reinstalling different versions repeatedly, to no avail, including 19.07.24.02. This later version also disabled X-Rite, probably because I pulled it from the Aorus driver page since I couldn't update to that version through Smart Utilities.

    Today, I finally got Control Center working again on v19.06.12.01

    In my case, I ran my machine wired through a Plugable USB docking station. First problem was that wired connection, and switching to WiFi was part of the solution. Not sure why, but the LAN over USB could have been part of the issue.

    Then I added exceptions for C:\Program Files\ControlCenter\ShowAP.exe and ControlCenter.exe in Windows Firewall. And excluded that main folder from AntiVirus.

    Finally, I made sure FusionStartUp was enabled on boot. Switching back to my wired connection stops drivers from showing up.

    Control Center started working only after I rebooted twice--once after the initial install, and again after I made the above changes.

    Also, another thing to note is that Intel XTU now comes bundled with the system manager. I could not get Control Center to start if I disabled the XTUOCDriverService.

    Hope this helps someone.
     
    Last edited: Aug 16, 2019
Loading...

Share This Page