Gigabyte Aero 15xv8 - HID Evolution

Discussion in 'Gigabyte and Aorus' started by Jaxom, Apr 1, 2020.

  1. Jaxom

    Jaxom Notebook Enthusiast

    Reputations:
    22
    Messages:
    24
    Likes Received:
    13
    Trophy Points:
    6
    Hi all,

    So two years ago (nearly to the date) I bought a Gigabyte Aero15cxv8 and had no issues up until two months ago (February). The laptop randomly died and would just not turn on.

    This February I sent the Laptop to HID Evolution, who could not figure out what was wrong with it and sent it to Gigabyte, Gigabyte then stated they needed a new motherboard and had to wait for shipment in regards to the part. So we wait around 4 weeks Gigabyte receive the motherboard and send it back to HID (who test it) and HID ship it back to me. So it's been 6-8 weeks since I sent this laptop to get fixed...

    I received the laptop earlier today unpack it try to turn it on and nope nothing... two lights turn on but there is no battery light. Sure I'm pissed of at Gigabyte, but for HID to have been told it's tested and working and then given a laptop which is not working at all is just ridiculous.
     
  2. Jaxom

    Jaxom Notebook Enthusiast

    Reputations:
    22
    Messages:
    24
    Likes Received:
    13
    Trophy Points:
    6
    Update: I flipped my laptop over and now it works?.... what also had to push the hdmi cord a bit to get it to read on my monitor. Maybe the delivery man dropped the damn thing? :(:(:(:(
     
Loading...

Share This Page