Gigabyte Aero 15 - Windows 10 Setup and Tweeks Guide

Discussion in 'Gigabyte and Aorus' started by TitaniumO, Jan 30, 2018.

  1. TLCH723

    TLCH723 Notebook Consultant

    Reputations:
    2
    Messages:
    141
    Likes Received:
    13
    Trophy Points:
    31
    @tcharette Read this

     
  2. g85222456

    g85222456 Company Representative

    Reputations:
    27
    Messages:
    205
    Likes Received:
    38
    Trophy Points:
    41
    you could go to the control center > power option and check if the sleep or hibernate mode is activated:
    https://www.pcworld.com/article/307...nate-option-to-the-windows-10-start-menu.html
     
  3. g85222456

    g85222456 Company Representative

    Reputations:
    27
    Messages:
    205
    Likes Received:
    38
    Trophy Points:
    41
    Exactly the function key will work after the installation of Smart Manger
     
  4. Joseph Kim

    Joseph Kim Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    I downloaded the precision drivers as instructed but it does not include palm rejection, so when I type, the aero 15's bad trackpad placement gets in the way. How can I fix this? I tried downloading an app called touchpad blocker but that blocks my mouse as well, which means I cant game.
     
  5. rooney111

    rooney111 Notebook Enthusiast

    Reputations:
    0
    Messages:
    39
    Likes Received:
    2
    Trophy Points:
    16
    Wait, so there is at least 1 benefit for having the ELAN drivers and that is "palm rejection" ? I cannot seem to find any settings under WIndows Precision touchpad to adjust/turn on/off palm rejection.
     
  6. Ollie222

    Ollie222 Notebook Consultant

    Reputations:
    3
    Messages:
    175
    Likes Received:
    5
    Trophy Points:
    31
    I too have looked for this as the mouse not responding on small movements is very annoying but I don't think it exists
     
  7. gnlu26

    gnlu26 Notebook Consultant

    Reputations:
    31
    Messages:
    123
    Likes Received:
    48
    Trophy Points:
    41
    I really hate the palm rejection for the elan driver because it introduces a lot of delay before I can use my mouse. Precision driver's DO have a sort of palm rejection, but it's a pain to change the settings and it works differently. A naive rejection approach turns off the pad when the keys are being pressed, and then enables them after a time has expired. Like the elan driver, this lowers the responsiveness of the touchpad and may hinder the user experience. Instead, Microsoft creates a "curtain," regions of high sensitivity and low sensitivity for when you are using the keyboard. These regions ARE user adjustable, but apparently only in the registry.

    To adjust these settings, check out the Microsoft page here. You want to look under "non-curtain region sizing."

    I'm going to guess these settings aren't exposed to a user because it's assumed the laptop maker set them for their machine. Since we are downloading the driver's from other OEMs, that could be part of the issue.

    TL;DR rejection exists, the settings are in the registy
     
  8. Zengusan

    Zengusan Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5

    Tried the default values but still no sign of rejecting the palm. I have another laptop that comes pre-installed with the precision driver and the palm rejection is excellent. If you slide your palm over the trackpad, the mouse won't move a bit.
     
Loading...

Share This Page