Gigabyte Aero 14K underforming... Any solution?

Discussion in 'Gigabyte and Aorus' started by EORUCIGN, Jan 29, 2018.

  1. EORUCIGN

    EORUCIGN Notebook Consultant

    Reputations:
    10
    Messages:
    214
    Likes Received:
    78
    Trophy Points:
    41
    Hi guys, I recently bought Aero 14K from ExcaliburPC, and so far I really like the laptop. However, whenever I play Overwatch, it seems like the performance does not match with the specs.

    GTX 1050ti
    i7-7700HQ
    16gb of ram (SIngle channel)
    256gb SSD

    my gaming set up is

    Mouse
    Keyboard
    2k 144hz G-sync monitor through display port.

    My overwatch setup is
    FHD in 144hz @ lowest setting, and I am getting 70 ~ 100 fps in game.

    I DON'T THINK that I should get 70 ~ 100fps @ lowest setting with GTX1050ti. Can you guys guess any solution? I recently received the laptop, so if the problem with the laptop itself, I can always refund or replace it.

    Also, when I watch video on youtube, I sometimes see the green glitch. So I assume it is the graphics card's problem.
     
  2. Svegetto

    Svegetto Notebook Evangelist

    Reputations:
    35
    Messages:
    317
    Likes Received:
    135
    Trophy Points:
    56
    I don't own the laptop, but that does seem low, I'd expect to see 70-100 fps on 'high' in overwatch, not low at that resolution. I'd probably start by running gpu-z while playing and see what is limiting the gpu (maybe it's a thermal/power issue)
     
  3. BeastsForever.TheDragon

    BeastsForever.TheDragon Notebook Evangelist

    Reputations:
    172
    Messages:
    562
    Likes Received:
    383
    Trophy Points:
    76
    What is the HDMI version?

    Hdmi 1.4 sucks at high refreshrate gaming.
     
Loading...

Share This Page