Gateway FX P-7811 Screen Issue

Discussion in 'Other Manufacturers' started by BryanK, Jul 8, 2016.

  1. BryanK

    BryanK Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hi, I'm new to this site and I understand this is about a decade old device, But I was wondering if anyone could help me.

    So my Gateway FX P-7811 laptop has been having screen issues, I can't seem to figure the issue out myself, Whenever I perform a task such as opening a window that may require internet access, or it seems a window that isn't pre-installed with the device causes the screen to go to a random color. So far the colors I've gotten are listed here:

    -Blue (Sky Blue almost)
    -Green
    -Pink
    -Purple

    I have tried many different ways of fixing it whether it be updating drivers or restoring to older versions of drivers, and none of fixed it. I also opened up the back panel to get in there with an air duster to clean it out more, and as expected.. Didn't help. Originally I believed the problem was with the GPU which seemed to be ruled out after the GPU was deactivated and this issue was still happening. I then moved my new culprit, Which was the screen.. And again, ruled that out. So now I'm left with the wireless card, I'm not sure exactly how this would work, but as I'm seeing network tasks seem to be what's causing these screen colors. I also checked everything for loose connections and found nothing loose.

    My specs are listed here:

    -Intel Core 2 Duo P8400 2.26GHz
    -Nvidia GeForce GTS 9800M
    - 4GB DDR3 RAM 1000MHz
    -7200 RPM Western Digital 320 GB HDD
    - Intel WiFi Link 5100 AGN Wireless Card

    If anyone could help me, That would be great!
     
  2. t456

    t456 1977-09-05, 12:56:00 UTC Moderator

    Reputations:
    967
    Messages:
    1,985
    Likes Received:
    1,157
    Trophy Points:
    181
    Try an external monitor; if that works fine then you need a new display cable. If not then it's the gpu. How did you disable the 9800M anyway? The Core 2 Duo doesn't have integrated graphics, so is there another Intel chip on the motherboard?

    Since the issue only occurs when switching windows, it seems a gpu function is kicking in that is no longer function correctly on the card, something like transparency or overlay. Driver rollback to vanilla VGA could rule this out.
     
Loading...

Share This Page