G-sync does not seem to work

Discussion in 'Gaming (Software and Graphics Cards)' started by Mjaaaland, Sep 4, 2016.

  1. Mjaaaland

    Mjaaaland Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    10
    Trophy Points:
    6
    I'm relatively new to this forum, so I'm not sure if this is the right place to ask questions. If it's not, let me know, and I'll delete the post.

    However, I've encountered a tricky problem when it comes to G-Sync. I'm not really a newbie when it comes to computers, but when it comes to the more advanced stuff, I can get lost, which I did now.

    So, I bought this new notebook which is similar/identical to a Clevo P651RP which houses a GTX 1060 and a integrated Intel HD Graphics card. This means I have the disadvantage (in my opinion) to be a part of the Nvidia Optimus technology. The manufacturer and a little sticker on the chassis tells me that I have G-Sync on the monitor. I'm not sure how well G-Sync is meant to perform, but I can tell you - my games tears really bad. I refuse to believe that G-Sync is activated.

    So, I searched for an answer on how to activate G-Sync, and one answer told me to open Nvidia Control Panel, and activate it from there. This is where I encountered another problem. The only tab I have on the Nvidia Control Panel is "3D-options", I can't adjust G-Sync or any other options, because I'm missing the tabs. A bit later I found out that it was because of the Optimus technology. All screen settings are treated within Intel's graphics control panel. Therefor, Nvidia has removed the settings in the Nvidia Control Panel, because it is not needed.

    So my question is this: Given what I've explained, how do I enable G-Sync?

    Additional things I already have tried:

    * Re-install graphics driver
    * Failed to find and option in the BIOS to prioritize my Nvidia card instead of Intel's.
    * Deactivate the Intel card from the device management
    * Run the option in Nvidia Control Panel which runs Nvidia Process with high performance
    * Restarted the computer after doing something (duh)

    Anyone that might have a clue on how to solve this, or to announce that nothing can be done? Many of the things I've tried may sound stupid for someone, but I really have no clue how to fix this :vbrolleyes:
     
    Last edited: Sep 4, 2016
  2. HTWingNut

    HTWingNut Moo

    Reputations:
    21,551
    Messages:
    35,315
    Likes Received:
    9,553
    Trophy Points:
    931
    G-Sync will not work with Optimus. With Optimus enabled, you will have limited control over Nvidia GPU as you have found.

    If the machine says it supports G-sync then there is likely a way to turn off Optimus, which would require a reboot, and then it would switch directly to using only your Nvidia GPU (GTX 1060).

    Likely in the BIOS or something in Clevo Control Center (press Fn+Esc to bring it up - it may come up minimized but should see icon on taskbar).
     
    Phoenix likes this.
  3. myx

    myx Notebook Deity

    Reputations:
    223
    Messages:
    1,006
    Likes Received:
    85
    Trophy Points:
    66
    I do believe that latest nvidia drivers need vsync to be activated in order to (also) activate gsync. I will try to find the source where I read this.
     
  4. Templesa

    Templesa Notebook Deity

    Reputations:
    172
    Messages:
    801
    Likes Received:
    241
    Trophy Points:
    56
    I encountered a similar issue with my P670RS-G - the setting is indeed in BIOS. You have to change over to nVidia GPU only. If the option isn't there, your laptop may not have G-Sync. I believe the model has -G at the end of it if it does have G-Sync.
     
  5. Mjaaaland

    Mjaaaland Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    10
    Trophy Points:
    6
    Thanks for answers!

    I could not find a way to disable Optimus. I searched in the BIOS and the Clevo Control Center, but was not lucky. If anyone knows how to turn off Optimus, I would like to know :)

    I'm a bit unsure what you meant by this. You mean I have to activate V-sync manually, and then G-sync may start working? If you should happen to find the source, I'm interested in seeing it!

    Do you know where in the BIOS the setting is located? My BIOS has very few configurations, at least compared to a desktop PC I owned before, so there is not much to go over. My model number says P651RP, but the product code says P651RP6-G, so I do believe it is supposed to have G-Sync :)
     
    Last edited: Sep 4, 2016
  6. Templesa

    Templesa Notebook Deity

    Reputations:
    172
    Messages:
    801
    Likes Received:
    241
    Trophy Points:
    56
    Restart > Press F2 to get into BIOS > Advanced Tab > Advanced Chipset Control > MSHybrid or DISCRETE Switch > DISCRETE
    After that I was able to open Nvidia Control Panel and select G-Sync for Fullscreen when booted into Windows.
     
  7. Mjaaaland

    Mjaaaland Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    10
    Trophy Points:
    6
    Thanks, that actually worked! I was able to activate G-Sync, so it should be working now. I still see some tearing, but it's much less then what it was (at least I think so). The screen tends to stutter a bit after the changes, but that's a problem not related to this topic, so I'll leave that for now. I'll probably keep the changes and see how it goes :)

    One more thing, is the Intel HD Graphics totally disabled now?
     
    Templesa likes this.
  8. Templesa

    Templesa Notebook Deity

    Reputations:
    172
    Messages:
    801
    Likes Received:
    241
    Trophy Points:
    56
    Yes it should be. I don't think you can even install a driver for it in this mode. I have all the settings available to me that my desktop 1070 has on my 'mobile' 1070 has in the discrete mode. It will be a lot better with the tearing in-game that just on the desktop since most things don't run in true full-screen. You may want to switch to Fullscreen + windowed mode for G-Sync and see if that helps desktop performance.

    Oh and the other thing I've noticed that affects stutter (since I hate it so much as well) is battery boost mode in the nvidia GeForce settings (not control panel) if your laptop isn't plugged in. It limits the discrete to 30fps. Try plugging it in or disabling it.
     
    Last edited by a moderator: Sep 6, 2016
  9. edumazieri

    edumazieri Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hello,

    Sorry to bring up an old topic but perhaps someone here can shed some light in my problem.

    I have a MSI GE72 2QC laptop with a GTX 970M which supposedly supports G-Sync. But I have no option on my Nvidia panel as well, probably because of the Intel integrated. But, I have no option to change that in my BIOS. Anyone with a similar setup can tell me if they found a solution?
     
  10. saturnotaku

    saturnotaku Notebook Prophet

    Reputations:
    3,185
    Messages:
    6,397
    Likes Received:
    1,628
    Trophy Points:
    331
    There should be a button near the keyboard that switches between Optimus (Intel/NVIDIA) and the dedicated GPU. G-Sync won't work when the system is in automatic switching mode.
     
Loading...

Share This Page