Force to use iGFX by default in Windows 10 on all apps

Discussion in 'Windows OS and Software' started by swenak, Jul 5, 2021.

  1. swenak

    swenak Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Because of known Optimus problems and because I cant in nVidia Controll panel set iGFX as default (now this is in Windows graphics settings, but only per app), I'm trying to adding apps in windows graphics settings and set to use iGFX. It seems, that this work, so, when I add explorer.exe, SystemSettings.exe and so, system not lagging so much. So, question is: Can I force to use Windows and all aps to use iGFX and only when I set to use dGPU on app, only this app will use dGPU? Now, it seems, that default is "windows decide".

    Thanks

    EDIT: Graphics settings store apps and settings here:

    [HKEY_CURRENT_USER\SOFTWARE\Microsoft\DirectX\UserGpuPreferences]
    "C:\\Program Files (x86)\\Razer\\Razer Services\\Razer Central\\Razer Central.exe"="GpuPreference=1;"
     
    Last edited: Jul 5, 2021
  2. swenak

    swenak Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    As I test, it seems, that only one app (from that I using) cant now be forced to use only iGFX, it is ntoskrnl.exe and as I can see, this is known problem app (especialy CPU usage problems). This app creating that GPU "spikes" from iGFX to dGPU and back and windows for second freeze at same time.
     
  3. swenak

    swenak Newbie

    Reputations:
    0
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Now I testing Windows 11 and Windows freezing is gone, it seems, that this was solved.
     
  4. Tech Junky

    Tech Junky Notebook Deity

    Reputations:
    222
    Messages:
    859
    Likes Received:
    331
    Trophy Points:
    76
    I was going to suggest disabling the other GPU to force the iGPU to be used.

    When I try to disable the iGPU to prefer using dGPU I end up seeing stuttering / performance issues as Windows doesn't like it when that happens. Funny / Odd that your situation is complete opposite preferring the iGPU. Sounds like a patch was released if your issue got resolved.

    There are definitely some quirks within Windows overall no matter 10 or 11 regarding drivers in the last 12 months or so. I had one issue that caused spontaneous reboots several times a day appearing to be a power issue from the event logs but, truly being a driver issue instead since it persisted with a new power supply and went away when switching to Linux for a couple of days. I used to have a display issue if I let the screensaver kick in while a tab was open running flash the screen wouldn't wake and required a reboot.

    Sometimes the issue you're having might not be as straight forward as you might think.
     
Loading...

Share This Page